Contribute
Register

[help] I can't use Samsung NVMe SSD on Mojave 10.14 Kernel panic !

Joined
Jan 7, 2014
Messages
50
Motherboard
Lenovo Legion y7000p-1060 - Clover
CPU
i7-8750H
Graphics
UHD 630 / GTX 1060
Mac
MacBook Pro
Mobile Phone
Android
Hi,
I followed the guide to install Macos on Laptop with Clover by Rehabman.
so far I fixed brightness and Usb 3.0 and battery.
I still need to fix touchpad and audio. have not tried anything yet .
The main issue is I can't use the booted system when I have the SSD plugged in .
my ssd is Samsung model : MZ-VLB5120 PCIe NVMe
although I read that from 10.13+ it's not necessary to patch anything for Samsung . I tried all methods to patch the IONVMeFamily with older patches, but always KP.
it works for a while and reboot
I get this message after login again :
Code:
Anonymous UUID:       A931BB94-EB47-B553-E41E-24BDFFBF7FA1

Tue Nov  6 17:19:25 2018

*** Panic Report ***
panic(cpu 0 caller 0xffffff7f89e4a5a8): nvme: "Fatal error occurred. CSTS=0x1
. FW Revision=4L1QEXA7\n"@/BuildRoot/Library/Caches/com.apple.xbs/Sources/IONVMeFamily/IONVMeFamily-387.201.1/IONVMeController.cpp:5307
Backtrace (CPU 0), Frame : Return Address
0xffffff9206dcba10 : 0xffffff80077aca1d
0xffffff9206dcba60 : 0xffffff80078e6b13
0xffffff9206dcbaa0 : 0xffffff80078d859a
0xffffff9206dcbb10 : 0xffffff8007759ca0
0xffffff9206dcbb30 : 0xffffff80077ac437
0xffffff9206dcbc50 : 0xffffff80077ac283
0xffffff9206dcbcc0 : 0xffffff7f89e4a5a8
0xffffff9206dcbe20 : 0xffffff8007e5da67
0xffffff9206dcbe90 : 0xffffff8007e5d989
0xffffff9206dcbec0 : 0xffffff80077e8865
0xffffff9206dcbf40 : 0xffffff80077e8415
0xffffff9206dcbfa0 : 0xffffff80077590ce
      Kernel Extensions in backtrace:
         com.apple.iokit.IONVMeFamily(2.1)[26E33FBA-73DC-3D8A-AA62-16A25FA97C8A]@0xffffff7f89e36000->0xffffff7f89e74fff
            dependency: com.apple.driver.AppleMobileFileIntegrity(1.0.5)[169BD129-26C1-32E2-82A5-B5E0C1FA99B4]@0xffffff7f885a7000
            dependency: com.apple.iokit.IOPCIFamily(2.9)[2CE7BCB3-0766-3A94-A8D4-29BF3EBAEFBC]@0xffffff7f88095000
            dependency: com.apple.driver.AppleEFINVRAM(2.1)[D872C3C2-611A-3BE6-B3A0-DC8B1A6795F8]@0xffffff7f8873c000
            dependency: com.apple.iokit.IOStorageFamily(2.1)[499E27C9-AC4D-3239-9FC4-754C7699FA76]@0xffffff7f883a6000
            dependency: com.apple.iokit.IOReportFamily(47)[EA2822EA-DACE-34D1-80D1-8EBF65889EBC]@0xffffff7f88bf3000

BSD process name corresponding to current thread: kernel_task
Boot args: nv_disable=1 dart=0 -cdfon -igfxnohdmi

Mac OS version:
18A391

Kernel version:
Darwin Kernel Version 18.0.0: Wed Aug 22 20:13:40 PDT 2018; root:xnu-4903.201.2~1/RELEASE_X86_64
Kernel UUID: DF83AD37-501E-3B4F-B1F0-04F3AC90FE35
Kernel slide:     0x0000000007400000
Kernel text base: 0xffffff8007600000
__HIB  text base: 0xffffff8007500000
System model name: MacBookPro15,2 (Mac-827FB448E656EC26)

System uptime in nanoseconds: 562278675673
last loaded kext at 286378279981: com.apple.filesystems.msdosfs   1.10 (addr 0xffffff7f8a5e7000, size 69632)
last unloaded kext at 370911435712: com.apple.filesystems.msdosfs   1.10 (addr 0xffffff7f8a5e7000, size 61440)
loaded kexts:
(none)

EOF
Model: MacBookPro15,2, BootROM 220.200.252.0.0, 6 processors, Intel Core i7, 2.21 GHz, 16 GB, SMC 2.44f1
Graphics: kHW_IntelUHDGraphics630Item, Intel UHD Graphics 630, Built-In
Graphics: Display, PCIe
Memory Module: BANK 0/DIMM0, 8 GB, DDR4, 2667 MHz, Samsung, M471A1K43CB1-CTD
Memory Module: BANK 1/DIMM0, 8 GB, DDR4, 2667 MHz, Samsung, M471A1K43CB1-CTD
Bluetooth: Version 6.0.8f6, 3 services, 19 devices, 1 incoming serial ports
PCI Card: display, VGA-Compatible Controller, Slot-1
Serial ATA Device: ST2000LM007-1R8174, 2 TB
USB Device: USB 3.1 Bus
USB Device: Bluetooth HCI
USB Device: Integrated Camera
USB Device: USB Receiver
Thunderbolt Bus:
what can I do to fix this ?
thanks
my specs are in the profile
and I attached the problem reporting file .
 

Attachments

Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
189,206
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi,
I followed the guide to install Macos on Laptop with Clover by Rehabman.
so far I fixed brightness and Usb 3.0 and battery.
I still need to fix touchpad and audio. have not tried anything yet .
The main issue is I can't use the booted system when I have the SSD plugged in .
my ssd is Samsung model : MZ-VLB5120 PCIe NVMe
although I read that from 10.13+ it's not necessary to patch anything for Samsung . I tried all methods to patch the IONVMeFamily with older patches, but always KP.
it works for a while and reboot
I get this message after login again :
Code:
Anonymous UUID:       A931BB94-EB47-B553-E41E-24BDFFBF7FA1

Tue Nov  6 17:19:25 2018

*** Panic Report ***
panic(cpu 0 caller 0xffffff7f89e4a5a8): nvme: "Fatal error occurred. CSTS=0x1
. FW Revision=4L1QEXA7\n"@/BuildRoot/Library/Caches/com.apple.xbs/Sources/IONVMeFamily/IONVMeFamily-387.201.1/IONVMeController.cpp:5307
Backtrace (CPU 0), Frame : Return Address
0xffffff9206dcba10 : 0xffffff80077aca1d
0xffffff9206dcba60 : 0xffffff80078e6b13
0xffffff9206dcbaa0 : 0xffffff80078d859a
0xffffff9206dcbb10 : 0xffffff8007759ca0
0xffffff9206dcbb30 : 0xffffff80077ac437
0xffffff9206dcbc50 : 0xffffff80077ac283
0xffffff9206dcbcc0 : 0xffffff7f89e4a5a8
0xffffff9206dcbe20 : 0xffffff8007e5da67
0xffffff9206dcbe90 : 0xffffff8007e5d989
0xffffff9206dcbec0 : 0xffffff80077e8865
0xffffff9206dcbf40 : 0xffffff80077e8415
0xffffff9206dcbfa0 : 0xffffff80077590ce
      Kernel Extensions in backtrace:
         com.apple.iokit.IONVMeFamily(2.1)[26E33FBA-73DC-3D8A-AA62-16A25FA97C8A]@0xffffff7f89e36000->0xffffff7f89e74fff
            dependency: com.apple.driver.AppleMobileFileIntegrity(1.0.5)[169BD129-26C1-32E2-82A5-B5E0C1FA99B4]@0xffffff7f885a7000
            dependency: com.apple.iokit.IOPCIFamily(2.9)[2CE7BCB3-0766-3A94-A8D4-29BF3EBAEFBC]@0xffffff7f88095000
            dependency: com.apple.driver.AppleEFINVRAM(2.1)[D872C3C2-611A-3BE6-B3A0-DC8B1A6795F8]@0xffffff7f8873c000
            dependency: com.apple.iokit.IOStorageFamily(2.1)[499E27C9-AC4D-3239-9FC4-754C7699FA76]@0xffffff7f883a6000
            dependency: com.apple.iokit.IOReportFamily(47)[EA2822EA-DACE-34D1-80D1-8EBF65889EBC]@0xffffff7f88bf3000

BSD process name corresponding to current thread: kernel_task
Boot args: nv_disable=1 dart=0 -cdfon -igfxnohdmi

Mac OS version:
18A391

Kernel version:
Darwin Kernel Version 18.0.0: Wed Aug 22 20:13:40 PDT 2018; root:xnu-4903.201.2~1/RELEASE_X86_64
Kernel UUID: DF83AD37-501E-3B4F-B1F0-04F3AC90FE35
Kernel slide:     0x0000000007400000
Kernel text base: 0xffffff8007600000
__HIB  text base: 0xffffff8007500000
System model name: MacBookPro15,2 (Mac-827FB448E656EC26)

System uptime in nanoseconds: 562278675673
last loaded kext at 286378279981: com.apple.filesystems.msdosfs   1.10 (addr 0xffffff7f8a5e7000, size 69632)
last unloaded kext at 370911435712: com.apple.filesystems.msdosfs   1.10 (addr 0xffffff7f8a5e7000, size 61440)
loaded kexts:
(none)

EOF
Model: MacBookPro15,2, BootROM 220.200.252.0.0, 6 processors, Intel Core i7, 2.21 GHz, 16 GB, SMC 2.44f1
Graphics: kHW_IntelUHDGraphics630Item, Intel UHD Graphics 630, Built-In
Graphics: Display, PCIe
Memory Module: BANK 0/DIMM0, 8 GB, DDR4, 2667 MHz, Samsung, M471A1K43CB1-CTD
Memory Module: BANK 1/DIMM0, 8 GB, DDR4, 2667 MHz, Samsung, M471A1K43CB1-CTD
Bluetooth: Version 6.0.8f6, 3 services, 19 devices, 1 incoming serial ports
PCI Card: display, VGA-Compatible Controller, Slot-1
Serial ATA Device: ST2000LM007-1R8174, 2 TB
USB Device: USB 3.1 Bus
USB Device: Bluetooth HCI
USB Device: Integrated Camera
USB Device: USB Receiver
Thunderbolt Bus:
what can I do to fix this ?
thanks
my specs are in the profile
and I attached the problem reporting file .
HackrNVMeFamily not applicable to 10.13.x and later.
Remove.

See patch-nvme README (on github) for patches which may apply to Hynix/Lite-on/etc.
 
Joined
Sep 9, 2011
Messages
900
Motherboard
HP 250 G5 (81EF) Clover UEFI
CPU
i3 5005u
Graphics
HD 5500 (1366x768)
Mobile Phone
Android
Hi,
I followed the guide to install Macos on Laptop with Clover by Rehabman.
so far I fixed brightness and Usb 3.0 and battery.
I still need to fix touchpad and audio. have not tried anything yet .
The main issue is I can't use the booted system when I have the SSD plugged in .
my ssd is Samsung model : MZ-VLB5120 PCIe NVMe
although I read that from 10.13+ it's not necessary to patch anything for Samsung . I tried all methods to patch the IONVMeFamily with older patches, but always KP.
it works for a while and reboot
I get this message after login again :
Code:
Anonymous UUID:       A931BB94-EB47-B553-E41E-24BDFFBF7FA1

Tue Nov  6 17:19:25 2018

*** Panic Report ***
panic(cpu 0 caller 0xffffff7f89e4a5a8): nvme: "Fatal error occurred. CSTS=0x1
. FW Revision=4L1QEXA7\n"@/BuildRoot/Library/Caches/com.apple.xbs/Sources/IONVMeFamily/IONVMeFamily-387.201.1/IONVMeController.cpp:5307
Backtrace (CPU 0), Frame : Return Address
0xffffff9206dcba10 : 0xffffff80077aca1d
0xffffff9206dcba60 : 0xffffff80078e6b13
0xffffff9206dcbaa0 : 0xffffff80078d859a
0xffffff9206dcbb10 : 0xffffff8007759ca0
0xffffff9206dcbb30 : 0xffffff80077ac437
0xffffff9206dcbc50 : 0xffffff80077ac283
0xffffff9206dcbcc0 : 0xffffff7f89e4a5a8
0xffffff9206dcbe20 : 0xffffff8007e5da67
0xffffff9206dcbe90 : 0xffffff8007e5d989
0xffffff9206dcbec0 : 0xffffff80077e8865
0xffffff9206dcbf40 : 0xffffff80077e8415
0xffffff9206dcbfa0 : 0xffffff80077590ce
      Kernel Extensions in backtrace:
         com.apple.iokit.IONVMeFamily(2.1)[26E33FBA-73DC-3D8A-AA62-16A25FA97C8A]@0xffffff7f89e36000->0xffffff7f89e74fff
            dependency: com.apple.driver.AppleMobileFileIntegrity(1.0.5)[169BD129-26C1-32E2-82A5-B5E0C1FA99B4]@0xffffff7f885a7000
            dependency: com.apple.iokit.IOPCIFamily(2.9)[2CE7BCB3-0766-3A94-A8D4-29BF3EBAEFBC]@0xffffff7f88095000
            dependency: com.apple.driver.AppleEFINVRAM(2.1)[D872C3C2-611A-3BE6-B3A0-DC8B1A6795F8]@0xffffff7f8873c000
            dependency: com.apple.iokit.IOStorageFamily(2.1)[499E27C9-AC4D-3239-9FC4-754C7699FA76]@0xffffff7f883a6000
            dependency: com.apple.iokit.IOReportFamily(47)[EA2822EA-DACE-34D1-80D1-8EBF65889EBC]@0xffffff7f88bf3000

BSD process name corresponding to current thread: kernel_task
Boot args: nv_disable=1 dart=0 -cdfon -igfxnohdmi

Mac OS version:
18A391

Kernel version:
Darwin Kernel Version 18.0.0: Wed Aug 22 20:13:40 PDT 2018; root:xnu-4903.201.2~1/RELEASE_X86_64
Kernel UUID: DF83AD37-501E-3B4F-B1F0-04F3AC90FE35
Kernel slide:     0x0000000007400000
Kernel text base: 0xffffff8007600000
__HIB  text base: 0xffffff8007500000
System model name: MacBookPro15,2 (Mac-827FB448E656EC26)

System uptime in nanoseconds: 562278675673
last loaded kext at 286378279981: com.apple.filesystems.msdosfs   1.10 (addr 0xffffff7f8a5e7000, size 69632)
last unloaded kext at 370911435712: com.apple.filesystems.msdosfs   1.10 (addr 0xffffff7f8a5e7000, size 61440)
loaded kexts:
(none)

EOF
Model: MacBookPro15,2, BootROM 220.200.252.0.0, 6 processors, Intel Core i7, 2.21 GHz, 16 GB, SMC 2.44f1
Graphics: kHW_IntelUHDGraphics630Item, Intel UHD Graphics 630, Built-In
Graphics: Display, PCIe
Memory Module: BANK 0/DIMM0, 8 GB, DDR4, 2667 MHz, Samsung, M471A1K43CB1-CTD
Memory Module: BANK 1/DIMM0, 8 GB, DDR4, 2667 MHz, Samsung, M471A1K43CB1-CTD
Bluetooth: Version 6.0.8f6, 3 services, 19 devices, 1 incoming serial ports
PCI Card: display, VGA-Compatible Controller, Slot-1
Serial ATA Device: ST2000LM007-1R8174, 2 TB
USB Device: USB 3.1 Bus
USB Device: Bluetooth HCI
USB Device: Integrated Camera
USB Device: USB Receiver
Thunderbolt Bus:
what can I do to fix this ?
thanks
my specs are in the profile
and I attached the problem reporting file .
AFAIK, NVMe is natively supported since 10.13. So no need for HackrNVMeFamily.kext. Correct me if I'm wrong.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
189,206
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
AFAIK, NVMe is natively supported since 10.13. So no need for HackrNVMeFamily.kext. Correct me if I'm wrong.
Some devices are not native. Some require a specific patch to ignore mismatch on preferred block size.
Refer to the patch-nvme README.

Note: Some devices (PM981? PM961?) may initially "work", but are not stable.
 
Joined
Jan 7, 2014
Messages
50
Motherboard
Lenovo Legion y7000p-1060 - Clover
CPU
i7-8750H
Graphics
UHD 630 / GTX 1060
Mac
MacBook Pro
Mobile Phone
Android
AFAIK, NVMe is natively supported since 10.13. So no need for HackrNVMeFamily.kext. Correct me if I'm wrong.
Thanks;
it crashed even before I did anything. first I tried to install directly to ssd but it always crashes; so I installed to HDD: tried to clone to ssd and KP:
that's why I tried a combination of HackrNVMeFamily .
now it's removed
I'm sorry I don't see where exaclty. it says (see above)
is it the link to the forum which post ?
 
Joined
Jan 7, 2014
Messages
50
Motherboard
Lenovo Legion y7000p-1060 - Clover
CPU
i7-8750H
Graphics
UHD 630 / GTX 1060
Mac
MacBook Pro
Mobile Phone
Android
HackrNVMeFamily not applicable to 10.13.x and later.
Remove.

See patch-nvme README (on github) for patches which may apply to Hynix/Lite-on/etc.
I removed the HackrNVMeFamily . but still KP when SSD is plugged .
I checked patch-nvme README, the only thing I understood there is that it has to be converted to 4k block .
I checked my SSD under Linux and it's only 512
Code:
Supported LBA Sizes (NSID 0x1)
Id Fmt  Data  Metadt  Rel_Perf
 0 +     512       0         0
is there any other solutions to this ?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
189,206
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I removed the HackrNVMeFamily . but still KP when SSD is plugged .
I checked patch-nvme README, the only thing I understood there is that it has to be converted to 4k block .
I checked my SSD under Linux and it's only 512
Code:
Supported LBA Sizes (NSID 0x1)
Id Fmt  Data  Metadt  Rel_Perf
 0 +     512       0         0
is there any other solutions to this ?
Did you read the section regarding Hynix/Lite-on/etc?
 
Joined
Jan 7, 2014
Messages
50
Motherboard
Lenovo Legion y7000p-1060 - Clover
CPU
i7-8750H
Graphics
UHD 630 / GTX 1060
Mac
MacBook Pro
Mobile Phone
Android
Did you read the section regarding Hynix/Lite-on/etc?
Thanks you ;
I just did and i'm guessing the solution now is in config_patches.plist
should I copy those patch to my config plist and that's it, or are there any specific steps ?
also my SSD is Samsung none of those .
sorry for the noobie questions :)
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
189,206
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Thanks you ;
I just did and i'm guessing the solution now is in config_patches.plist
should I copy those patch to my config plist and that's it, or are there any specific steps ?
also my SSD is Samsung none of those .
sorry for the noobie questions :)
You will only need one of the patches. Make sure you read the background info on those patches (link in README).
You should undo anything else you did with NVMe.
Keep in mind certain Samsung SSDs are not stable (I forget the specific model(s), but ... PM961? PM981?)
 
Joined
Jan 7, 2014
Messages
50
Motherboard
Lenovo Legion y7000p-1060 - Clover
CPU
i7-8750H
Graphics
UHD 630 / GTX 1060
Mac
MacBook Pro
Mobile Phone
Android
You will only need one of the patches. Make sure you read the background info on those patches (link in README).
You should undo anything else you did with NVMe.
Keep in mind certain Samsung SSDs are not stable (I forget the specific model(s), but ... PM961? PM981?)
Alright, my ssd is Samsung model : MZ-VLB5120 and yes I checked it's PM981
here is what I did:
- Installed back the native kext (no hackerNVMe)
- ran : sudo kextcache -i /
- removed the SSDT_NVMe-Pcc.aml I created when I tried to patch with the old method
- disabled the patch _DSM to XDSM
- used the patch bellow because all the others are 10.13.x .
Code:
  <dict>
        <key>Comment</key>
        <string>IONVMeFamily: Ignore FLBAS bit:4 being set - for Plextor/LiteOn/Hynix</string>
        <key>Disabled</key>
        <false/>
        <key>Name</key>
        <string>IONVMeFamily</string>
        <key>Find</key>
        <data>ikga9sEQ</data>
        <key>Replace</key>
        <data>ikga9sEA</data>
      </dict>
booted from HDD the SSD is recognized;
went to Disk Utility and formated it to APFS
then a sudden reboot again
the system worked for about 20min until I formated the SSD ; strange !

Thank you Rehabman for your patience :)
I guess I'll keep MacOS on HDD.
are they unstable only with Mac, because I have Linux and Windows 10 on it never had any issues.
 
Top