Contribute
Register

Help! How to completely accelerate my XFX AMD Radeon RX 470 4 GB?

Joined
Jan 23, 2018
Messages
18
Motherboard
Biostar G41D3
CPU
Intel Core 2 Duo E7400 2,79 GHz
Graphics
Nvidia Geforce 8400 GS
Mac
iMac
My configuration is:

CPU: Core 2 Duo E7400
Motherboard: Biostar G41D3
Ram: 8 gb DDR3
GPU: XFX RX 470 RS 4GB

I am running Mojave 10.14.0. My configuration does not support IGPU. The system charges without problems. However, I do not have a full acceleration. I have Lilu and Whatervegreen loaded in L \ E. I appreciate your help. In the attached images you can see that my system does not load AMD9500controller.kext nor AMDRadeonX4000.kext

388373
388374
388375
388376
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,679
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
GTX 970
I am running Mojave 10.14.0. My configuration does not support IGPU. The system charges without problems. However, I do not have a full acceleration.
Your Intel Core 2 Duo E7400 doesn't have SSE4.2
AFAIK the newer AMD drivers used in Mojave require the SSE4.2 instruction set.
 
Joined
Jan 23, 2018
Messages
18
Motherboard
Biostar G41D3
CPU
Intel Core 2 Duo E7400 2,79 GHz
Graphics
Nvidia Geforce 8400 GS
Mac
iMac
Your Intel Core 2 Duo E7400 doesn't have SSE4.2
AFAIK the newer AMD drivers used in Mojave require the SSE4.2 instruction set.
Thank you @BreBo for your prompt response. So, the problem of the partial acceleration that I have is due to my processor? Previously I managed to achieve a full acceleration but with failures, with my previous geforce 8400 gs. I upgraded to RX 470 hoping to have the same acceleration results but without failures.
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,679
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
GTX 970
So, if I do not use the Mojave Patcher, but install High Sierra 10.13.6 by the Unibeast method, I would find myself in the same situation because of the processor, right?
You could try macOS High Sierra
AFAIK macOS Sierra and High Sierra require CPU's with SSE4.1 instructions.
 
Joined
Jan 23, 2018
Messages
18
Motherboard
Biostar G41D3
CPU
Intel Core 2 Duo E7400 2,79 GHz
Graphics
Nvidia Geforce 8400 GS
Mac
iMac
You could try macOS High Sierra
AFAIK macOS Sierra and High Sierra require CPU's with SSE4.1 instructions.
Okay, I'll try again. Although, the last time I tried, I got a black screen. Unlike Mojave, which allows me to enter the desktop with partial acceleration.
 
Joined
Jan 23, 2018
Messages
18
Motherboard
Biostar G41D3
CPU
Intel Core 2 Duo E7400 2,79 GHz
Graphics
Nvidia Geforce 8400 GS
Mac
iMac
You could try macOS High Sierra
AFAIK macOS Sierra and High Sierra require CPU's with SSE4.1 instructions.
Hello @BreBo. Hi. I have tried with High Sierra, however, I only get a black screen after the apple logo. It makes no difference having Lilu and Whatervegreen loaded, I only get a black screen. This behavior is strange, since in Mojave, at least it enters the desktop (without acceleration).
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,679
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
GTX 970
I have tried with High Sierra, however, I only get a black screen after the apple logo. It makes no difference having Lilu and Whatervegreen loaded, I only get a black screen. This behavior is strange, since in Mojave, at least it enters the desktop (without acceleration).
What port do you use, DisplayPort, DVI-D, HDMI ?
Try a different one.
 
Joined
Jan 23, 2018
Messages
18
Motherboard
Biostar G41D3
CPU
Intel Core 2 Duo E7400 2,79 GHz
Graphics
Nvidia Geforce 8400 GS
Mac
iMac
What port do you use, DisplayPort, DVI-D, HDMI ?
Try a different one.
Use HDMI. It is an option that I considered trying, but I do not have a monitor with a different input. Although I think that when I tested with Mojave, I got video using the same port (with the corresponding lack of acceleration problem), why could not I use that HDMI port in High Sierra ?.
 
Top