Contribute
Register

HackinDROM App for OpenCore EFI Creation and Update

Joined
May 15, 2020
Messages
1,170
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
2.0.5 downloaded (before it was direct update if I am right) and installed.
Everything is smooth so far :)
Direct update causes issues on some hackintoshes (can't find the reason) that's why I disabled it until I find a better implementation
 
Joined
Jun 10, 2010
Messages
219
Motherboard
ASRock Z490M-ITX/ac
CPU
i10 10700 3.8GHz
Graphics
RX 580
Mac
  1. MacBook Air
Mobile Phone
  1. Android
Guys have you read my post just above about this issue ?
Will publish a fix today

EDIT: HackinDROM v2.0.5 is available!
Thanks for the update. I deleted my 2.0.4 from the machine and downloaded a fresh copy of the new 2.0.5 from the website. But I'm now more confused than ever! :)
  • The website says 2.0.5 (https://hackindrom.zapto.org/)
  • After I unzip it & run it, it says it's 2.0.4 and that a 2.0.5 is available
  • When I get info on the application it says it's 2.0 !

    Any thoughts?

    Thanks again
 

Attachments

  • 205.png
    205.png
    904.2 KB · Views: 11
Joined
May 15, 2020
Messages
1,170
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Thanks for the update. I deleted my 2.0.4 from the machine and downloaded a fresh copy of the new 2.0.5 from the website. But I'm now more confused than ever! :)
  • The website says 2.0.5 (https://hackindrom.zapto.org/)
  • After I unzip it & run it, it says it's 2.0.4 and that a 2.0.5 is available
  • When I get info on the application it says it's 2.0 !

    Any thoughts?

    Thanks again
Just tested and it is working as excepted
Screenshot 2021-10-26 at 14.39.02.png
 
Joined
May 15, 2020
Messages
1,170
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Thanks for the update. I deleted my 2.0.4 from the machine and downloaded a fresh copy of the new 2.0.5 from the website. But I'm now more confused than ever! :)
  • The website says 2.0.5 (https://hackindrom.zapto.org/)
  • After I unzip it & run it, it says it's 2.0.4 and that a 2.0.5 is available
  • When I get info on the application it says it's 2.0 !

    Any thoughts?

    Thanks again
Try to download it from Github
 
Joined
Jun 10, 2010
Messages
219
Motherboard
ASRock Z490M-ITX/ac
CPU
i10 10700 3.8GHz
Graphics
RX 580
Mac
  1. MacBook Air
Mobile Phone
  1. Android
Try to download it from Github
Perfect. I didn't realise there was a repo for it, I always use the website from post #1 here.

Thanks again for all your efforts on HackindROM - it's much appreciated.

(btw: cosmetically the build from Github still shows 2.0 when I use get-info, but it runs as v2.0.5)
 
Joined
May 15, 2020
Messages
1,170
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Perfect. I didn't realise there was a repo for it, I always use the website from post #1 here.

Thanks again for all your efforts on HackindROM - it's much appreciated.

(btw: cosmetically the build from Github still shows 2.0 when I use get-info, but it runs as v2.0.5)
Thanks, maybe it was browser cache issue
macOS doesn't shows patch version (2.0.5) in get info
 
Joined
May 19, 2020
Messages
38
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
RX 580
@Inqnuam v2.05 works correctly and updated my backup m.2 to 0.74 so that's fixed. Unfortunately I lost keyboard and mouse operation upon reboot (which I know isn't your problem!) so it's back to drawing board and guide reading and temporary revert to 0.6.8 for me. Thanks for the patch though!
 

CeeeWeee

Suspended
Joined
May 31, 2017
Messages
137
Motherboard
Gigabyte Z590 Aorus Elite AX
CPU
i7-10700KF
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
It may work, or not..
You can try following next steps:
  1. Make a backup of your current EFI
  2. Select the motherboard which is the closest to yours
  3. Mount your EFI partitions through HackinDROM App
  4. Click to "Update to X.Y.Z" or "Reinstall OC" if your EFI is already up to date
  5. Carefully Switch OFF"Update" (blue buttons) for all amls kexts and drives that your system don't need
  6. Click to "Update OpenCore"
  7. Then try to boot your system with that newly updated EFI and let me know if it worked!

Please keep in mind HackinDROM App isn't made to work like this, this is just for test, chances are very big that it will work but it may fail too
It worked on my Z170 (I chose Gigabyte Z370).

I had to add kext for network and audio afterwards. But other then that it seems fine :)

Now waiting for HackinDROM to update me to 0.7.4 or 0.7.5 so I can get to Moneterey...(I can only install 0.7.3 in the tool right now)
 
Top