Contribute
Register

[GUIDE] Sierra on the GA-Z170X-UD3

PFG

Joined
Dec 15, 2016
Messages
93
Motherboard
Gigabyte Z170X-UD3
CPU
i7-6700K
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. iOS
Clemy88

I'm not sure you can have both SS01 and HS01. I didn't know where to find the ports patch, so I just assigned only 1 port type for each USB port depending if it was USB 2.0 or USB 3.0. All my ports work, but I have not speed tested the USB 3.0 ports.
Doing this meant I did not need the ports patch.

Regards
 
Joined
Oct 8, 2011
Messages
201
Motherboard
Gigabyte Z390 Designare
CPU
i7 8700
Graphics
RX580 Nitro+
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hey guys,

I've installed Sierra on my system and everything is working nicely BUT sometimes i see the mouse pointer freezing for a split second. If I'm not paying attention, it's not even noticeable but now that I know it's there, it's annoying.

It doesn't actully freeze but it jumps to the location where it should be.

As I've counted, this happens regularly every 10 seconds or so.

I have a wired Razer Naga v2 and I've also tried a wireless mouse and it's still happening - so I don't think it's a mouse/driver issue.

Any idea what might be causing this?
 
Last edited:
Joined
Dec 30, 2010
Messages
41
Motherboard
GA-Z170X-UD3
CPU
i7 6700K
Graphics
Gigabyte GTX970 G1 GAMING
Mac
  1. MacBook Pro
Hey folks,

I have a ga-z170x-ud3 and was happy to get my USB ports to life. Now while speed testing I discovered that I only get USB 2.0 speed with the USB 3.0 ports. I did the increase max port limit patch with multibeast which includes the usbinjectall.kext and then I ran the usb-ssdt.command to create the usb-ssdt.aml
I'm on Sierra and everything else runs smooth. I searched the forum but maybe someone knows
a thread that I oversaw or knows a solution.
Cheers

Just to be sure, you either use usbinjectall.kext with port limit patch or the vanilla solution proposed by this guide (which involves two file to place in APCI/patched and a Drop Table entry in config.plist). When you generate the SSDTs with usb-ssdt.command, note that you have to manually edit USB-SSDT.aml if you have F20 bios.
Look at this post for details.
https://www.tonymacx86.com/threads/guide-sierra-on-the-ga-z170x-ud3.202296/page-17#post-1406742
 
Joined
Feb 17, 2011
Messages
488
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
For anyone who have problems with my USB script after updating the BIOS to F20 please try this:

Open the USB-SSDT in MaciASL (RehabMan-MaciASL-2016-0423.zip)

Remove these two lines:
Code:
External (HUBC, IntObj)    // (from opcode)
External (UMAP, IntObj)    // (from opcode)

Replace these lines:

Code:
    Scope (\_SB)
    {
        Method (_INI, 0, NotSerialized)  // _INI: Initialize
        {
            Store ("Method \\_SB._INI Called", Debug)
            Store (***SOMEHEXCODE***, \HUBC)
            Store (***SOMEOTHERHEXCODE***, \UMAP)
        }
    }

with:

Code:
    Name (HUBC, ***SOMEHEXTCODE***)
    Name (UMAP, ***SOMEOTHERHEXCODE***)

By: ***SOMEHEXCODE*** and ***SOMEOTHERHEXCODE*** I mean, there is a value there, on mine it's: 0xC243 and 0x013C, copy those and use them in the replaced code (Use your own, those are only an example).

The problem is there because Gigabyte changed some of their ACPI code in the F20 BIOS (They removed the HUBC and UMAP from DSDT, which means we can no longer write these values to the fields in the DSDT).

Cnrd, I guess it does also apply to El Capitan, right?
 
Last edited:
Joined
Jun 6, 2013
Messages
4
Motherboard
Z170X UD3 Ultra with BIOS F22
CPU
i7-7700K
Graphics
GEFORCE GTX 670 FTW
After following cnrd's detailed instructions, my Sierra installation on Z170X-UD3 Ultra is hanging with the following output with verbose mode:

OsxAptioFix2Drv: Starting overrides for System\Library\CoreServices\boot.efi
Using reloc block: no, hibernate wake: no
++++++++++++++++++++++++++++++++++++++

Any suggestions how to bypass this?
 
Joined
Feb 21, 2011
Messages
312
Motherboard
GA-Z170X-UD3
CPU
I5-6600K
Graphics
Vega 64
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Cnrd, I guess it does also apply to El Capitan, right?
Yup on F20 BIOS.

After following cnrd's detailed instructions, my Sierra installation on Z170X-UD3 Ultra is hanging with the following output with verbose mode:

OsxAptioFix2Drv: Starting overrides for System\Library\CoreServices\boot.efi
Using reloc block: no, hibernate wake: no
++++++++++++++++++++++++++++++++++++++

Any suggestions how to bypass this?
First: Fill out your PC specs.
 
Joined
Mar 4, 2010
Messages
80
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i7-9700K
Graphics
RX560 + GTX 2060 super
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Hey guys,

I've installed Sierra on my system and everything is working nicely BUT sometimes i see the mouse pointer freezing for a split second. If I'm not paying attention, it's not even noticeable but now that I know it's there, it's annoying.

It doesn't actully freeze but it jumps to the location where it should be.

As I've counted, this happens regularly every 10 seconds or so.

I have a wired Razer Naga v2 and I've also tried a wireless mouse and it's still happening - so I don't think it's a mouse/driver issue.

Any idea what might be causing this?

I vaguely remember a problem similar to this many years ago and I think it was a result of the graphics card/driver. I see you are using a Radeon - you may want to try swapping out with something else to test if that is the issue.
 
Joined
Jun 6, 2013
Messages
4
Motherboard
Z170X UD3 Ultra with BIOS F22
CPU
i7-7700K
Graphics
GEFORCE GTX 670 FTW
After following cnrd's detailed instructions, my Sierra installation on Z170X-UD3 Ultra is hanging with the following output with verbose mode:

OsxAptioFix2Drv: Starting overrides for System\Library\CoreServices\boot.efi
Using reloc block: no, hibernate wake: no
++++++++++++++++++++++++++++++++++++++

Any suggestions how to bypass this?

First: Fill out your PC specs.

PC specs:
Mainboard: Z170X UD3 Ultra with BIOS F22
CPU: i7-7700K
Graphics card: GEFORCE GTX 670 FTW (tried both with external GPU and internal HD630 same result)

Thanks, cnrd!
 
Joined
Oct 8, 2011
Messages
201
Motherboard
Gigabyte Z390 Designare
CPU
i7 8700
Graphics
RX580 Nitro+
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Anyone tried F21 BIOS on Z170X-UD3 ?

Any issues? I'm on F6 now and I intend to update to F21. I'm having some issues with an Asus ThunderboltEX2 Dual card.
 
Top