Contribute
Register

[GUIDE] Remove extra Clover BIOS boot entries & prevent further problems

Joined
Nov 23, 2013
Messages
77
Motherboard
GA-Z87X-UD5H
CPU
i7-4770K
Graphics
GTX 770 4 GB
Mac
iMac
Mobile Phone
iOS
If the deleted entries from the Clover BIOS are still present after reboot in the BIOS, how do we remove them here ?

I successfully deleted the non-HD entries following the mentioned steps but deleted ones are still present on reboot and doing it twice didn't changed anything.

I don't see any suggestion about that in the Guide.
 
Joined
Jul 24, 2015
Messages
2,331
Motherboard
MSI H81i
CPU
i5-4570
Graphics
RX 580
If the deleted entries from the Clover BIOS are still present after reboot in the BIOS, how do we remove them here ?

I successfully deleted the non-HD entries following the mentioned steps but deleted ones are still present on reboot and doing it twice didn't changed anything.

I don't see any suggestion about that in the Guide.
The EmuVariableUEFI driver might prevent this from having any effect. Firmware will recreate appropriate entries at boot time, but you shouldn't have a long list pointing to the same /EFI/BOOT/BOOTX64.EFI instance.
 
Joined
Nov 23, 2013
Messages
77
Motherboard
GA-Z87X-UD5H
CPU
i7-4770K
Graphics
GTX 770 4 GB
Mac
iMac
Mobile Phone
iOS
The EmuVariableUEFI driver might prevent this from having any effect. Firmware will recreate appropriate entries at boot time, but you shouldn't have a long list pointing to the same /EFI/BOOT/BOOTX64.EFI instance.
Thank you for the suggestion, I'm trying to understand what I can do with that.

Also, nobody responded to my topic since my build stopped booting Sunday, would you mind telling me what's wrong with it ?
https://www.tonymacx86.com/threads/updating-from-yosemite-to-high-sierra-i7-4770k-z87-ud5h-unable-to-boot-after-working-for-a-while.246440/page-2

Thanks again :)
 
Joined
Jul 20, 2013
Messages
144
Motherboard
GA-Z77X-UPH TH
CPU
I7-3770K OC 4.5
Graphics
R9 280
Mac
Mac mini
Mobile Phone
Android, iOS
No, the Preboot volume is for booting.
I’m aware of that, however its that many of us have still this option after a successful / completed install. This is my situation after installing a Mojave beta. I’ve also read that others have had this occur after a ahigh Sierra install.

As such, I had assumed it was a left over remnant boot option.
 
Joined
Jul 24, 2015
Messages
2,331
Motherboard
MSI H81i
CPU
i5-4570
Graphics
RX 580
As such, I had assumed it was a left over remnant boot option
I believe the installer option is created by the Clover entry scan when it finds an APFS container, it doesn't check the files. It's used for updates otherwise it does nothing.

You could hide the entries for 'Preboot' in your Clover settings, there's a guide here.
preboot.png
If you have custom entries for the options you use, turning off the entry scan will also hide the installer option.

You'd need to unhide (press F3) or re-enable the scan to do updates.
 
Last edited:
Joined
Nov 20, 2015
Messages
32
Motherboard
GA H170N WIFI
CPU
I7 6700
Graphics
EVGA GTX 970 FTW
Mac
MacBook Air, MacBook Pro
Classic Mac
PowerBook
Mobile Phone
iOS
After running into this trouble again, I can only advise to upgrade the Bios.

You don't need windows.

- Download the bios upgrade from the Gigabyte website (support)
- Make sure you select the correct motherboard AND revision number
- format a USB stick FAT
- put the file on your USB stick
- reboot and hit DEL to go into your Bios
- click Q-Flash and select your usb stick

-> manual here https://www.gigabyte.com/webpage/20/images/utiltiy_qflash_uefi.pdf

Succes with H170N-wifi revision 1.0 flashed to firmware F22
 
Top