Contribute
Register

[Guide] MSI PS63 Modern using Clover UEFI

Joined
Sep 13, 2017
Messages
116
Motherboard
Lenovo IdeaPad S145-15IWL
CPU
i3‎-8145U‎
Graphics
UHD 620
Mac
MacBook Air
Mobile Phone
Android, iOS
I live in Taiwan. So I ordered from Hong Kong and it costs around 80USD. I will try after I receive it.
Currently what is your BIOS version? E16S1IMS.106 ??
Incredible, the value of this card has increased dramatically. 4 years ago I bought it for € 25 (~30USD)

it's really a shame if it doesn't work, if I get my laptop back I'll definitely try it and I'll keep you updated
 
Joined
Mar 28, 2015
Messages
117
Motherboard
MSI GS65 8SE
CPU
i7-8750H
Graphics
UHD 630 + RTX 2060
Mac
MacBook Pro
Mobile Phone
Android
FYI on my MSI GS65 8SE, I also have CNVi setting as Auto Detect but my DW1560 works fine on Windows 10 and on the latest macOS Catalina.
 
Joined
Nov 18, 2019
Messages
4
Motherboard
MSI-PS63-8RC
CPU
i7-8565U
Graphics
GTX 1050
I have installed the last BIOS update and windows don't recognize the DW1560 or the DW1820. Its not HW problem.
Hi, I have newly installed Mojave in PS63. I am still experiencing graphics problem (no acceleration). If possible, can you please share your working Clover folder and other necessary kexts?
 
Joined
Aug 9, 2012
Messages
51
Motherboard
MSI PS63-Clover
CPU
i7-8565U
Graphics
UHD 620 + GTX 1050 Max-q, 1920x1080
Mac
MacBook Pro
Mobile Phone
iOS
@bhaskarJB You have a great guide at the #1 post. We expend a lot of time to find how to make it allmost perfect Make a hackintosh it’s not for lazy and DOY it’s the best way to learn.
Please, take your time to read it and be greatfull that you have a guide so well explaned.

I continue trying to make the DW1560 work. I'll never quit.
 
Joined
Mar 28, 2015
Messages
117
Motherboard
MSI GS65 8SE
CPU
i7-8750H
Graphics
UHD 630 + RTX 2060
Mac
MacBook Pro
Mobile Phone
Android
Another issue that I have is that at system startup, my brightness level has not been saved. I’ve installed well my emulated NVRAM.
I found a fix for this, but I am not emulating my ram. Instead, I use this https://github.com/ReddestDream/OcQuirks instead of OsxAptioDriverFix.efi and replace it with FwRuntimeService.efi and OCQuirks.efi, but I don't think you have to do this, and then Make sure you also have SMCLightSensor.kext.

EDIT: I noticed in your EFI file you used FakeSMC.kext. You will have to replace all the FakeSMC kexts with the VirtualSMC and all of it's plugins if you plan on trying to fix the brightness issue. You also must have the SSDT-ASL0.aml, which you currently have, and remove the backlight level from clover.plist.
 
Last edited:
Joined
Sep 13, 2017
Messages
116
Motherboard
Lenovo IdeaPad S145-15IWL
CPU
i3‎-8145U‎
Graphics
UHD 620
Mac
MacBook Air
Mobile Phone
Android, iOS
I found a fix for this, but I am not emulating my ram. Instead, I use this https://github.com/ReddestDream/OcQuirks instead of OsxAptioDriverFix.efi and replace it with FwRuntimeService.efi and OCQuirks.efi, but I don't think you have to do this, and then Make sure you also have SMCLightSensor.kext.

EDIT: I noticed in your EFI file you used FakeSMC.kext. You will have to replace all the FakeSMC kexts with the VirtualSMC and all of it's plugins if you plan on trying to fix the brightness issue. You also must have the SSDT-ASL0.aml, which you currently have, and remove the backlight level from clover.plist.
Attention, the attached folder is USB Clover, for the first boot. I'm using VirtualSMC instead Fake
 
Top