Contribute
Register

[Guide] MSI PS63 Modern using Clover UEFI

Joined
Sep 13, 2017
Messages
114
Motherboard
MSI-PS63-8RC
CPU
i7‎-8565U‎
Graphics
UHD 620 - GTX 1050 max-q
Mac
MacBook Air
Mobile Phone
Android, iOS
MSI PS63 Modern - Mojave 10.14.6

msi.pngAboutThisMac2.png
Thanks @Bucaro and @GeneralDS and @richardchiu 's guide

What Works
  • Battery Support
  • Intel UHD 620
  • Sound
  • iMessage and iCloud services
  • Brightness
    You need to use Karabiner app (google it) for enable F1 and F2 brightness slider keys. Or you can setting brightness level in Settings/Monitor.
  • Volume Keys (Fn+ArrowLeft/ArrowRight)
  • Keyboard
  • Keyboard native Brightness with 3 levels
  • Track-Pad with gestures
  • Webcam and Microphone
  • USB 3 & TYPE-C
  • USB-C to HDMI output with audio working
  • HDMI port working with audio
  • Sleep & Wake
  • Headphone

What Doesn't Work
  • WIFI and Bluetooth (This laptop uses a CNVi m.2 WiFi port. None of the old Broadcom cards will be detected)
see post #44 to disable CNVi support in bios hidden settings
  • Nvidia dedicated card obviously (disabled)
  • Little drain problems and brightness level at startup (not saved from shutdown) - see at the end of this guide to know more (*)

BIOS SETTINGS

IMG_0188.JPGIMG_0189.JPGIMG_0190.JPG

After install, you can re-enable VT-d


PRE-INSTALL


First of all, you need to create a USB bootable media. You can follow this perfect guide by RehabMan:

https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

Remember to format your disk (where do you want to install Macintosh) in APFS volume.

If you need, you can have a look of my USB folder for see (or take) what Drivers and Kexts are inside, and you can take my config.plist directly (downloaded from RehabMan archive) from here.
Download it from attached files - USB_CLOVER.zip


POST-INSTALL


Suggested apps:

Clover Installation
1.png
Download and install the last version of “Clover EFI Bootloader” in your system drive from sourceforge.net.
Choose Customiseinstallation.
You need to check:

- Clover for UEFI booting only
- Install Clover in the ESP
- AudioDxe
- DataHubDxe
- FSInject
- ApfsDriverLoader
- Fat
- VBoxHfs
- OsxAptioFix3Drv
- EmuVariableUefi
- NvmExpressDxe
- PartiotionDxe
- Install RC scripts on target volume
- Black Green Moody
- CloverThemeManager
- Install Clover Preference Pane

You need to uncheck ALL other voices!

After that, copy your config.plist from your USB boot drive (if you have done all right, the config.plist is exactly the config_UHD630.plist from RehabMan. If you use another config.plist from unknow source, please use the RehabMan’s one.)
config.plist from RehabMan GitHub --> right click on raw and download, then change the name to config.plist

Copy it in your disk where you install MacOS EFI/CLOVER folder, and replace it.

In the driver (UEFI) folder you NEED to put VirtualSmc.efi (I don’t use FakeSMC). Take it from drivers folder.

In kexts folder, erase all folders (10.1, 10.2, 10.3,…) and leave only “other” folder. Here you need to install the most important kexts that will load at system update or in recovery mode.
Now, at this point, you can reboot without USB.
Try to do it.
If the system boot up, Clover is properly installed.
If you have problems at startup, try to see post #22:




Install Kexts properly

Using Clover Configurator, mount EFI partition of your drive.
Go to your config.plist, and open it with CloverConfigurator App. Go to System Parameters and set Inject Kexts to Detect.

Now, with Hackintool, we need to install all the kexts that we have in the EFI/CLOVER/kexts/Other folder, to L/E.
Do not remove them anyway from EFI\Clover\kexts\Other.

With “Detect”, in config.plist, the system loads kexts in Other folder ONLY if he notice that VirtualSMC is not load in L/E.


All future kexts must to be properly installed in L/E with Hackintool.
Hackintool1.pngHackintool2.png


Fake Ethernet (for iMessage/FaceTime services)
I suggest you, if you can, to not connect the laptop to the internet, we must first install a fake ethernet port for iMessage/FaceTime. If you haven’t another MacBook or Hackintosh where you can fix your DSDT/SSDT files with MaciASL, install your dongle Wi-Fi but afterwards it will be necessary to fix the false ethernet port (after you have installed it) as the main internet connection (en0) – look it in DCPI Manager app. It’s all written in the iMessage guide.

Little quote:
If your Ethernet interface is identified as anything other than en0 you may need to reset your network configuration files.
Open Finder and browse to /Library/Preferences/SystemConfiguration/ then delete these two files:

  • NetworkInterfaces.plist
  • preferences.plist
Empty the Trash and then Restart.
INSTALL TIPS

In Clover Bootloader (in the screen where you select the operating system to start), press F4. Now you have your DSDT and SSDT files in EFI/Clover/ACPI/origin folder.
You need to edit your DSDT for enabling fake ethernet port.
IMPORTANT: you need to disassembly your DSDT.aml, edit your DSDT.dsl and recompile it. After you’ve done it, you need to put your new DSDT.aml in EFI/Clover/ACPI/patched folder.
Obviously if you need to modify again your DSDT, you must to take the patched one and decompile it.

If you never patching Laptop DSDT/SSDTs read first RehabMan guide patching laptop DSDT/SSDTs.
After reboot, verify that your fake Ethernet is setting up on en0 with DCPI Manager app and it’s build-in.
After that, you can install your Wi-Fi dongle or reset plist files in SystemConfiguration folder for reset the ports if you have already used a Wi-Fi dongle.




USB Inject ALL fix

Disabling Fingerprint scanner not recognized, microSD card (cause Sleep-Wake loops problems), Bluetooth/Wi-Fi Card reader. Without disable it, you can’t use an Bluetooth USB dongle.

What to do:
FIRST OF ALL, eject all USB devices.

  1. Place the USBInjectAll.kext (for port discovery) into EFI/CLOVER/kexts/Other
  2. ONLY FOR NOW: Go to your config.plist, and open it with CloverConfigurator App. Go to System Parameters and set Inject Kexts to YES.
  3. Reboot
  4. Run Hackintool then go to General->Installed to check USBInjectAll is installed correctly
    • Eg. USBInjectAll: Yes (Release-0.7.1)
  5. Go to the General->USB tab
  6. Select the “Clear All” button then the “Refresh” button
  7. Remove the three green line (it’s Fingerprint, Bluetooth/Wi-Fi, microSD card slot)
  8. Plug and unplug a USB device into all ports on your system
    • The ports that are active will remain highlighted green (set connector to USB3)
  9. Plug and unplug a Type-C device into all ports
    • The ports that are active will remain highlighted green (Set connector to TypeC+Sw)
  10. Remember the WebCam, enable it and set Connector to Internalfor Cam.
  11. Delete all ports that are not highlighted green with “Delete” button.
  12. Use the “Export” button to generate files to your Desktop
    • Copy .aml files in EFI/CLOVER/ACPI/patched and kext file in L/E (install it with Hackintool).
  13. You can now perform a clean up and remove unnecessary files:
    • Remove USBInjectAll.kext (from EFI partition)
    • Go to your config.plist, and open it with CloverConfigurator App. Go to System Parameters and set Inject Kexts to Detect.
  14. Reboot
  15. Run Hackintool and go to the General->USB tab
  16. Select all items in the USB Ports list and select the “Delete All” then the “Refresh” button
    • Now you can check all ports are working correctly

USB_InjectAllFix.png




Enable Graphic Acceleration of Intel video card + fixes

Adding hotpatch: SSDT-PNLFCFL.aml to EFI\Clover\ACPI\patched folder from hotpatch folder of RehabMan OS-X-Clover-Laptop-Config-master.

Use Hackintool’s Patch option like this screenshot:

Graphic_1.png
Graphic_2.png
Generate Patch button
Graphic_3.png
export bootloader config.plist to desktop and with PlistEdit Pro app edit your config.plist adding new lines correctly – simple drag and drop of line that you want put on your config.plist

Graphic_4.png


reboot

HDMI PORT FIX
Add this boot argument in config.plist: agdpmod=vit9696
Download HDMI.zip from attached files and open HDMI.plist. Fix your config.plist with PlistEdit Pro app (again, simple drag and drop of the line that you want copy from HDMI.plist to config.plist for adding it)

DISABLING NVIDIA CARD + FIX AFTER SLEEP

Refer to Disabling discrete graphics in dual GPU laptops guide

Apply Disable from _INIpatch, on SSDT-9-OptTabl.dsl
With correction like the guide: PEG0 to RP05


Apply Disable/Enable on _WAK/_PTS (DSDT)patch, on DSDT.dsl (for Fix After Sleep)



AUDIO FIX

Install AppleALC.kext, FakePCIID_Intel_HDMI_Audio.kext and FakePCIID.kext in L/E with Hackintool.

In config.plist go to devices\Audio\ Inject=29, ResetHDA=yes

Reboot.

Remember:
When you update system, if your audio isn’t working try to reinstall this kext in L/E. I’ve solved in this way.
When you switch between Windows and Mac, always shutdown system before go to the other operating system. If you startup Mac OS from a reboot in Windows, Audio may be not works.




HEADPHONE FIX

In config.plist, Devices, Inject audio = 29

Headphone_Fix.png
Install in L/E CodecCommander.kext

Put had_verb in /usr/bin (you can open this folder with terminal: open /usr/bin)

Fix codec from terminal (install ALC Plug Fix):

Code:
sh -c "$(curl -fsSL https://raw.githubusercontent.com/daliansky/XiaoMi-Pro-Hackintosh/master/ALCPlugFix/one-key-alcplugfix.sh)"
reboot



TRACKPAD with gestures

Fallow the guide from point C of this useful guide:

https://www.tonymacx86.com/threads/guide-acer-swift-5-sf514-53t-whiskey-lake-macos10-14-5.277618/#post-1959633

My ACPI ID is: \SB.PCI0.I2C0.TPD0
My changes is underlined in this screenshot, because when I compile my DSDT file, I’ve got some errors.

TrackPad.png

After that, before restarting
Modify VoodooPS2Controller.kext (the only one installed in L/E, don’t touch VoodooPS2 kext in EFI partition)
  • Right click on kext
  • Show Package Contents
  • Remove in Plugins folder: VoodooPS2Trackpad.kext and VoodooPS2Mouse.kext
Remember to fix KextCache with Hackintool.



iMessage and FaceTime
Code (Terminal):

Code:
defaults write com.apple.finder AppleShowAllFiles TRUE
killall Finder
cd ~/Library/Caches/
rm -R com.apple.Messages*
rm -R com.apple.imfoundation*
cd ~/Library/Preferences/
rm com.apple.iChat*
rm com.apple.imagent*
rm com.apple.imessage*
rm com.apple.imservice*
rm -R ~/Library/Messages/
defaults write com.apple.finder AppleShowAllFiles FALSE
killall Finder
Reboot

Continue and follow -> An iDiot's guide to iMessage

Use Mac15,1 in clover SMBIOS



POWER MANAGEMENT – HACKINTOOL

Go to Power section:
1) Fix Sleepimage button
2) Refresh button
All red lines, becomes green.

Tools Section: Tick on Enable HWP
Get AppleIntelInfo and verify the line enableHWP….: 1 – so it’s ok!



-----------------------------------------------------------------------------------------------------------------​



CLEANUP config.plist

Remove all lines in “DisabledAML” section in Acpi section
DisabledAML.png


FIX RESET BRIGHTNESS AFTER SYSTEM BOOTS UP -> Installing Fake Ambient Sensor

Download SSDT-ALS0.dsl ->compile in .aml and put in patched folder


XCPM

Download SSDT-XCPM.dsl, modify, compile and put aml file in patched folder.

XCPM_1.pngXCPM_2.png


I still have this issues(*):

Seeing intel Power Gadget, for a minute the PKG Power stay at 1.8 (with Wi-Fi and Bluetooth on), and another minuter it stay at 2.8. This for an infinite loop. Same thing without Wi-Fi and Bluetooth dongles. (1.6 to 2.6 this time)


PowerPKG_1.pngPowerPKG_2.png

Another issue that I have is that at system startup, my brightness level has not been saved. I’ve installed well my emulated NVRAM.

After installed SSDT-ALS0 for fake ambient sensor, I’ve set brightness level to 0 in config.plist. Same thing if, with PlistEdit, I leave the line blank. If I remove the line, at startup I’ve brightness level set to 100%.


BrightnessProblem.png




AESTHETIC FEATURE

Chime Sound at startup

(you can download Chime.aiff at the bottom of the topic)

https://www.tonymacx86.com/threads/diy-startup-sound-a-clean-way-to-do.184732/

6 seconds for me is the best setup: Change ThrottleInterval line of com.hackintosh.sound.plist (Use Plist Edit Pro)


Windows 10 time

Open regedit in Windows and go to
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TimeZoneInformation
Create new dword-32 with name "RealTimeIsUniversal" with "1" value.
If you have a problem with Microsoft Store, modify date to some say before and disable automatic time update. Reboot. Try to re-open MS Store, and enable again automatic data/clock.


Power Charging Sound Effect

Use this code in terminal:

Code:
defaults write com.apple.PowerChime ChimeOnAllHardware -bool true; open /System/Library/CoreServices/PowerChime.app &




Some TIPS

How to write ~in MacOS= WinKey + 5

Remove Automount NTFS for some disk/partitions:
sudo nano /etc/fstab
UUID=*****-*****-***** none ntfs rw,noauto
CTRL+X for save

(See your UUID with Disk Utility)

.aml in .dsl

Download iasl
cd ~/Downloads
unzip iasl.zip
sudo cp iasl /usr/bin

Decompiling code command:
cd "Directory"
iasl -dl DSDT.aml SSDT*.aml

(use RehabMan MaciASL for edit and put all patch with his repo)





Hoping it was useful and my writing was clear. :angel: :wave:





Some benchmarks:


Schermata 2019-08-29 alle 05.58.53.pngSchermata 2019-08-29 alle 06.08.46.pngSchermata 2019-08-29 alle 06.09.49.png
 

Attachments

Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
13,023
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
iOS
if your hdmi is connected to the intel graphics, then you can use the hackintool to setup the connectors

and also your USB ports
 
Joined
Sep 13, 2017
Messages
114
Motherboard
MSI-PS63-8RC
CPU
i7‎-8565U‎
Graphics
UHD 620 - GTX 1050 max-q
Mac
MacBook Air
Mobile Phone
Android, iOS
Thanks, in fact in windows I see that my HDMI port is connected to Intel graphics.. but for work reasons I have no time to fix it now. For sure, when I'll do it, I will upload all files :thumbup:
 
Joined
Aug 26, 2019
Messages
5
Motherboard
MSI-PS63
CPU
i7‎-8565U
Graphics
UHD 620 / GTX 1050
Mobile Phone
Android
The boot argument agdpmod=vit9696 is required to disable board checks, since the MacBookPro15,1 doesn’t have an HDMI output, and would be ignored by the OS by default.
 
Joined
Aug 26, 2019
Messages
4
Motherboard
Lenovo Y740 (LNVNB161216)
CPU
i7-9750H
Graphics
RTX 2070 Max-Q
Mobile Phone
Android
Thank you so much for your work!

I'm planning on getting this laptop mostly for music production(the reason why I'm doing hackintosh i.e, to use logic pro x) & light gaming on windows, I just wonder if you got any issues with the audio output even after installing AppleALC? and also I'll most likely get the GTX-1650 version, will everything gonna work fine for me? thanks again!
 
Last edited:
Joined
Aug 26, 2019
Messages
4
Motherboard
Lenovo Y740 (LNVNB161216)
CPU
i7-9750H
Graphics
RTX 2070 Max-Q
Mobile Phone
Android
The boot argument agdpmod=vit9696 is required to disable board checks, since the MacBookPro15,1 doesn’t have an HDMI output, and would be ignored by the OS by default.
Hey GeneralDS!
Did you happened to install successfully?
 
Joined
Sep 13, 2017
Messages
114
Motherboard
MSI-PS63-8RC
CPU
i7‎-8565U‎
Graphics
UHD 620 - GTX 1050 max-q
Mac
MacBook Air
Mobile Phone
Android, iOS
Thank you so much for your work!

I'm planning on getting this laptop mostly for music production(the reason why I'm doing hackintosh i.e, to use logic pro x) & light gaming on windows, I just wonder if you got any issues with the audio output even after installing AppleALC? and also I'll most likely get the GTX-1650 version, will everything gonna work fine for me? thanks again!
No problems with Audio (except for audio in Headphones, but can be fixable using HDA configuration maybe)..you can take the 1650 version, doesn’t matter in hackintosh because you need to disable it anyway. But I can’t tell you if my files works with this version
 
Last edited:
Joined
Aug 26, 2019
Messages
4
Motherboard
Lenovo Y740 (LNVNB161216)
CPU
i7-9750H
Graphics
RTX 2070 Max-Q
Mobile Phone
Android
Ah bummer, but I'll try!
 
Joined
Aug 26, 2019
Messages
5
Motherboard
MSI-PS63
CPU
i7‎-8565U
Graphics
UHD 620 / GTX 1050
Mobile Phone
Android
Hey GeneralDS!
Did you happened to install successfully?
I took a different path than @Gius96, but I think it will solve the problem.
I don't have any problems with HDMI thanks to this solution.
 
Joined
Sep 13, 2017
Messages
114
Motherboard
MSI-PS63-8RC
CPU
i7‎-8565U‎
Graphics
UHD 620 - GTX 1050 max-q
Mac
MacBook Air
Mobile Phone
Android, iOS
I took a different path than @Gius96, but I think it will solve the problem.
I don't have any problems with HDMI thanks to this solution.
I tried, but unfortunately it doesn't work :(
 
Top