Contribute
Register

[Guide] Intel NUC7/NUC8 using Clover UEFI (NUC7i7Bxx,NUC8i7Bxx,etc)

Joined
Feb 24, 2019
Messages
16
Motherboard
Intel NUC8i5BEH
CPU
i5-8259U
Graphics
Iris Plus 655
Mac
MacBook Pro
Mobile Phone
Android
Can you try this config.plist? It eliminates a boot argument having to do with HDMI. Sorry, I can’t remember, did you ever try a different monitor?
@Leesureone, you rock! It is the screen. When I hooked up my LG monitor, things work just fine - no flickers.

So the culprit is Epson Powerlite 3010 projector - not compatible with Hackintosh (unless there's a magic kext you can recommend to me). And it makes sense that nobody else had this issue - it's a pretty uncommon setup. A quick google search tells me I'm the first person on the planet to try it. :)
 
Last edited:
Joined
Feb 21, 2010
Messages
1,668
Motherboard
Asus Rog Strix Z390 Gaming E
CPU
i9-9900K
Graphics
5700 XT
Mac
MacBook Air
Mobile Phone
Android
@Leesureone, you rock! It is the screen. When I hooked up my LG monitor, things work just fine - no flickers.

So the culprit is Epson Powerlite 3010 projector - not compatible with Hackintosh (unless there's a magic kext you can recommend to me). And it makes sense that nobody else had this issue - it's a pretty uncommon setup. A quick google search tells me I'm the first person on the planet to try it. :)
Awsome. Sorry I didn't suggest it earlier!
 
Joined
Feb 24, 2019
Messages
16
Motherboard
Intel NUC8i5BEH
CPU
i5-8259U
Graphics
Iris Plus 655
Mac
MacBook Pro
Mobile Phone
Android
Awsome. Sorry I didn't suggest it earlier!
I'd never think a screen would make a difference. And there was so much variance with different plists, kexts, and macOS version, and more noticeably - different video files, I was sure the solution lays somewhere on the graphics hardware drivers side.

I wonder if anybody else had issue with various monitors/screens and found solutions.
 
Joined
Feb 21, 2010
Messages
1,668
Motherboard
Asus Rog Strix Z390 Gaming E
CPU
i9-9900K
Graphics
5700 XT
Mac
MacBook Air
Mobile Phone
Android
I'd never think a screen would make a difference. And there was so much variance with different plists, kexts, and macOS version, and more noticeably - different video files, I was sure the solution lays somewhere on the graphics hardware drivers side.

I wonder if anybody else had issue with various monitors/screens and found solutions.
You would be surprised, display is one of the most common issues posted about in the various forums for different and more or less complex reasons. Display port is generally reccomended as the output of choice for best results but not always an option. There have also quite a few reported monitor problems relating to 4K resolution, some work, some don't, but I've never seen any overview of why. Just basic suggestions of what to try.
 
Last edited:
Joined
Dec 20, 2018
Messages
38
Motherboard
NUC 7i7DNHE
CPU
i7
Graphics
UHD 620
Mac
MacBook Pro
Hi folks, another question...I upgrades my NUC7 from Mojave to Catalina. Everything seems to work, but iMovie doesn't work now. Says no graphics acceleration. Is there something I need to set in order to get this working?

Thanks.
 
Joined
Feb 21, 2010
Messages
1,668
Motherboard
Asus Rog Strix Z390 Gaming E
CPU
i9-9900K
Graphics
5700 XT
Mac
MacBook Air
Mobile Phone
Android
Hi folks, another question...I upgrades my NUC7 from Mojave to Catalina. Everything seems to work, but iMovie doesn't work now. Says no graphics acceleration. Is there something I need to set in order to get this working?

Thanks.
See below from the home page, it’s possible you need to update Whatevergreen.kext. If that doesn’t work take a screen shot of “About This Mac” showing the graphics information and post it.

What we know about the 10.15.1 Update so far...
  • macOS Build 19B88
  • Updated Intel and AMD graphics drivers
    • Initial support for AMD Navi graphics cards
    • AMD users may need to update to WhateverGreen 1.3.4
  • Updated audio drivers- established users of Catalina with AppleALC or VoodooHDA should not need to update.
  • Updated USB drivers- those using Port Limit Removal patch may have to update to new patches for 10.15.1
  • Install macOS Catalina App has been updated - If you downloaded macOS Catalina from the App Store prior to today, and you want to have the latest version on your backup installer USB, simply log into the Mac App Store and click Download. The updated Install macOS Catalina App can be found in the Applications folder.
Testing is now underway- this post will be updated. Good luck, and let us know how it goes! Report your results here.
 
Joined
Dec 20, 2018
Messages
38
Motherboard
NUC 7i7DNHE
CPU
i7
Graphics
UHD 620
Mac
MacBook Pro
See below from the home page, it’s possible you need to update Whatevergreen.kext. If that doesn’t work take a screen shot of “About This Mac” showing the graphics information and post it.

What we know about the 10.15.1 Update so far...
  • macOS Build 19B88
  • Updated Intel and AMD graphics drivers
    • Initial support for AMD Navi graphics cards
    • AMD users may need to update to WhateverGreen 1.3.4
  • Updated audio drivers- established users of Catalina with AppleALC or VoodooHDA should not need to update.
  • Updated USB drivers- those using Port Limit Removal patch may have to update to new patches for 10.15.1
  • Install macOS Catalina App has been updated - If you downloaded macOS Catalina from the App Store prior to today, and you want to have the latest version on your backup installer USB, simply log into the Mac App Store and click Download. The updated Install macOS Catalina App can be found in the Applications folder.
Testing is now underway- this post will be updated. Good luck, and let us know how it goes! Report your results here.
 

Attachments

Joined
Feb 21, 2010
Messages
1,668
Motherboard
Asus Rog Strix Z390 Gaming E
CPU
i9-9900K
Graphics
5700 XT
Mac
MacBook Air
Mobile Phone
Android
Your intel graphics aren't being identified correctly, see my about this Mac for an example of what I mean. Did you update Whatevergreen.kext?
About This Mac.png
 
Joined
Sep 21, 2018
Messages
21
Motherboard
Intel NUC8i7BEH
CPU
i7-8859U
Graphics
Iris Plus 655
I am running Mojave on my NUC8i7beh and I am experiencing this weird issue with sleep: when I try to put the machine to sleep for the first time, the monitor sleeps OK, but 1-2 seconds after the NUC itself goes to sleep, it wakes up again by itself (monitor still stays off). If I press a key/click the mouse, the screen wakes up and I can log back in. All sleep attempts after that work fine (monitor sleeps and a few seconds later the NUC goes to sleep). Wake from sleep is also working OK.

Any ideas what might be causing this?

Also, has anyone actually managed to get *hibernation* working? It is a feature I would love to have, since I take my NUC to my office every day. If someone is interested in debugging this I'd be happy to share my findings so far (after a lot of experimentation).
 
Top