Contribute
Register

[Guide] How to fix non working audio alc898 driver with applealc

Status
Not open for further replies.
Joined
Aug 4, 2013
Messages
202
Motherboard
ASUS G531GT
CPU
i5-9300H
Graphics
UHD 630+GTX 1650
First of all I am using CLEVO P65xRS series laptop and my layout-id is 65 if yours is different try to find your own layout id https://github.com/acidanthera/AppleALC/wiki/Supported-codecs
I open that guide because I find that fix accidentally and there are no other thread on anywhere
If you have alc898 driver and you cant use microphone or etc you need to try that
Also before you do that remove all sound related kext you installed before


Instructions:
1-) Download AppleALC kext https://github.com/acidanthera/AppleALC/releases from here
2-) Download multibeast https://www.tonymacx86.com/resources/categories/tonymacx86-downloads.3/ from here
3-) Put AppleALC kext on Clover kexts others folder then restart computer open sound settings if you can see your sound devices on here ( It doesnt metter on that point you got working audio) YOU HAVE TO skip step 4 if you are not try step 4
4-) Open System/Library/Extensions copy AppleHDA (dont delete it) put it on clover/kext/others folder reboot if still it wont recognize it move apple hda from System/Library/Extensions reboot and reinstall it with any kext utility.
5-) After that open multibeast select your audio codec its under drivers section (mine was alc898 so I selected mine if yours different then select yours). Then install
6-) Open Library Extensions (not system)and Remove RealtekALC.kext
Then Restart
7-) Use clover confugirator an edit your config.plist on your efi folder. open devices section type your layout id on audio part and select ResetHDA (try layout ids for your card https://github.com/acidanthera/AppleALC/wiki/Supported-codecs) and save then restart. Try it again until you find your proper layout id.
I hope it works good luck.
 
Joined
Jul 18, 2020
Messages
1
Motherboard
Gigabyte GA-Z77X-UP5 TH LGA 1155
CPU
Intel Core i7
Graphics
EVGA GeForce GTX 570 HD
I've been trying to fix the audio for over a month after upgrading to Mojave and this is the guide that worked!

Thank you thank you!
 
Status
Not open for further replies.
Top