Contribute
Register

[Guide] El Capitan on the Intel Broadwell NUC

Joined
Oct 5, 2013
Messages
32
Motherboard
Intel NUC i7 RYH
CPU
i7
Graphics
Iris 6100
As long as you have the most recent Clover that can boot 10.12.4, yes, just update via the app store.

There were certain versions of Sierra in which the on-board bluetooth worked, and then it stopped working again. That's a crap shoot, maybe it works maybe it doesn't. Everything else works as the original post mentions.
 
Joined
Feb 3, 2016
Messages
7
Mac
Classic Mac
Mobile Phone
As long as you have the most recent Clover that can boot 10.12.4, yes, just update via the app store.

There were certain versions of Sierra in which the on-board bluetooth worked, and then it stopped working again. That's a crap shoot, maybe it works maybe it doesn't. Everything else works as the original post mentions.

Hi xauyd ,
Many thanks for the reply , last night I made update as updated clover bootloader, inserted fakesmc file and restarted everything !! Everything perfect, fantastic in sierra update. When not working sound card ... any advice on how to proceed correctly in order to reinstall the sound card? thank you ;-)
 
Joined
Feb 3, 2016
Messages
7
Mac
Classic Mac
Mobile Phone
:banghead::thumbdown NO Audio .....
.. I made many trials and installations but nothing! speaker symbol appears but nothing !!!!! can someone help me for exact procedure? Thanks in advance
Sierra OSX v.10.12.1 - NUC 5i3RYH
 
Joined
Jan 17, 2016
Messages
1
Mac
Classic Mac
Mobile Phone
:banghead::thumbdown NO Audio .....
.. I made many trials and installations but nothing! speaker symbol appears but nothing !!!!! can someone help me for exact procedure? Thanks in advance
Sierra OSX v.10.12.1 - NUC 5i3RYH

Are you sure you have the right output selected in System Preferences - Sound?
You may have the wrong output selected, like HDMI instead of Headphone Out.
 
Joined
Nov 12, 2015
Messages
10
Motherboard
Intel NUC5i7RYH
CPU
Intel® Core™ i7-5557U
Graphics
Intel® Iris™ Graphics 6100
Mac
  1. Mac mini
Mobile Phone
  1. Android
  2. iOS
Like an above poster, I am also missing sound after updating to Sierra. I have the NUC5i7. I have a television attached via HDMI, and I did not have an issue with sound before upgrading to Sierra from El Capitan.

There are no audio outputs detected in system preferences. I tried plugging in headphones and I had the same result. I've tried the Midi settings in utilities, but there is nothing to do because no audio outputs are detected.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,161
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Like an above poster, I am also missing sound after updating to Sierra. I have the NUC5i7. I have a television attached via HDMI, and I did not have an issue with sound before upgrading to Sierra from El Capitan.

There are no audio outputs detected in system preferences. I tried plugging in headphones and I had the same result. I've tried the Midi settings in utilities, but there is nothing to do because no audio outputs are detected.

See guide:
https://www.tonymacx86.com/threads/...clover-uefi-nuc5i5mhye-nuc5i3myhe-etc.191011/
 
Joined
Apr 8, 2011
Messages
7
Motherboard
Intel NUC5i3RYH
CPU
i3-5010U
Graphics
HD 5500
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I did a clean Sierra install on my NUC 5i3RYH. Everything works well, except for WiFi/Bluetooth...
Do you know if there is an USB combo adapter Wifi/Bluetooth that works?

Thanks!
 
Joined
Apr 8, 2011
Messages
7
Motherboard
Intel NUC5i3RYH
CPU
i3-5010U
Graphics
HD 5500
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi guys, I found a way to get bluetooth working without dual-booting with Windows. These are the steps:
- Just create a VM with Ubuntu or Windows (I used VMware Fusion but maybe will works also with VirtualBox)
- connect the Bluetooth device (seen in MacOS as USB) to VM
- enable Bluetooth in VM
- Shutdown the VM

That's all! :mrgreen:

I also tried shutting down the NUC, and it continues to work at next boot
 
Last edited:
Joined
Jan 1, 2016
Messages
27
Motherboard
Intel NUC 5i5 RYB
CPU
Core i5 1.6 GHz
Graphics
Intel HD Graphics 6000
Mac
  1. iMac
Mobile Phone
  1. Android
First of all, thank you for the excellent installation manual. Spend time, etc. But to the sound I have one piece of information that will surely please the lovers of music and Apple's sound. Enhanced pleasure, beginners may be disappointed. The disappointment will be that the sound of the ALC283 must go from the beginning through Linux using codecdump. I now warn that my data is valid for NUC 5i5 RYB sold in Slovakia (not RYH), so the Linux codecdump output will be different for each model. Already on the third machine, it occurred to me that Mirone's patch is absolutely irritating because the codec is not identical to its variant. The number of issues, revisions, and OEM changes to sound cards are about normal. When you make an analysis of the ALC283 variants in another excellently crafted AppleALC.kext and Lilu.kext, info.plist, platform.xml and layout.xml, you will find that if it accidentally produces sound - even disastrous, including downtime, it's just a happy match coincidences. The most recent ApleALC.kext in its pinconfig has three versions for ALC283, only the Mirone version is closest to my version.
Here's the detail of the comparison.

AppleALC.kext - pinconfigs from info.plist
ALC configdata - Mirone 78 - layoutId 3
01271C10 01271D01 01271EA0 01271F90
01471C20 01471D01 01471E17 01471F90
01971C30 01971D00 01971E8B 01971F00
02171C40 02171D10 02171E2B 02171F01 01470C02 02170C02

ALC configdata - Slbomber 79 - layoutId 11
01271C10 01271D01 01271EA0 01271F90
01471C40 01471D01 01471E17 01471F90
01771CF0 01771D00 01771E00 01771F40
01871CF0 01871D00 01871E00 01871F40
01971CF0 01971D00 01971E00 01971F40
01A71CF0 01A71D00 01A71E00 01A71F00
01B71CF0 01B71D00 01B71E00 01B71F40
01D71CF0 01D71D00 01D71E00 01D71F40
01E71CF0 01E71D00 01E71E00 01E71F40
02171C50 02171D10 02171E21 02171F03 01470C02 02170C02

ASRock DeskMini 110 - 80 - LayoutId 66
01271C80 01271D00 01271E00 01271F40
01471C40 01471D01 01471E13 01471F90
01A71C20 01A71D90 01A71E81 01A71F01
01D71C60 01D71D90 01D71E55 01D71F40
02171C50 02171D10 02171E21 02171F01 01470C02 02170C02

My model ALC283
Verbs from Linux Codec Dump File: codec_dump.txt
Codec: Realtek ALC283 Address: 0 DevID: 283902595 (0x10ec0283)
Jack Color Description Node PinDefault Original Verbs
--------------------------------------------------------------------------------------------
PinConfigurator output - + EAPD for output
01971c00 01971d10 01971e81 01971f01
02171c10 02171d10 02171e21 02171f01 01470C02 02170C02
--------------------------------------------------------------
01971c00 01971d10 01971e81 01971f01 02171c10 02171d10 02171e21 02171f01 01470C02 02170C02

But I have had problems with the right channel of the audio. It helped a bit through the midi setup, but it did not last, plus a volume control problem. The second patch - letting the audio settings on input devices - I have a line-in port (no MICs) in Windows 10, has led me to suspect that it is missing in info.plist EAPD for inputs, not just for outputs.
Luckily I was right and finally after 3 days of experiments and restart I found that the ALC283 headphones have a god's sound - I use the Fiio X5 as a headphone amplifier as a DAC, and the difference in quality is unreachable.
Also, the overall sound quality, including HDMI, is identical to the Windows 10 sound, which I consider to be the equivalent of quality.

PinConfigurator output Final +EAPD for input and output
01971c00 01971d10 01971e81 01971f01 01470C02 02170C02
02171c10 02171d10 02171e21 02171f01 01470C02 02170C02

01971c00 01971d10 01971e81 01971f01 01470C02 02170C02 02171c10 02171d10 02171e21 02171f01 01470C02 02170C02
 

Attachments

  • PinConfigurator Outputs.png
    PinConfigurator Outputs.png
    180.5 KB · Views: 134
  • platforms and layout.xml  Changes.png
    platforms and layout.xml Changes.png
    486.1 KB · Views: 128
  • XML FINAL OK.zip
    8.3 KB · Views: 46
  • Windows 10 Sound Inputs.jpg
    Windows 10 Sound Inputs.jpg
    37.3 KB · Views: 121
  • Windows 10 Sound Outputs.jpg
    Windows 10 Sound Outputs.jpg
    57.2 KB · Views: 118
Last edited:
Joined
Jun 22, 2017
Messages
1
Did anyone find a fix for the integrated bluetooth draining batteries quickly? I'm losing about 10% a day on the latest Magic Keyboard and Magic Trackpad.

Not a huge issue but curious if anyone has found a solution. I'm on Sierra on the i7 NUC. Thanks!
 
Top