Contribute
Register

GTX 970 / GTX 980 are here

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
23,246
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
I bought and installed this card http://www.amazon.com/dp/B00NT9UT3M/ref=as_li_ss_tl?ie=UTF8&tag=tonymacx86com-20 and did a clean install of Yosemite on my -UD7.

Unigine Valley for Win7 = file:///Users/epan/Desktop/Unigine_Valley_Benchmark_1.0_20141221_1158.html

Unigine Valley for Yosemite = file:///Users/epan/Desktop/Unigine_Valley_Benchmark_1.0_20141221_1455.html

difference is probably due to Direct3D11 vs openGL.

Unigine Valley for Win10 + 1080P display:
[h=1]Unigine Valley Benchmark 1.0[/h]
FPS: 114.0
Score: 4769
Min FPS: 5.5
Max FPS: 207.5

[h=2]System[/h]
Platform: Windows 8 (build 9200) 64bit
CPU model: Intel(R) Core(TM) i7-5930K CPU @ 3.50GHz (3498MHz) x6
GPU model: NVIDIA GeForce GTX 980 9.18.13.4411 (4095MB) x1

[h=2]Settings[/h]
Render: Direct3D11
Mode: 1920x1080 fullscreen
Preset Custom
Quality High

Powered by UNIGINE Engine
Unigine Corp. © 2005-2013


Unigine Valley Win10 with 4K Dell display:
 
Joined
Jul 29, 2012
Messages
46
Motherboard
ASUS ROG Maximus X Hero (Wi-Fi AC)
CPU
i7-8700K
Graphics
GTX 1080 Ti
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Thanks for everybody's help in this thread. Just bought a Gigabyte GTX 980, installed the latest nvidia drivers for Yosemite 10.10.1, installed the CUDA drivers, put the nvda_drv=1 boot flag in the org.chameleon.plist, shut down, removed my gtx 770, put in the gtx 980 turned the tower on and voila, perfect boot.

However a quick question about the nvidia utility. I installed 343.01.02f01 as that was the latest linked on here. When i installed it, I immediately got notified about an update to 343.02.01f01. So I googled that version number and literally no results came up for it. Checked the nvidia website, no results. Has anyone used this or know anything about this update and whether or not it is worth updating to it? Thanks for the help guys. Love this community!
Screen Shot 2014-12-22 at 7.40.15 PM.png
 
Joined
Jun 26, 2012
Messages
55
Motherboard
Gigabyte Z390 Designare BIOS F9i
CPU
i9-9900K
Graphics
RX 6900 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
  2. Power Mac
  3. PowerBook
  4. Quadra
  5. SE
Mobile Phone
  1. Android
However a quick question about the nvidia utility. I installed 343.01.02f01 as that was the latest linked on here. When i installed it, I immediately got notified about an update to 343.02.01f01. So I googled that version number and literally no results came up for it. Checked the nvidia website, no results. Has anyone used this or know anything about this update and whether or not it is worth updating to it? Thanks for the help guys. Love this community!

I'm using this version right now. Works very well, no issue.
 
Joined
Jul 29, 2012
Messages
46
Motherboard
ASUS ROG Maximus X Hero (Wi-Fi AC)
CPU
i7-8700K
Graphics
GTX 1080 Ti
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
I'm using this version right now. Works very well, no issue.

Good news. Do you know what changes were made in it? I was very surprised when there was absolutely no mention of it and no google results for it whatsoever when i searched for it. So I'd like to know if it is even needed to update to frivolously lol
 
Joined
Nov 25, 2011
Messages
32
Motherboard
Gigabyte GA-Z77X-UD5H LGA 1155 Z77 ATX Motherboard
CPU
Intel Core i7 3770K 3.5GHz LGA 1155 Processor
Graphics
EVGA NVIDIA GeForce GTX 980 SC
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac Pro
Classic Mac
  1. Classic
  2. iMac
  3. Performa
  4. Power Mac
Mobile Phone
  1. iOS
I just installed NVidia Mac OS X Web Drivers with my old 660 Ti still installed on my GA-Z77X-UD5H motherboard.

Followed Tonymac's instructions:
http://www.tonymacx86.com/graphics/...1-01-maxwell-geforce-gtx-970-980-support.html

I changed the org.chameleon.Boot.plist using Chameleon Wizard 2 ( nv_disable=1 to nvda_drv=1 and added kext-dev-mode=1) then shutdown and swapped in the gtx 980 - Rebooted into bios. Changed Peripherals -> Init Display First to PCI- Saved and Exited

It booted with no problems and when it finished the Nvidia Driver Manager immediately wanted to install an update.
I also checked the CUDA preference pane and it said an update was available but after it finished installing the 6.5.33 update it stated both "Update Required" but "No newer CUDA Driver available." Clearly there are CUDA issues still. . .

Also only the Mac pro 3,1 smbios works for me so far.
I tried Mac Pro 5,1 and got a kernel panic on reboot.
Might give iMac 13,2 & 14,2 a try.

The CUDAZ ver 0.9.231 shows card working but CUDA Performance tab is blank. Also after effects gives CUDA errors when trying to preview a comp with ray tracing in it.

I also noticed the heaven benchmark tops out at 60fps regardless of the setting medium through extreme.


So I tried this fix on Netkas http://forum.netkas.org/index.php?PHPSESSID=bl3psjk66pvk27ui83aj7h271s9isopg&topic=8674.0

and it looks like it fixed a few things. . .

CUDA-Z - CUDA performance tab now working - 5598 GFlops/s!!
Need to download the CUDAZ Beta Version here
http://sourceforge.net/projects/cuda-z/files/cuda-z/Beta/

Luxmark
Medium - 2657
Complex - 1478

Unigine Valley benchmark is higher after running Netkas fix but not at the performance level on Windows. . .(90FPS)
FPS: 73.1
Score: 3058


Premiere Pro CC 2014 Let's you Start a new project with OpenGL or CUDA - Need to test Further.

Updated "raytracer_supported_cards.txt" file to included "GeForce GTX 980"
sudo nano /Applications/Adobe\ After\ Effects\ CC\ 2014/Adobe\ After\ Effects\ CC\ 2014.app/Contents/raytracer_supported_cards.txt

After Effects CC 2014 shows the GTX 980 as a Unsupported Card in Preferences ->Previews -> GPU Infomation

OpenGL is Box still showing the card and seems works fine. Scrubbing through a comp is smoother.

CUDA Box shows the Card now but when you render a project with Ray Tracing enabled you get Ray-Trace Errors. . .
So we'll probably have to wait for Adobe or Nvidia to fix this one. . . .

BruceX FCPX Benchmark
http://blog.alex4d.com/2013/10/30/brucex-a-new-fcpx-benchmark/
Avg after 3 Renders - 64 Seconds

DaVinci Resolve 11 Lite
60fps Playback with Arri Alexa 24P Footage
ABout twice as fast as my 660ti

Everything looks promising!!
 

Attachments

  • Screen Shot 2014-12-23 at 5.44.56 PM.png
    Screen Shot 2014-12-23 at 5.44.56 PM.png
    71.5 KB · Views: 126
  • Screen Shot 2014-12-23 at 5.51.38 PM.png
    Screen Shot 2014-12-23 at 5.51.38 PM.png
    69.3 KB · Views: 142
  • Screen Shot 2014-12-23 at 7.58.28 PM.png
    Screen Shot 2014-12-23 at 7.58.28 PM.png
    130.6 KB · Views: 222
  • Screen Shot 2014-12-23 at 8.34.47 PM.jpg
    Screen Shot 2014-12-23 at 8.34.47 PM.jpg
    146.7 KB · Views: 259
  • Screen Shot 2014-12-24 at 2.32.12 AM.png
    Screen Shot 2014-12-24 at 2.32.12 AM.png
    66.6 KB · Views: 159
Joined
Jun 26, 2012
Messages
55
Motherboard
Gigabyte Z390 Designare BIOS F9i
CPU
i9-9900K
Graphics
RX 6900 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
  2. Power Mac
  3. PowerBook
  4. Quadra
  5. SE
Mobile Phone
  1. Android
Good news. Do you know what changes were made in it? I was very surprised when there was absolutely no mention of it and no google results for it whatsoever when i searched for it. So I'd like to know if it is even needed to update to frivolously lol

It just came along when I switched from GTX680 to GTX980, so I took it.
Can't tell you the difference with prior versions.
 
Joined
Jul 29, 2012
Messages
46
Motherboard
ASUS ROG Maximus X Hero (Wi-Fi AC)
CPU
i7-8700K
Graphics
GTX 1080 Ti
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
It just came along when I switched from GTX680 to GTX980, so I took it.
Can't tell you the difference with prior versions.

Ya the same happened with me switching from the 770 to the 980. I installed it and everything is fine for me as well. Thanks for the information :)

On another note, I know in windows you can turn off the blue Windforce led light using the Nvidia Experience software. Is there anyway to disable it in OS X using software? I noticed there is a simple little cord I think I could unplug to turn off the light, but it looks like I'd have to disassemble to top of the card to be able to reach it, so I'd prefer a software solution to avoid doing that.
 
Joined
Dec 16, 2012
Messages
82
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I installed a Gainward GTX 980 Phantom 4GB during the week, and it's working perfectly.

I had two Gigabyte GTX 670 2GB OC cards previously, and was already running the nVidia driver, so it was just a simple swap out for me. I was happy with the 670's except that I had screen glitches in Yosemite on my second cinema display that I couldn't resolve. That was when running a screen on each card's single display port using a mini display port to display port adapter.

I chose the Gainward because (i) it was well priced, and (ii) it has 3x mini display port connectors (plus a mini HDMI and DVI) so I can connect my 24" cinema displays directly with no adaptors. Works great in Yosemite, Windows 7, Windows 8 and Ubuntu 14.04 LTS. Just one minor glitch - when I first boot into Windows 7 the primary screen is distorted, however to resolve this I simply enter my password to log in, unplug and re-plug the display, then all is fine. Hopefully a driver update will eventually resolve this.
 
Joined
Oct 18, 2012
Messages
48
Motherboard
GA-Z97X-UD3H-BK
CPU
i7-4770K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
I freshly installed Gainward 970 GTX, it seems that all is working fine AFTER i set UseKernelCache=No in my Boot.plist.

Is there any way to avoid this ? What is the impact to set this to No ?

Then i too have the Cuda issue, as performance pane is empty in Cuda-Z. So help welcome :)

Thx and Merry Xmas :p
 

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
23,246
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
Since I wasn't able to get the GTX980 working in the X99M Killer, I put it in the GA-X58A-UD7.
Installed Yosemite, installed web drivers, installed GTX980.

Works great so far as I can tell, but Unigine Valley crashes as soon as it begins to run.
Going to try Luxmark next.
 
Top