Contribute
Register

GTX 1060 performance on 10.13 High Sierra

Status
Not open for further replies.
Joined
Jul 24, 2015
Messages
2,234
Motherboard
MSI H81i
CPU
i5-4570
Graphics
RX 580
I think that makes sense for Nvidia, get their foot in the door again - they haven't been getting any action in authentic apple hardware for a while now I believe?
Either way, I'm curious to see your config.plist if you can share? Also, do you have any custom DSDT/SSDT outside of clover patching?
Just speculating that changes Apple make to the graphics in macOS to better accommodate GPU's cropping up as secondary display devices might affect their use as the main display - probably more so with last 2 generation Nvidia cards as there are no system drivers. Something is being done differently in 10.13 anyway.
 

Attachments

  • CLOVER.zip
    1.4 MB · Views: 68
Joined
Dec 11, 2017
Messages
3
Motherboard
Rog STRIX Z370
CPU
8700k
Graphics
EVGA 1080ti ftw3
Hi, just my two pennys worth.

Running HS 10.13.2 with latest Nvidia web drivers. 1080Ti on a i7 8700k - I've come from a late 2013 13" MBP with IRIS graphics, so the Finder perf seems OK here, window re-size, scrolling, animation etc. Dual monitor setup. SysInf reports PCI x16 2.5GT/s OK but deffo have issues with driver - as I thinks been mentioned in this thread somewhere, when the GPU is being taxed (fairly heavily) the machine will just dump out to the boot screen. Crash logs show a WindowServer crash with
this in the log.. pretty much any issues I have with my hack are GPU / Nvidia related. which is a shame as its the reason for going to a Hack in the first place :0(

Code:
Process:               WindowServer [200]
Path:                  /System/Library/PrivateFrameworks/SkyLight.framework/Versions/A/Resources/WindowServer
Identifier:            WindowServer
Version:               600.00 (312.23.4)
Code Type:             X86-64 (Native)
Parent Process:        launchd [1]
Responsible:           WindowServer [200]
User ID:               88

Date/Time:             2018-01-01 21:54:01.181 +0000
OS Version:            Mac OS X 10.13.2 (17C88)
Report Version:        12
Anonymous UUID:        972A00FD-1C84-E5CE-7DC9-46FDB1BC6893


Time Awake Since Boot: 2000 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Application Specific Information:
StartTime:2018-01-01 21:20:53
GPU:NV
MetalDevice for accelerator(0x2d2f): 0x7f91bfe05c58 (MTLDevice: 0x7f91c0854000)
IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/PEG0@1/IOPP/PEGP@0/NVDA,Display-D@3/NVDA
IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/PEG0@1/IOPP/PEGP@0/NVDA,Display-A@0/NVDA
Assertion failed: (false && "10 seconds of continuous GPU Driver unreadiness, relaunching WindowServer"), function IMGGraphicsStackReadinessFailure, file /BuildRoot/Library/Caches/com.apple.xbs/Sources/SkyLight/SkyLight-312.23.4/SkyLight/Server/Windows/Updater.cc, line 3052.
 
Joined
Jul 31, 2012
Messages
113
Motherboard
ASUS STRIX Z370G
CPU
i7-8700K
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Just speculating that changes Apple make to the graphics in macOS to better accommodate GPU's cropping up as secondary display devices might affect their use as the main display - probably more so with last 2 generation Nvidia cards as there are no system drivers. Something is being done differently in 10.13 anyway.

thanks for sharing!

very custom DSDT & SSDT :) curious, why did you define your GFX0 in DSDT and not SSDT? POP2 seems like an unusual name, did that exist in your dumped DSDT?

you don't use <key>NvidiaWeb</key> ?
 
Joined
Jul 24, 2015
Messages
2,234
Motherboard
MSI H81i
CPU
i5-4570
Graphics
RX 580
Crash logs show a WindowServer crash with
this in the log.. pretty much any issues I have with my hack are GPU / Nvidia related.
What other errors are you getting at this time?
Code:
log show --start "2018-01-01 21:44:01" --end "2018-01-01 22:04:01" > ~/windowservercrash.log
very custom DSDT & SSDT :) curious, why did you define your GFX0 in DSDT and not SSDT? POP2 seems like an unusual name, did that exist in your dumped DSDT?
The OEM DSDT is being replaced and the OEM SSDTs dropped so which file doesn't matter, one file is easier to maintain. iMac14,2 uses P0P2 but i doubt the name of the port makes a difference, OEM is PEG0.
you don't use <key>NvidiaWeb</key> ?
I have working nvram, using that setting sort of implies that removing it will mean the Nvidia drivers won't be used, but it's all down to the nvda_drv=1 nvram variable (which Clover sets if it isn't already when it finds NvidiaWeb=true)
 
Joined
Dec 11, 2017
Messages
3
Motherboard
Rog STRIX Z370
CPU
8700k
Graphics
EVGA 1080ti ftw3
What other errors are you getting at this time?

I was getting a boot issue with both monitors in the card (DVI-D & HDMI), where it would get 2/3 through boot the either go to black screen or the prohibited symbol - I could boot successfully with one monitor in then plug the second when logged in. Sorted that one by enabling CSM in BIOS (on a Rog Strix z370-g). I also have graphics related errors in certain webGL applications (SketchFab) - where the WebGL window is Whited out - it all there, its sort of an inverted Vignette you can see stuff round the edges. but mainly its this crash straight out to boot screen. I just tried running Heaven benchmark on xtreme/ ultra settings 4 times over and it seemed fine, getting good scores - I wonder if the issue is CUDA related? The intention was that I use the card for GPU rendering within Sketchup, so thats where I've been testing it, with VRay. I'll try another renderer, maybe Octane to test it.
 
Joined
Oct 22, 2013
Messages
12
Motherboard
Gigabyte GA-Z68X-UD4-B3
CPU
i5 2500k (4.0)
Graphics
Gigabyte GTX 1070 G1 Gaming
Hi there,
I have 1070 working fine in OS, in GB and other benchmarks show 60-150 fps:

Screen Shot 2018-01-02 at 19.35.47.png

But in game (Fortnite for example or any Steam game) I have 1-2 fps :)
Chess app and experiments like google water working great.
I have latest 378.10.10.10.25.102 web drivers installed and latest CUDA 387.99

Screen Shot 2018-01-02 at 20.17.01.png

What should I do to improve in-game performance?
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
25,732
Motherboard
Lenovo ThinkStation p700
CPU
2x E5-2620 V3
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
I have 1070 working fine in OS, in GB and other benchmarks show 60-150 fps:
Off topic - This thread is for GTX 1060 - See title.
 
Joined
Jul 24, 2015
Messages
2,234
Motherboard
MSI H81i
CPU
i5-4570
Graphics
RX 580
I was getting a boot issue with both monitors in the card (DVI-D & HDMI), where it would get 2/3 through boot the either go to black screen or the prohibited symbol - I could boot successfully with one monitor in then plug the second when logged in. Sorted that one by enabling CSM in BIOS (on a Rog Strix z370-g). I also have graphics related errors in certain webGL applications (SketchFab) - where the WebGL window is Whited out - it all there, its sort of an inverted Vignette you can see stuff round the edges. but mainly its this crash straight out to boot screen. I just tried running Heaven benchmark on xtreme/ ultra settings 4 times over and it seemed fine, getting good scores - I wonder if the issue is CUDA related? The intention was that I use the card for GPU rendering within Sketchup, so thats where I've been testing it, with VRay. I'll try another renderer, maybe Octane to test it.
I mean the crash report gives you some information. You can check the log for more information.
Code:
log show --start "2018-01-01 21:44:01" --end "2018-01-01 22:04:01" > ~/windowservercrash.log
 
Joined
Oct 22, 2013
Messages
12
Motherboard
Gigabyte GA-Z68X-UD4-B3
CPU
i5 2500k (4.0)
Graphics
Gigabyte GTX 1070 G1 Gaming
I guess this is not about card model, but more global problem with performance.
 
Joined
Mar 12, 2012
Messages
53
Motherboard
Asus ROG STRIX B360-I Gaming
CPU
i5-8500
Graphics
RX 570
Mobile Phone
  1. iOS
I guess this is not about card model, but more global problem with performance.

Exactly. This seems to be the issue with all Pascal-based GPUs under High Sierra OS...
 
Status
Not open for further replies.
Top