Contribute
Register

Gigabyte Z490 Vision D (Thunderbolt 3) + i5-10400 + AMD RX 580

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,914
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Guys, can't find the post about upgrade from BigSur to Monterey, including list of things which doesn't work in Monterey. I remember I saw it on the very first post, but now it's missing...
To upgrade from Big Sur to Monterey we need to be on OpenCore 0.7.6 or newer. Latest version is 0.7.7. Then we can perform an in-place upgrade from System Preferences --> Software Update.

For links to OpenCore 0.7.6 and 0.7.7 mini-guides please see the top of Post 1.
 
Joined
Dec 21, 2011
Messages
31
Motherboard
Gigabyte Z490 Vision D
CPU
i5 10500
Graphics
UHD 630 + RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
To upgrade from Big Sur to Monterey we need to be on OpenCore 0.7.6 or newer. Latest version is 0.7.7. Then we can perform an in-place upgrade from System Preferences --> Software Update.

For links to OpenCore 0.7.6 and 0.7.7 mini-guides please see the top of Post 1.

Thank you so much! Any recent update on Intel I-225V 2.5GbE Ethernet port? Does it still not working?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,914
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Thank you so much! Any recent update on Intel I-225V 2.5GbE Ethernet port? Does it still not working?
The I-225V works for some and not for most of us. Still haven't determined the cause... So it may or may not work for you.
 
Joined
Apr 18, 2021
Messages
13
Motherboard
Z490 vision D
CPU
Intel 10700k
Graphics
RX VEGA 64
I am writing with my F20 BIOS hackintosh. It is sucks. No BT at all, I can enable it. No SideCar, no reliable wifi. WT* is that thing? It destroyed my build.
F 20 was working well with me but sometimes I had to do recover bios ( bios F20 is not stable I don't know why) F21 is best than old version and stable so far. But I having issue with it that is not showing my graphic card info ( Vega 64 8 gig) on about Mac window plus you cannot go back to old bios version anymore add to that is not let system firmware version update with the newest one, still keep old version
 

Attachments

  • Screen Shot 2022-02-01 at 2.09.39 PM.png
    Screen Shot 2022-02-01 at 2.09.39 PM.png
    232.7 KB · Views: 23
  • Screen Shot 2022-02-01 at 2.10.14 PM.png
    Screen Shot 2022-02-01 at 2.10.14 PM.png
    246.5 KB · Views: 26
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,914
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
F 20 was working well with me but sometimes I had to do recover bios ( bios F20 is not stable I don't know why) F21 is best than old version and stable so far. But I having issue with it that is not showing my graphic card info ( Vega 64 8 gig) on about Mac window plus you cannot go back to old bios version anymore add to that is not let system firmware version update with the newest one, still keep old version
Two suggestions:
  • First try a cold boot (shutdown then flip power switch on PSU to OFF for 10 seconds; turn back on and boot macOS).
  • If problem persists, perform a CMOS Reset by following procedure in the Gigabyte manual. It will be necessary to configure all BIOS parameters afterwards, starting with F7 (Load Optimized Defaults).
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
25,932
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
@CaseySJ any suggestions on this image? I ran OCValidator and this one small error popped up and is related to the pci device properties tab.

"Original path: PciRoot(0x0)/Pci(0x1C,0x1)/Pci(0x0, 0x0)
Path after internal conversion: PciRoot(0x0)/Pci(0x1C,0x1)/Pci(0x0,0x0)
DeviceProperties->Add[0]->DevicePath is borked! Please check the information above!
CheckDeviceProperties returns 1 error!
Found 1 issue requiring attention."
upload your config.plist
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
18,914
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ any suggestions on this image? I ran OCValidator and this one small error popped up and is related to the pci device properties tab.

"Original path: PciRoot(0x0)/Pci(0x1C,0x1)/Pci(0x0, 0x0)
Path after internal conversion: PciRoot(0x0)/Pci(0x1C,0x1)/Pci(0x0,0x0)
DeviceProperties->Add[0]->DevicePath is borked! Please check the information above!
CheckDeviceProperties returns 1 error!
Found 1 issue requiring attention."
There cannot be any spaces in the PCI path. See that space near the end of this path?

PciRoot(0x0)/Pci(0x1C,0x1)/Pci(0x0, 0x0)

We need to remove it so it looks like this:

PciRoot(0x0)/Pci(0x1C,0x1)/Pci(0x0,0x0)
 
Top