Contribute
Register

G-sync no longer recognized after booting into OS X Yosemite

Status
Not open for further replies.
Joined
Feb 4, 2013
Messages
13
Motherboard
Asus ROG Strix Z370-F
CPU
i7-8700K
Graphics
GTX 1080 Ti
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
How do you disable and enable the drivers? Sounds like a way better solution than power cycling!
You can do that via Device Manager. Right click the device and Disable Driver.

I found that if you disable and enable the Nvidia drivers in Windows, G-Sync is recognized again (most of the time). Maybe it is possible to create a small software tool which disables and enables the driver after windows startup to enable G-Sync. Or maybe a small script which does the job, but I have no experience in such things
I tried it several times, it doesn't help.

Hey,
when I turn on G-Sync in OSX, G-Sync is also recognized when I restart to windows. So with enables G-Sync I do not have the problem of G-Sync recognition. G-Sync is always recognized in OSX and Windows as long as G-Sync is enabled in both systems.

But with enables G-Sync in OSX (my display also indicates active G-Sync), on fast movements I can see screen tearing. When I move a finder window very fast from left to right or when I scroll a long webpage very fast I can see screen tearing. I use 120hz refresh rate in OSX. Because of this issue I always turn G-Sync off in OSX and I have the problem with recognition.

I asked the Nvidia support about this issue and they replied that G-Sync is officially not supported on OSX, so they can not help me.

Regarding your screen tearing, you might want to try the latest Nvidia Web Driver .156. At least in the very brief minutes that G-Sync was working for me while I was in this driver version, I didn't experience any screen tearing. In contrast to driver version .104 where I did indeed experience screen tearing.

A few questions to you:
1. What MacOS version you have installed, preferably build number?
2. What Nvidia Web Driver version are you using?
3. What model is your GTX?
4. What refresh rate is your monitor configured in System Preferences -> Displays?

I had a feeling I need to enable G-Sync in MacOS in order to have it recognized in Windows 10. But, if I enable it, the system freezes completely within a few seconds and the only way out is restart. While G-Sync is enabled, once MacOS is starting again, it will freeze right after typing my password. So I'm left with only one option - Disabling G-Sync. I'm running Nvidia Web Driver .104 (the newest one causes terrible graphics lag) on MacOS High Sierra 10.13.3.

The only way I found to disable it though once MacOS becomes unusable is by disabling NVIDIA web driver in Clover boot screen and once I'm in MacOS, delete folder /Library/PreferencePanes/NVIDIA\ Driver\ Manager.prefPane and restart. Would be great to hear if there's a better way to do that.

There was a moment when I thought I managed to get it to work with G-Sync after I changed the monitor refresh rate to 144Hz (It was initially set to 60Hz). But, at some point after a few minutes it froze once again :/
 
Last edited:

foo

Joined
Aug 5, 2018
Messages
1
Motherboard
asus rog strix z3070-h gaming
CPU
i5-8600k
Graphics
gtx 1070
Mac
  1. MacBook Pro
Same problem here. I have enabled G-SYNC in OSX, and have not yet seen any issues with it. When booting to OSX, the G-SYNC is disabled until I log in. After login that the screen flickers once and G-SYNC is enabled.

In Win10 the disable/enable drivers seems to be the most convenient way to enable G-SYNC. Anyone know command line/powershell commands to disable and enable drivers? Might be easiest to put something like that in start-up-applications in Windows...

Oh yeah, latest Win10, OS, drivers, etc.

Edit:
Here's powershell script that I made to disable and enable the GTX drivers:
Code:
$d = Get-PnpDevice| where {$_.friendlyname -like "NVIDIA GeForce GTX*"}
$d  | Disable-PnpDevice -Confirm:$false
Start-Sleep -s 2
$d  | Enable-PnpDevice -Confirm:$false

... for some reason the disable/enable does not always help. But running the script a few times usually makes the trick. Also, you need to run the script as administrator.

Edit #2:
Disable/Enable has really poor success rate as an own, but I found another workaround. If I switch off my screen while windows is booting, and switch it on after a short moment, Windows seems to detect the the g-sync correctly. Same applies to disable/enable script; if I shutdown the screen immediately after clicking the script, the g-sync seems to get enabled more often.
 
Last edited:
Status
Not open for further replies.
Top