Contribute
Register

EVGA P55 SLI - USB Issue (SOLVED)

Joined
Aug 10, 2010
Messages
79
Motherboard
EVGA P55V
CPU
Intel i7 860
Graphics
Radeon 4890
Mac
  1. MacBook
Classic Mac
Mobile Phone
  1. Android
Hey Guys,

Not sure how many people here have build a hackintosh using the EVGA P55 SLI, let alone still using Snow Leopard, but for over 2 years I have had an issue with my USB ports and have recently fixed them.

When I first created the hackintosh I had issues with the USB's reading as Expansion Slots and not Built-in Ports. That was fixed soon after using an edited DSDT provided by Humph in an old post. http://legacy.tonymacx86.com/viewtopic.php?f=7&t=4475&start=20

But ever since I bought an iPhone it has been unable to sync or work with the computer. It would charge, but give itunes a spinning wheel of death and never work properly.

Last week my buddy who has the exact same build purchased a Razer Naga gamer mouse. The mouse requires the use of a program to set all the extra buttons, but although the computer recognizes the mouse, the program wouldn't.

After comparing our issues we figured that it had to be the USB ports. We compared EVERYTHING on our computers USB wise and found a fix after reading through a bunch of forums....and doing the exact opposite of what they suggested.

A lot of people need to do the USB Rollback in Multibeast to get USBs working properly, We had to roll up.

My buddy was using IOUSBFamily.kext version 2.4 or something while I was running version 4.2.4. After giving him the updated version and having him use Kext Utility to install it after removing the old one, his mouse and program worked 100%.

But there still was the issue of my iPhone...

Well I was using IOUSBMassStorageClass.kext version 2.6.7. My buddy was using version 2.6.1. Once I rolled back to 2.6.1 my iphone worked like a charge. Plugged it in and within 20 seconds everything was showing up on my computer.

So in conclusion...

If you are using this motherboard and on Snow Leopard 10.6.8 you need...

IOUSBFamily.kext version 4.2.4
IOUSBMassStorageClass.kext version 2.6.1

Hope this helped a few of you.

Cheers,

~ Midsyde
 
Joined
May 21, 2010
Messages
4,071
Motherboard
GA-EX58-UD3R-SLI
CPU
XEON x5570
Graphics
NVidia 9600GT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. SE
Mobile Phone
  1. Android
Midsyde

Wondered if you could update your post with the how you established the versions of the files and locations where located.
Some of the issues are that these are hidden kexts - Also where the replacements came from. etc.
This would be a help to me and others.
Thanks
 
Top