Contribute
Register

Direct Update to macOS Sierra using Clover

Joined
Jul 19, 2016
Messages
26
Motherboard
MSI B85M Gaming
CPU
Intel Core i5 3.20 GHz 4460 Haswell
Graphics
NVIDIA GeForce GT 730 2GB GDDR5 with integrated Intel HD Graphics 4600
Mac
  1. iMac
Mobile Phone
  1. iOS
Install your ethernet Kext and FakeSMC only to EFI/Clover/Kexts/Others. Make a back up folder of your used kexts on the desktop. The graphics kexts are included in macOS Sierra. You shouldn't need to do anything different to your graphics injection that is not already been done in Yosemite. Once you get macOS Sierra installed you can then use KextBeast to install your Voodoo kexts. I'm not sure if audio will work you may have to update your drivers.
That sounds great. :)

I used VoodooHDA-2.8.8 setup and the audio worked ever since. I will let you know if my audio works with the same setup file in sierra.

Just a quick silly question, in the Direct Update from Yosemite to El Capitan thread, there is an additional instruction number 3, should I worry about that here?
 
Last edited:
Joined
Nov 12, 2011
Messages
13
Motherboard
Maximus Hero X
CPU
I7 8700k
Graphics
GTX970
Mobile Phone
  1. iOS
Did you try booting without cache and kext, selected from the clover menu by pressing space bar at boot up.
Yes, followed the direct update guide.

Installs El Cap with no hiccup, double checked my Bios settings too but everything seems in order.
Created a new installation usb to be double sure and also tested another USB port.
 
Joined
Oct 20, 2012
Messages
8
Motherboard
Gigabyte Z370P D3
CPU
i3 8350K
Graphics
RX 580
Mobile Phone
  1. iOS
updated to Sierra finally, have working GTX 970 full acceleration but menu and dock are not transparent, anyone know of any fixes?
 
Joined
Jun 26, 2012
Messages
4,094
Motherboard
Z170 Deluxe
CPU
i5-6600K
Graphics
GTX 970
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
  2. Other
That sounds great. :)

I used VoodooHDA-2.8.8 setup and the audio worked ever since. I will let you know if my audio worked with the same setup.

Just a quick silly question, in the Direct Update from Yosemite to El Capitan thread, there is an additional instruction number 3, should I worry about that here?
Yes you will need to add those two parameters to your config.plist shown in number 3. This will disable SIP (System Integrity Protection) and allow 3rd party kexts to load. Well spotted:clap:
 
Joined
Nov 7, 2015
Messages
2
Motherboard
ThinkPad X220
CPU
2520M
Graphics
HD Graphics 3000
Mobile Phone
  1. iOS
The install macOS does not boot. If I do not use verbose it never shows the progress bar and with verbose it stops at the 17th plus sign.
 
Joined
Mar 20, 2015
Messages
10
Motherboard
GA-Z97X-UD5H
CPU
Intel Core i7 4790k
Graphics
NVIDIA GeForce GTX 760
Mac
Classic Mac
Mobile Phone
The install macOS does not boot. If I do not use verbose it never shows the progress bar and with verbose it stops at the 17th plus sign.

I had that issue my first attempt. I had selected boot without caches but had not selected inject kexts. Injecting kexts and booting without caches fixed that issue for me.
 
Joined
Jan 17, 2015
Messages
28
Motherboard
GA Z97MX-Gaming 5
CPU
Intel Core i7-4790K
Graphics
ASUS Strix GeForce GTX 960
Mac
Classic Mac
Mobile Phone
It looks like my Sierra installation works good ...

I have a GA-Z97-MX-Gaming 5 and GTX960.

Couple points:

1. Clover Bootloader needs to be updated
2. FakeSMC.kext needed to be copied to my Clover Extensions->Other folder. I also copied my ethernet and trackball driver as well - this seemed to make the mouse work smoothly.
3. Did not try to resolve sound issues since I'm using a soundbar
4. After installation, used nv_disable=1 to boot into macOS Sierra, ran the Nvidia WebDriver update, then ran AGPDfix to patch the black screen issue.

Looking good so far...
 
Last edited:
Joined
Jan 28, 2014
Messages
165
Motherboard
Asus Rog Strix Z370-G Gaming (WI-FI AC)
CPU
i7-9700K OC'd @ 5.0GHz
Graphics
Vega 56
Mobile Phone
  1. Android
Thanks, I updated today.
Everything is working. :clap:
MB: Gigabyte GA-H97M-D3H
 
Joined
Sep 9, 2015
Messages
12
Motherboard
GA-X58A-UD5 rev 2.0 || GA-Z68X-UD4-B3 rev 1.0
CPU
i5 || i7
Graphics
ATI Radeon HD 6870 || NVIDIA GeForce GTX 260
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
I've been trying various ways to pass all this through for two days. No luck yet. But I figured out some patterns:
1) The main reason of kernel panics is com.apple.NVDAStartup kext.
2) I could once pass to the Sierra installation screen from bootable USB stick – when I didn't edit embedded config.plist file (UEFI iMac14,2 one) at all. But it stopped with 'Undefined error: 0' just on start.
3) So there obviously is kind a conflict between SMBIOS settings and a graphics card I have.
I reinstalled El Cap from scratch. It's working perfectly and shows me Asus GeForce GTX 260 as graphics with NVIDIA as a vendor. With iMac 14,2 SMBIOS settings.

What I cannot figure out, is why the hell Sierra doesnt work with the same settings? Why kernel panics?
 
Top