Contribute
Register

Closed Thread: For FYI only > [GUIDE] 10.8 / How to enable HD4000

Status
Not open for further replies.
Joined
Apr 4, 2012
Messages
34
Motherboard
ASUS P8Z77-I Deluxe
CPU
Intel 3570K
Graphics
Intel HD 4000
Mac
Classic Mac
Mobile Phone
  1. iOS
I changed the GraphicsEnabler to yes and set the memory size to max, but still no..
So, I put the code(ioreg -k AAPL,ig-platform-id) into terminal and I get this.

Code:
+-o Root  <class IORegistryEntry, id 0x100000100, retain 11>
  +-o Macmini5,1  <class IOPlatformExpertDevice, id 0x100000109, registered, ma$
    +-o AppleACPIPlatformExpert  <class AppleACPIPlatformExpert, id 0x10000010a$
    | +-o IOPMrootDomain  <class IOPMrootDomain, id 0x10000010e, registered, ma$
    | | +-o IORootParent  <class IORootParent, id 0x10000010f, !registered, !ma$
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x10000028f, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x100000290, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x100000291, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x100000292, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x100000294, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x100000296, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x100000299, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x1000002e6, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x1000002e7, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x1000002eb, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x100000337, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x100000375, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x100000382, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x10000038c, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x1000003c8, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x1000003c9, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x1000003d0, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x1000003d1, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x1000003d2, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x1000003d3, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x1000003d4, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x1000003d5, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x1000003dc, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x1000003de, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x1000003df, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x1000003e0, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x1000003e2, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x1000003f5, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x1000003fc, $
    | | +-o RootDomainUserClient  <class RootDomainUserClient, id 0x1000003fd, $
    | +-o cpus  <class IOPlatformDevice, id 0x100000117, registered, matched, a$
    | +-o CPU0@0  <class IOACPIPlatformDevice, id 0x100000118, registered, matc$
    | | +-o AppleACPICPU  <class AppleACPICPU, id 0x100000121, registered, matc$
    | |   +-o AppleACPICPUInterruptController  <class AppleACPICPUInterruptCont$
    | |   +-o ACPI_SMC_PlatformPlugin  <class ACPI_SMC_PlatformPlugin, id 0x100$
    | |     +-o AGPMEnabler  <class IOPlatformPluginDevice, id 0x1000002ec, reg$
    | |     | +-o AGPMController  <class AGPMController, id 0x1000002f4, !regis$
    | |     +-o IOPlatformEnabler  <class IOPlatformPluginDevice, id 0x1000002e$
    | |       +-o ApplePlatformEnabler  <class ApplePlatformEnabler, id 0x10000$
    | +-o CPU1@2  <class IOACPIPlatformDevice, id 0x100000119, registered, matc$
    | | +-o AppleACPICPU  <class AppleACPICPU, id 0x100000122, registered, matc$
    | +-o CPU2@4  <class IOACPIPlatformDevice, id 0x10000011a, registered, matc$
    | | +-o AppleACPICPU  <class AppleACPICPU, id 0x100000123, registered, matc$
    | +-o CPU3@6  <class IOACPIPlatformDevice, id 0x10000011b, registered, matc$
    | | +-o AppleACPICPU  <class AppleACPICPU, id 0x100000124, registered, matc$
    | +-o CPU4  <class IOACPIPlatformDevice, id 0x10000011c, registered, matche$
    | +-o CPU5  <class IOACPIPlatformDevice, id 0x10000011d, registered, matche$
    | +-o CPU6  <class IOACPIPlatformDevice, id 0x10000011e, registered, matche$
    | +-o CPU7  <class IOACPIPlatformDevice, id 0x10000011f, registered, matche$
    | +-o io-apic@fec00000  <class IOACPIPlatformDevice, id 0x100000120, regist$
    | | +-o AppleAPICInterruptController  <class AppleAPICInterruptController, $
    | +-o AppleACPIEventController  <class AppleACPIEventController, id 0x10000$
    | +-o bios  <class IOPlatformDevice, id 0x10000012c, registered, matched, a$
    | | +-o OemSMBIOS  <class OemSMBIOS, id 0x10000012d, registered, matched, a$
    | | +-o AppleSMBIOS  <class AppleSMBIOS, id 0x10000012e, registered, matche$
    | +-o PCI0@0  <class IOACPIPlatformDevice, id 0x100000132, registered, matc$
    | | +-o AppleACPIPCI  <class AppleACPIPCI, id 0x1000001f6, registered, matc$
    | |   +-o pci8086,150@0  <class IOPCIDevice, id 0x100000202, registered, ma$
    | |   +-o GFX0@2  <class IOPCIDevice, id 0x1000001ed, registered, matched, $
    | |   | +-o .Display_boot  <class IONDRVFramebuffer, id 0x1000002b7, regist$
    | |   |   +-o AppleMCCSControlModule  <class AppleMCCSControlModule, id 0x1$
    | |   |   | +-o AppleMCCSParameterHandler  <class AppleMCCSParameterHandler$
    | |   |   +-o AppleUpstreamUserClientDriver  <class AppleUpstreamUserClient$
    | |   |   +-o AGPM  <class AGPM, id 0x1000002f5, registered, matched, activ$
    | |   |   | +-o gpu-control  <class IOService, id 0x1000002f6, registered, $
    | |   |   |   +-o IOHWControl  <class IOHWControl, id 0x10000037f, register$
    | |   |   +-o display0  <class IODisplayConnect, id 0x100000379, registered$
    | |   |   | +-o AppleDisplay  <class AppleDisplay, id 0x10000037b, register$
    | |   |   +-o IOFramebufferUserClient  <class IOFramebufferUserClient, id 0$
    | |   |   +-o IOFramebufferSharedUserClient  <class IOFramebufferSharedUser$
    | |   +-o XHC@14  <class IOPCIDevice, id 0x1000001d9, registered, matched, $
    | |   | +-o AppleUSBXHCI  <class AppleUSBXHCI, id 0x100000217, registered, $
    | |   |   +-o XHCI Root Hub SS Simulation@14  <class IOUSBRootHubDevice, id$
    | |   |   | +-o AppleUSBHub  <class AppleUSBHub, id 0x10000023e, registered$
    | |   |   | +-o IOUSBInterface@0  <class IOUSBInterface, id 0x100000240, !r$
    | |   |   +-o XHCI Root Hub USB 2.0 Simulation@14  <class IOUSBRootHubDevic$
    | |   |     +-o AppleUSBHub  <class AppleUSBHub, id 0x100000243, registered$
    | |   |     +-o IOUSBInterface@0  <class IOUSBInterface, id 0x100000245, !r$
    | |   +-o pci8086,1e3a@16  <class IOPCIDevice, id 0x100000203, registered, $
    | |   | +-o AppleIntelMEIDriver  <class AppleIntelMEIDriver, id 0x10000029d$
    | |   +-o EHC2@1A  <class IOPCIDevice, id 0x1000001d0, registered, matched,$
    | |   | +-o AppleUSBEHCI  <class AppleUSBEHCI, id 0x100000215, registered, $
    | |   |   +-o EHCI Root Hub Simulation@1A  <class IOUSBRootHubDevice, id 0x$
    | |   |   | +-o AppleUSBHub  <class AppleUSBHub, id 0x10000022a, registered$
    | |   |   | +-o IOUSBInterface@0  <class IOUSBInterface, id 0x10000022c, !r$
    | |   |   +-o HubDevice@1a100000  <class IOUSBHubDevice, id 0x100000259, re$
    | |   |   | +-o AppleUSBHub  <class AppleUSBHub, id 0x10000025b, registered$
    | |   |   | +-o IOUSBInterface@0  <class IOUSBInterface, id 0x10000025d, !r$
    | |   |   +-o Dell USB Keyboard@1a160000  <class IOUSBDevice, id 0x10000026$
    | |   |     +-o IOUSBCompositeDriver  <class IOUSBCompositeDriver, id 0x100$
    | |   |     +-o IOUSBInterface@0  <class IOUSBInterface, id 0x100000269, re$
    | |   |       +-o IOUSBHIDDriver  <class IOUSBHIDDriver, id 0x10000026e, re$
    | |   |         +-o IOHIDInterface  <class IOHIDInterface, id 0x100000270, $
    | |   |         | +-o IOHIDEventDriver  <class IOHIDEventDriver, id 0x10000$
    | |   |         |   +-o IOHIDKeyboard  <class IOHIDKeyboard, id 0x100000272$
    | |   |         |   | +-o IOHIDSystem  <class IOHIDSystem, id 0x10000022e, $
    | |   |         |   |   +-o IOHIDStackShotUserClient  <class IOHIDStackShot$
    | |   |         |   |   +-o IOHIDUserClient  <class IOHIDUserClient, id 0x1$
    | |   |         |   |   +-o IOHIDParamUserClient  <class IOHIDParamUserClie$
    | |   |         |   |   +-o IOHIDEventSystemUserClient  <class IOHIDEventSy$
    | |   |         |   |   +-o IOHIDEventSystemUserClient  <class IOHIDEventSy$
    | |   |         |   +-o IOHIDSystem  <class IOHIDSystem, id 0x10000022e, re$
    | |   |         |     +-o IOHIDStackShotUserClient  <class IOHIDStackShotUs$
    | |   |         |     +-o IOHIDUserClient  <class IOHIDUserClient, id 0x100$
    | |   |         |     +-o IOHIDParamUserClient  <class IOHIDParamUserClient$
    | |   |         |     +-o IOHIDEventSystemUserClient  <class IOHIDEventSyst$
    | |   |         |     +-o IOHIDEventSystemUserClient  <class IOHIDEventSyst$
    | |   |         +-o IOHIDLibUserClient  <class IOHIDLibUserClient, id 0x100$
    | |   |         +-o IOHIDLibUserClient  <class IOHIDLibUserClient, id 0x100$
    | |   +-o HDEF@1B  <class IOPCIDevice, id 0x1000001e3, registered, matched,$
    | |   | +-o AppleHDAController@1B  <class AppleHDAController, id 0x1000002a$
    | |   |   +-o IOHDACodecDevice@1B,0  <class IOHDACodecDevice, id 0x1000002c$
    | |   |   | +-o IOHDACodecDriver  <class IOHDACodecDriver, id 0x1000002d0, $
    | |   |   |   +-o IOHDACodecFunction@1B,0,1  <class IOHDACodecFunction, id $
    | |   |   |     +-o AppleHDACodecGeneric  <class AppleHDACodecGeneric, id 0$
    | |   |   |       +-o AppleHDADriver  <class AppleHDADriver, id 0x1000002f8$
    | |   |   |         +-o AppleHDAEngineInput@1B,0,1,0  <class AppleHDAEngine$
    | |   |   |         | +-o AppleHDAStream  <class AppleHDAStream, id 0x10000$
    | |   |   |         | +-o IOAudioSelectorControl  <class IOAudioSelectorCon$
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioLevelControl  <class IOAudioLevelControl, $
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioLevelControl  <class IOAudioLevelControl, $
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioToggleControl  <class IOAudioToggleControl$
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioToggleControl  <class IOAudioToggleControl$
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioToggleControl  <class IOAudioToggleControl$
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioToggleControl  <class IOAudioToggleControl$
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |         | +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |         | +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |         | +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |         | +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |         +-o AppleHDAEngineInput@1B,0,1,1  <class AppleHDAEngine$
    | |   |   |         | +-o AppleHDAStream  <class AppleHDAStream, id 0x10000$
    | |   |   |         | +-o IOAudioSelectorControl  <class IOAudioSelectorCon$
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioLevelControl  <class IOAudioLevelControl, $
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioLevelControl  <class IOAudioLevelControl, $
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioToggleControl  <class IOAudioToggleControl$
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioToggleControl  <class IOAudioToggleControl$
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioToggleControl  <class IOAudioToggleControl$
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |         | +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |         | +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |         | +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |         | +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |         +-o AppleHDAEngineOutput@1B,0,1,2  <class AppleHDAEngin$
    | |   |   |         | +-o AppleHDAStream  <class AppleHDAStream, id 0x10000$
    | |   |   |         | +-o IOAudioToggleControl  <class IOAudioToggleControl$
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o AppleHDAStream  <class AppleHDAStream, id 0x10000$
    | |   |   |         | +-o IOAudioSelectorControl  <class IOAudioSelectorCon$
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioLevelControl  <class IOAudioLevelControl, $
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioLevelControl  <class IOAudioLevelControl, $
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioToggleControl  <class IOAudioToggleControl$
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioToggleControl  <class IOAudioToggleControl$
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioToggleControl  <class IOAudioToggleControl$
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioToggleControl  <class IOAudioToggleControl$
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o AudioAUUCDriver  <class AudioAUUCDriver, id 0x100$
    | |   |   |         | +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |         | +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |         | +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |         | +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |         | +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |         +-o AppleHDAEngineOutput@1B,0,1,3  <class AppleHDAEngin$
    | |   |   |         | +-o AppleHDAStream  <class AppleHDAStream, id 0x10000$
    | |   |   |         | +-o IOAudioToggleControl  <class IOAudioToggleControl$
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o AppleHDAStream  <class AppleHDAStream, id 0x10000$
    | |   |   |         | +-o IOAudioSelectorControl  <class IOAudioSelectorCon$
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioLevelControl  <class IOAudioLevelControl, $
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioLevelControl  <class IOAudioLevelControl, $
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioToggleControl  <class IOAudioToggleControl$
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioToggleControl  <class IOAudioToggleControl$
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioToggleControl  <class IOAudioToggleControl$
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o AudioAUUCDriver  <class AudioAUUCDriver, id 0x100$
    | |   |   |         | +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |         | +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |         | +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |         | +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |         | +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |         +-o AppleHDAEngineOutput@1B,0,1,4  <class AppleHDAEngin$
    | |   |   |         | +-o AppleHDAStream  <class AppleHDAStream, id 0x10000$
    | |   |   |         | +-o IOAudioToggleControl  <class IOAudioToggleControl$
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o AppleHDAStream  <class AppleHDAStream, id 0x10000$
    | |   |   |         | +-o IOAudioSelectorControl  <class IOAudioSelectorCon$
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioLevelControl  <class IOAudioLevelControl, $
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioLevelControl  <class IOAudioLevelControl, $
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioToggleControl  <class IOAudioToggleControl$
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioToggleControl  <class IOAudioToggleControl$
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o IOAudioToggleControl  <class IOAudioToggleControl$
    | |   |   |         | | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |         | +-o AudioAUUCDriver  <class AudioAUUCDriver, id 0x100$
    | |   |   |         | +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |         | +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |         | +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |         | +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |         | +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |         +-o AppleHDAEngineOutput@1B,0,1,5  <class AppleHDAEngin$
    | |   |   |           +-o AppleHDAStream  <class AppleHDAStream, id 0x10000$
    | |   |   |           +-o IOAudioToggleControl  <class IOAudioToggleControl$
    | |   |   |           | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |           +-o AppleHDAStream  <class AppleHDAStream, id 0x10000$
    | |   |   |           +-o IOAudioSelectorControl  <class IOAudioSelectorCon$
    | |   |   |           | +-o IOAudioControlUserClient  <class IOAudioControl$
    | |   |   |           +-o AudioAUUCDriver  <class AudioAUUCDriver, id 0x100$
    | |   |   |           +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |           +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |           +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |           +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   |           +-o IOAudioEngineUserClient  <class IOAudioEngineUser$
    | |   |   +-o IOHDACodecDevice@1B,3  <class IOHDACodecDevice, id 0x1000002c$
    | |   |     +-o IOHDACodecDriver  <class IOHDACodecDriver, id 0x1000002d1, $
    | |   |       +-o IOHDACodecFunction@1B,3,1  <class IOHDACodecFunction, id $
    | |   +-o RP01@1C  <class IOPCIDevice, id 0x1000001ad, registered, matched,$
    | |   | +-o IOPCI2PCIBridge  <class IOPCI2PCIBridge, id 0x10000021d, regist$
    | |   |   +-o PXSX@0  <class IOPCIDevice, id 0x1000001ae, registered, match$
    | |   |     +-o AirPort_AthrFusion21  <class AirPort_AthrFusion21, id 0x100$
    | |   |       +-o en2  <class AtherosFusion21Interface, id 0x1000002e3, reg$
    | |   |         +-o IONetworkStack  <class IONetworkStack, id 0x10000022d, $
    | |   |           +-o IONetworkStackUserClient  <class IONetworkStackUserCl$

There is no ig-platform-id.
 

dta

Joined
May 6, 2012
Messages
122
Motherboard
MSI Z77A-G43
CPU
Core i7 3770K
Graphics
Intel HD4000
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
Yeah, HD4000 kext is not loaded. Are you sure you are using Chimera 1.11? Have you tried using efi string?
 
Joined
Apr 4, 2012
Messages
34
Motherboard
ASUS P8Z77-I Deluxe
CPU
Intel 3570K
Graphics
Intel HD 4000
Mac
Classic Mac
Mobile Phone
  1. iOS
Yeah, HD4000 kext is not loaded. Are you sure you are using Chimera 1.11? Have you tried using efi string?

Yes, I am sure that I used Chimera 1.11.0.pkg.
I also have tried using the efi string and setting the memory to 32M. However, my display blacked out during the boot (it seemed like the display gone right before the log-in pops up.) and I tried different boot options to recover my system..though I had to re-install mountain lion.

Now, I am going to try the efi string method for one more time. UPDATE: Nope. It didn't work again.. reinstalling ML again.

This is frustrating...what am I doing wrong? It can't be this hard..
 
Joined
Sep 27, 2011
Messages
69
Motherboard
10.8.2
CPU
i5-3570k
Graphics
HD4000
Mac
Classic Mac
Mobile Phone
  1. iOS
Thank you!

i had set my bios to 512mb as per other instructions posted elsewhere witch caused artifacts and poor performance

with bios set to 64mb and grarphicsenabler=yes hd4000 is working perfectly!! with 512mb reconized in system profilier
 

dta

Joined
May 6, 2012
Messages
122
Motherboard
MSI Z77A-G43
CPU
Core i7 3770K
Graphics
Intel HD4000
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
Yes, I am sure that I used Chimera 1.11.0.pkg.
I also have tried using the efi string and setting the memory to 32M. However, my display blacked out during the boot (it seemed like the display gone right before the log-in pops up.) and I tried different boot options to recover my system..though I had to re-install mountain lion.

Now, I am going to try the efi string method for one more time. UPDATE: Nope. It didn't work again.. reinstalling ML again.

This is frustrating...what am I doing wrong? It can't be this hard..

Maybe it is your mainboard and the HD4000 port configurations not working together. I will post some more efi strings with different configurations when I have time. But it is weird that using Chimera 1.11 and setting GraphicsEnabler to yes it is doing nothing.


Thank you!

i had set my bios to 512mb as per other instructions posted elsewhere witch caused artifacts and poor performance

with bios set to 64mb and grarphicsenabler=yes hd4000 is working perfectly!! with 512mb reconized in system profilier

Great. What mainboard are you using?
 
Joined
Jun 19, 2012
Messages
68
Motherboard
Gigabyte Z77X-UD5H
CPU
Intel Core i7-3770K
Graphics
eVGA GTX970, HD4000
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
To all of you who are getting completely scrambled output when switching resolutions. Just tried the first method with Chimera 1.11 and GraphicsEnabler=yes and I'm also getting a complete mess when switching resolutions. So a fix for you could be using the efi string.



I can't test this on my own system because I don't have a HDMI display, but here is the efi string with fix for HDMI audio included. I would be glad if you could give it a try:

Code:
<key>device-properties</key>
<string>7f0000000100000001000000730000000200000002010c00d041030a000000000101060000027fff04002c0000004100410050004c002c00690067002d0070006c006100740066006f0072006d002d006900640000000800000005006201140000006800640061002d0067006600780000000d0000006f6e626f6172642d31</string>

This is ig-platform-id 01620005 again with the key "hda-gfx":"onboard-1" added.

I don't know if it is enough injecting this into HD4000, you might also have to add something like this to your HDEF device in DSDT:

Code:
"hda-gfx", 
Buffer (0x0A)
{
    "onboard-1"
}

I couldn't get the string to work. But then again, I wasn't sure what to name the key for this one because Xcode wouldn't let me add another <key>device-properties</key>
 
Joined
Jun 8, 2012
Messages
370
Motherboard
Asus X99-A
CPU
i7-5820K
Graphics
GTX Titan X
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. Classic
  2. Color Classic
  3. eMac
  4. iBook
  5. iMac
  6. Performa
  7. Power Mac
  8. PowerBook
  9. Quadra
  10. Xserve
Mobile Phone
  1. iOS
I just checked and switching resolutions is working for me. I'm using the efi-string injection. What port are you using on your board? HDMI?

You get the EFI string by converting a .plist file to hex with a tool called gfxutil. It is not different for board/processor. This is how the plist looks:

Code:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
  <key>PciRoot(0x0)/Pci(0x2,0x0)</key>
  <dict>
    <key>AAPL,ig-platform-id</key>
    <string>0x01620005</string>
  </dict>
</dict>
</plist>



What port are you using? HDMI? DVI? Also if you are using my efi string above make sure that VRAM is set to 32MB in BIOS, not 64MB.

I will mess with the EFI Injection when I get home from work on my personal machine. I am using the Thunderbolt port for video out on my TB display.

I am building a hackintosh today for work using HD4000 and HDMI so I will play with it on this machine as well and see what I can get going. It sounds like the EFI injection is a more reliable method. Thanks for your help and I will keep posted with my progress as the day progresses.

Mark
 
Joined
Dec 18, 2011
Messages
82
Motherboard
MSI B85M-G43
CPU
i7-4770K
Graphics
HD4600
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
kext not loaded on Zotac Z77-ITX

Yes, I am sure that I used Chimera 1.11.0.pkg.
I also have tried using the efi string and setting the memory to 32M. However, my display blacked out during the boot (it seemed like the display gone right before the log-in pops up.) and I tried different boot options to recover my system..though I had to re-install mountain lion.

Now, I am going to try the efi string method for one more time. UPDATE: Nope. It didn't work again.. reinstalling ML again.

This is frustrating...what am I doing wrong? It can't be this hard..

Me, I have the same problem on the same motherboard... i need your help!
 
Joined
Jun 8, 2012
Messages
370
Motherboard
Asus X99-A
CPU
i7-5820K
Graphics
GTX Titan X
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. Classic
  2. Color Classic
  3. eMac
  4. iBook
  5. iMac
  6. Performa
  7. Power Mac
  8. PowerBook
  9. Quadra
  10. Xserve
Mobile Phone
  1. iOS
Maybe it is your mainboard and the HD4000 port configurations not working together. I will post some more efi strings with different configurations when I have time. But it is weird that using Chimera 1.11 and setting GraphicsEnabler to yes it is doing nothing.




Great. What mainboard are you using?

Alright here is an update. Using EFI Injection it always boots properly over HDMI as long as the resolution is set to ideal for display. The second you change it freaks out over HDMI. This is using your original string and the modified one.

Now while its freaked out over HDMI I will take the same monitor and plug it in using DVI instead and I can change resolutions to my hearts content. It will let me boot using any resolution etc. If after I "rescue" the monitor by plugging in DVI then unplugging and plugging HDMI. I can then change to any resolution I want as well. As soon as I reboot it is up to its same old tricks however. So it certainly seems like a driver issue on HDMI. Now that said in the plist on the card you can change that ID to anything from 0-9 what if we set to 0 then set our VRAM to 96mb I wonder if that would enable HDMI to fully function.
 
Joined
Jun 8, 2012
Messages
370
Motherboard
Asus X99-A
CPU
i7-5820K
Graphics
GTX Titan X
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. Classic
  2. Color Classic
  3. eMac
  4. iBook
  5. iMac
  6. Performa
  7. Power Mac
  8. PowerBook
  9. Quadra
  10. Xserve
Mobile Phone
  1. iOS
Also I just did the terminal command and my kg-platform-id is "AAPL,ig-platform-id" = <05006201>
 
Status
Not open for further replies.
Top