Contribute
Register

Catalina vs Amd Radeon R9 290x - Cant boot after installation

Status
Not open for further replies.
Joined
Jan 6, 2017
Messages
15
Motherboard
Gigabyte Z170X Designare
CPU
intel core i7-6700K - 4GH
Graphics
Amd Radeon r9 290x
I had a 100% perfect hackintosh with Nvidia 980 ti, but i need catalina so i bough Amd Radeon r9 290x because i though it was an easy GPU to hackintosh...

I have a very old "helper" GPU and i boot into Catalina using that gpu and as you see on the image everything exept gpu is working nicely, so the only thing i miss is to get the GPU working.
I really need help with this as i feel i have tried everything google can offer.

my EFI is attached below.

When i try to boot, it shuts down somewhere in the loading...
----
Hardware:
Gigabyte z170x designare
Amd Radeon R9 290x
i7 9700k
----
Bios settings:
storage boot option - UEFI ONLY
(a step in the installation i couldnt find the UEFI partition without having this setting on Legacy, but now i find my clover bootloader having this setting on UEFI ONLY)...

XHCI - enable
VT-d - Disable.

And i have tried on and off the "IGPU" because people say different things..
i have tried 100 other things with bios too... but this is where im at now.
-----
i feel i tried everything
fake id,
amg8000controller
different boot flags, i have done it all i feel,, but nothing seem to work.

the best thing would be if someone could share a working clover confg.plist, or have any idea what i need to do.....

Thanks. i need your help.
 

Attachments

  • 94977615_278838506455808_265442125787693056_n.jpg
    94977615_278838506455808_265442125787693056_n.jpg
    1.1 MB · Views: 148
  • 95488134_258282218879526_5470140381922328576_n.jpg
    95488134_258282218879526_5470140381922328576_n.jpg
    868.8 KB · Views: 114
  • IMG_5843.PNG
    IMG_5843.PNG
    10.2 MB · Views: 94
  • 95136782_258792668639876_4729149663121244160_n.jpg
    95136782_258792668639876_4729149663121244160_n.jpg
    851.4 KB · Views: 93
  • EFI.zip
    2 MB · Views: 55
Last edited:
Joined
Jan 6, 2017
Messages
15
Motherboard
Gigabyte Z170X Designare
CPU
intel core i7-6700K - 4GH
Graphics
Amd Radeon r9 290x
i really need help :/
 

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
22,448
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
i really need help :/
Do you have Lilu and WhateverGreen kexts in Clover/Kexts/Other?
Have you enabled RadeonDeInit in config.plist?
 
Joined
Jan 6, 2017
Messages
15
Motherboard
Gigabyte Z170X Designare
CPU
intel core i7-6700K - 4GH
Graphics
Amd Radeon r9 290x
yes... i did all this :p i feel like i have tried everything. really.
here is my EFI.

So here i am now.
I can only access "Boot macos from hackingtoshHD" when i have "Storage bootable control on Legacy" i know this is supposed to be Legacy, but i remember from my previous hackingtosh that i had this on legacy and that build worked 100% :p

pic 5877 is on legacy..

do i need to find a way to find "Boot macos from hackingtoshHD" when "Storage bootable control is on UEFI? or how is it :p
 

Attachments

  • Total usb efi section.zip
    6.5 MB · Views: 87
  • IMG_5874.jpg
    IMG_5874.jpg
    762.1 KB · Views: 54
  • IMG_5875.jpg
    IMG_5875.jpg
    1.6 MB · Views: 59
  • IMG_5876.jpg
    IMG_5876.jpg
    2.4 MB · Views: 63
  • IMG_5877.jpg
    IMG_5877.jpg
    1.3 MB · Views: 50

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,570
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
yes... i did all this :p i feel like i have tried everything. really.
here is my EFI.

So here i am now.
I can only access "Boot macos from hackingtoshHD" when i have "Storage bootable control on Legacy" i know this is supposed to be Legacy, but i remember from my previous hackingtosh that i had this on legacy and that build worked 100% :p

pic 5877 is on legacy..

do i need to find a way to find "Boot macos from hackingtoshHD" when "Storage bootable control is on UEFI? or how is it :p
Try this. Disable IGPU, remove the helper GPU, use only the R9 290x, connect HDMi or Displayport to the R9.
 
Joined
Jan 6, 2017
Messages
15
Motherboard
Gigabyte Z170X Designare
CPU
intel core i7-6700K - 4GH
Graphics
Amd Radeon r9 290x
You are a living god!!
at least now i know this folder work.

Couldnt mount the EFI for hackintoshHD tho.. to make a bootloader without USB.
but i guess i can google my way to that.

allso the HackintoshHD have really no space (tried to put i video on it but it didnt work)
 

Attachments

  • Screen Shot 2020-04-30 at 7.50.26 AM.png
    Screen Shot 2020-04-30 at 7.50.26 AM.png
    593.9 KB · Views: 156
  • Screen Shot 2020-04-30 at 7.50.17 AM.png
    Screen Shot 2020-04-30 at 7.50.17 AM.png
    924 KB · Views: 156
Status
Not open for further replies.
Top