Contribute
Register

Broadcom WiFi/Bluetooth [Guide]

Joined
May 23, 2019
Messages
23
Motherboard
Asrock z370 fatality mini itx
CPU
i7 8700 non-k
Graphics
AMD VEGA RX 56
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Remove or disable the KextsToPatch.
Thanks for the reply.

I tried and here is the outcome,
The SSDT is not shown correctly...I don't know why
1577703597413.png
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
16,724
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
this is my efi file folder

What kind of Wi-Fi/Bluetooth card are you using?

Nevermind... I see you have DW1820A...

Please try with this EFI.
 

Attachments

  • EFI.zip
    24.6 MB · Views: 61
Last edited:
Joined
May 23, 2019
Messages
23
Motherboard
Asrock z370 fatality mini itx
CPU
i7 8700 non-k
Graphics
AMD VEGA RX 56
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
What kind of Wi-Fi/Bluetooth card are you using?

Nevermind... I see you have DW1820A...

Please try with this EFI.
Thank you so much. Now I see the port shows hs14 for bluetooth. Wondering would you mind sharing what did you do to make the port available? In addition, do I configure this efi to have my usb3.0 bus port discovered and configure the current patch?
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
21,166
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Thank you so much. Now I see the port shows hs14 for bluetooth. Wondering would you mind sharing what did you do to make the port available? In addition, do I configure this efi to have my usb3.0 bus port discovered and configure the current patch?
usb setup guide:
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
16,724
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Thank you so much. Now I see the port shows hs14 for bluetooth. Wondering would you mind sharing what did you do to make the port available? In addition, do I configure this efi to have my usb3.0 bus port discovered and configure the current patch?

You were using iMac19,2 system definition with a version of USBInjectAll that had no support for iMac19,2 system definition.

I thought that you had your USB ports configured already... If not, then follow the guide linked by Feartech.
 
Joined
May 23, 2019
Messages
23
Motherboard
Asrock z370 fatality mini itx
CPU
i7 8700 non-k
Graphics
AMD VEGA RX 56
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
usb setup guide:
Thanks. I was able to proceed after reconfiguring the SSDT.
 
Joined
May 23, 2019
Messages
23
Motherboard
Asrock z370 fatality mini itx
CPU
i7 8700 non-k
Graphics
AMD VEGA RX 56
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
You were using iMac19,2 system definition with a version of USBInjectAll that had no support for iMac19,2 system definition.

I thought that you had your USB ports configured already... If not, then follow the guide linked by Feartech.
Thank you pastrychef,
After following the SSDT guide, now I have a fully functioning bluetooth and I can do airdrop with it. Thanks for the help, happy holidays!
 
Joined
May 23, 2019
Messages
23
Motherboard
Asrock z370 fatality mini itx
CPU
i7 8700 non-k
Graphics
AMD VEGA RX 56
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Thank you pastrychef,
After following the SSDT guide, now I have a fully functioning bluetooth and I can do airdrop with it. Thanks for the help, happy holidays!
Good afternoon Pastrychef,
I just updated to the Catalina with the refi you provided. Before update, bt and wifi worked fine, but wanted to get the new feature.

After update, the bluetooth port, hs14, went missing, and thus cannot find the bluetooth card under usb tab. Just as I had the same issue at the beginning with Mojave, too. So I am wondering what should I do? Is it the same way that the usbinjectall.kext is not supported?

I haven't change anything from the update, and I am using the same efi that you provided me last time
Also I added brcmpatchram3, and disabled the rampatch2, did no work
Thanks in advance.
 
Top