Contribute
Register

Solved > Boot failed with Intel HD 4600 and Radeon RX 580

Joined
Jun 13, 2014
Messages
14
Motherboard
GIGABYTE GA-Z97X-UD7
CPU
i7-4790K
Graphics
SAPPHIRE PULSE RX 580
Mac
MacBook Pro
Mobile Phone
Android
Hello, I am currently trying to upgrade my Hackintosh with Sapphire Radeon RX 580 but cannot boot with both, integrated and discrete graphics working together, it simply fails to boot.
bios.jpg

boot_failed.jpg

This is the problem, but let me step back to give you more context.

I have a perfectly working Hackintosh with the following setup:
CPU: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz
Motherboard: GIGABYTE GA-Z97X-UD7
Graphics: NVIDIA GeForce GTX 770
Bootloader: Clover
SMBIOS: iMac15,1
Kexts:
WhateverGreen.kext
AirportBrcmFixup.kext
AppleALC.kext
FakeSMC_ACPISensors.kext
FakeSMC_CPUSensors.kext
FakeSMC_GPUSensors.kext
FakeSMC_LPCSensors.kext
FakeSMC_SMMSensors.kext
FakeSMC.kext
IntelMausiEthernet.kext
Lilu.kext
USBInjectAll.kext

Both, intel iGPU and Nvidia graphics work fine together:
gtx_770_and_intel_hd_4600.png


I decided to upgrade my video card with the more powerful SAPPHIRE Radeon RX 580, unfortunately, whatever I try it doesn't work properly.
When I enable integrated graphics in BIOS it simply fails to boot with the error I posted above, if I disable integrated graphics it boots just fine and MacOs detect AMD Radeon RX 580. Unfortunately, there is another issue, when I open a bunch of applications, for example, Chrome with many tabs and other applications the system UI starts to freeze and lag. Not sure why it happens, faulty RX 580 card, or missing Intel iGPU. It looks like iGPU is pretty important for the Mac os to keep UI smooth, so it could be the reason why.

I already tried so many things but nothing works and I feel that I am lost.
I've tried different Clover configurations, i.e. Inject Intel, Load VBios, ig-platform-id, IntelGFX Fake ID.
I also tried a clean Clover configuration with the latest Lilu and Whatevergreen, still no luck.
Changes to the amount of memory allocated to iGPU from 32 to 96 take no effect as well.

I am not sure what is the next step to take, please advice how to troubleshoot to understand why I cannot boot with Intel and AMD graphics working together.
 

Attachments

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,836
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
@endryha,

Try reducing the IGPU DVMT allocation size to 64 or 128 MB.
MacOS normally expects a size of 64 MB but some BIOS's do not offer this in which case use 128 MB instead.

Install Lilu + WhatEverGreen and configure the IGPU as Headless, see this guide for more info :-


The examples in the "Headless" section of the guide are straight from my Z97 system with a HD4600 IGPU so you can use those examples as they are, also as detailed in the guide I recommend you use the iMac15,1 SMBIOS.

Most Z97 BIOS's have an option called "IGPU Multi-Monitor" which is usually required to be enabled to get the IGPU and dGPU working nicely together (at least in my experience), here is what that option looks like on my ASRock Z97 System (see White Knight build in my sig for full specs) :-

IGPU-BIOS.png


If you don't have this option then check to see if there is a BIOS update that offers it, if not it's probably there but is a hidden option (not all OEM's offer all BIOS options). You might be able to enable the "Multi-Monitor" option by dumping the BIOS and finding the relevant offset in the data and modifying the value directly from a EFI tool.

I have never done this myself as have no need, but it should be possible, other users have to do a similar thing in order to alter the DVMT allocation on BIOS's that do not allow it to be set. Be warned that the method does carry a risk of breaking things if you try randomly setting values but as long as you find the correct offset it should work.

Cheers
Jay
 
Last edited:
Joined
Jun 13, 2014
Messages
14
Motherboard
GIGABYTE GA-Z97X-UD7
CPU
i7-4790K
Graphics
SAPPHIRE PULSE RX 580
Mac
MacBook Pro
Mobile Phone
Android
Thank you for your guidance.

I've followed your guide for a headless iGPU configuration and it worked for Platform ID 0x0412000B
I tried a similar approach before but it didn't work for some reason.

macOS seems to run smoothly and Hackintool reports that VDA Decoder is Fully Supported

I guess that now I am good to go with my RX 580.

Thanks a lot
 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,836
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
I've followed your guide for a headless iGPU configuration and it worked for Platform ID 0x0412000B ... I tried a similar approach before but it didn't work for some reason.

@endryha,

Glad that it worked for you and your up and running now ...
I have marked the thread Solved.

Cheers
Jay
 
Joined
Jun 13, 2014
Messages
14
Motherboard
GIGABYTE GA-Z97X-UD7
CPU
i7-4790K
Graphics
SAPPHIRE PULSE RX 580
Mac
MacBook Pro
Mobile Phone
Android
@jaymonkey apparently it doesn't work perfectly, it was running for quite a while with no issues, but today, when I opened a bunch of Chrome tabs system UI started to lag and freeze.

kernel_task occupied most of the CPU resources and it looks like it was procrastinating, eventually, computer shutdown, and when I started again I could see a message that it shut down due to kernel panic.

Could you suggest how to troubleshoot this issue? What can be done about it?

Thank you
 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,836
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
@endryha,

The first thing you need to do is to find out what is causing the kernel panic.

As long as you have Native NVRAM working (not emulated) then after the KP and shutdown on the next restart MacOs should give you a message indicating that it recovered from a serious error. Click on the more details buttons to see a the kernel panic log, copy and paste it to a txt file so you can debug it or post it here, do not click on the options to send the log to Apple.

Chrome is renowned to be a memory hog when lots of tabs are open so this may be a memory related issue and nothing to do with the IGPU or dGPU. I think many users have been seeing issues with Chrome when lots of tabs are open and not just in MacOS but in Windoze too.

Try using Safari and see if it does it with that, if not then it could well be be an issue with Chrome.

Cheers
Jay
 
Last edited:
Joined
Jun 13, 2014
Messages
14
Motherboard
GIGABYTE GA-Z97X-UD7
CPU
i7-4790K
Graphics
SAPPHIRE PULSE RX 580
Mac
MacBook Pro
Mobile Phone
Android
@jaymonkey thank you for the advice, I will make sure to capture system logs after the restart when it happens next time.
 
Joined
Jun 13, 2014
Messages
14
Motherboard
GIGABYTE GA-Z97X-UD7
CPU
i7-4790K
Graphics
SAPPHIRE PULSE RX 580
Mac
MacBook Pro
Mobile Phone
Android
@jaymonkey
I have 32GB of RAM, so even though I had a lot of Chrome tabs opened I had at least 16 GB of free memory, so, I don't think this is a memory issue, it looks like something causes kernel_task to runaway and consume most of the CPU.

But, I am not sure what exactly triggers that, another fact, that I never had such issues with my NVidia GTX 770, it only started to happen when I switched to AMD Radeon RX 580 with headless iGPU setup.

I still observe the issue with kernel_task CPU usage periodically, however, no kernel panics anymore.
When it triggers I have to restart the computer to stop that.

I will continue to monitor, but, I am not sure how to troubleshoot this kind of problem.
 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,836
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
I have 32GB of RAM, so even though I had a lot of Chrome tabs opened I had at least 16 GB of free memory ...

@endryha,

Understood ....

I will continue to monitor, but, I am not sure how to troubleshoot this kind of problem.

Did you try using an alternant browser as I suggested above such as Safari, Opera, Firefox .. etc to see if the issue is just related to Chrome ?, if it is then try removing all extensions and test again, if the system runs ok then add the extensions back one at a time. It's not unheard of for a web extension to cause issues.

I believe Chorome has a debug mode so it might be worth looking into that .... might give you some clues.

Cheers
Jay
 
Joined
Jun 13, 2014
Messages
14
Motherboard
GIGABYTE GA-Z97X-UD7
CPU
i7-4790K
Graphics
SAPPHIRE PULSE RX 580
Mac
MacBook Pro
Mobile Phone
Android
@jaymonkey I've been testing a little bit more and it doesn't seem that the issue specifically with Chrome. From what I observe system UI is freezing at random, periodically I feel some micro-lags with the mouse cursor, sometimes it happens when I launch a new program, sometimes when I swipe between different virtual screens, also, I noticed that the screen saver is lagging as well.

It feels like there is a global issue but not a specific software issue.

I switched back to my NVidia GTX 770 to verify my observations and I can confidently say that the system runs much smoother with GTX 770.
I don't apply any custom iGPU configuration for Intell HD Graphics 4600 (i4790K) + NVidia GTX 770, Lilu + WEG automatically configures a headless iGPU, so it appears in the iStats Menu and Hackintool reports that VDA Decoder is fully supported.
Just in case I am attaching a screenshot from the Hackintool to demonstrate what is the auto-configuration.

For some reason, Lilu + WEG cannot autoconfigure my Sapphire Pulse Radeon RX 580.
If I understand correctly if I set manually the same Platform ID 0x04120004 which is autoconfigured for GTX 770 it has to work, but for some reason, it doesn't. It boots into the system and it looks like both iGPU and dGPU is visible for the system but I get all these problems which I just explained.

Should I try different SMBIOS? Currently, I am on iMac15,1 should I switch to iMac14.1?
Should I try a different PCI slot?
Could it be just a faulty or maybe not compatible RX 580 card? Should I verify some device ids or anything like that?

Just thinking about potential options for the next step, would really appreciate your advices.
 

Attachments

Top