Contribute
Register

Black screen Intel HD 530 on Mojave after patching Framebuffer

Joined
Dec 11, 2014
Messages
82
Motherboard
SONY VAIO VPCEA46FG
CPU
i5-480M
Graphics
HD 5470
Mobile Phone
iOS
Bus ID and connector type not important for VGA port, need AGDP patch on Mojave, even SMBIOS iMac14,2 AGDP config value is set to none, still not work for me, for SKL use ig-platform-id 0x193B0005, all 5/6/7 ports work.
Try below patch should work.

View attachment 378387
So you mean without the Intel Framebuffer patching method, directly adding this values to kexts to patch on clover? and use platform-id 0x193B0005 ? with Inject intel to yes ??
 
Joined
Oct 26, 2013
Messages
990
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
So you mean without the Intel Framebuffer patching method, directly adding this values to kexts to patch on clover? and use platform-id 0x193B0005 ? with Inject intel to yes ??
If only need VGA port work on Mojave, add AGDP patch to Clover kexts to patch section, use ig-platform-id 0x193B0005 for SKL, set Inject intel to yes, do not need WEG or any Framebuffer patch.
 
Joined
Dec 11, 2014
Messages
82
Motherboard
SONY VAIO VPCEA46FG
CPU
i5-480M
Graphics
HD 5470
Mobile Phone
iOS
Just the Device ID, plattform ID has to stay 1219, but I'm just guessing here. shuhung's solution sounds like he knows what he's doing
True, let me try it.
 
Joined
Oct 26, 2013
Messages
990
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
ig-platform-id 0x193B0005 + AGDP patch VGA port test result, without any FB patches, no WEG, everything work.

1547216376706.png
 

Attachments

Joined
Dec 11, 2014
Messages
82
Motherboard
SONY VAIO VPCEA46FG
CPU
i5-480M
Graphics
HD 5470
Mobile Phone
iOS
Bus ID and connector type not important for VGA port, need AGDP patch on Mojave, even SMBIOS iMac14,2 AGDP config value is set to none, still not work for me, for SKL use ig-platform-id 0x193B0005, all 5/6/7 ports work.
Try below patch should work.

View attachment 378387

Hey, I tried this- but getting a KP. smbios is iMac17,1 also tried with 14,2
Please see my attached config.plist
Here is Kp report.
 

Attachments

Last edited:
Joined
Dec 11, 2014
Messages
82
Motherboard
SONY VAIO VPCEA46FG
CPU
i5-480M
Graphics
HD 5470
Mobile Phone
iOS
Bus ID and connector type not important for VGA port, need AGDP patch on Mojave, even SMBIOS iMac14,2 AGDP config value is set to none, still not work for me, for SKL use ig-platform-id 0x193B0005, all 5/6/7 ports work.
Try below patch should work.

View attachment 378387
No luck getting KP.
 
Joined
Dec 11, 2014
Messages
82
Motherboard
SONY VAIO VPCEA46FG
CPU
i5-480M
Graphics
HD 5470
Mobile Phone
iOS
@shuhung Also, I tired ADGP patch with FB patch then also I get to a black screen but this time it reboots.
 
Top