Contribute
Register

Big sur doesn't update to 11.2 and not update apps

Status
Not open for further replies.
Joined
Jun 30, 2018
Messages
26
Motherboard
AsusTeK COMPUTER INC. X510UF
CPU
i5 8250U
Graphics
MX130
Mobile Phone
  1. Android
Hello.
I've successfully update my Asus VivoBook S15 from Catalina to Big Sur. I'm using Clover (in this moment v. 5129). The recovery partition was gone but I've mounted EFI partition with Clover and now it is reappeared. The issue that I have is that there is an update (11.2) but I always get an error of connection. I have also try "softwareupdate -i -a" but it stucks at 10% and after gives me some errors. Moreover I have 11 apps from the App Store to update but at my first startup xCode started to download but never started the installation process. After that now no download starts. I've already try to reinstall Big Sur, downloading it from app store, but nothing changed.
Someone knows how to resolve this problem?
Thanks.

Schermata 2021-02-03 alle 02.00.10.png
 
Joined
Mar 6, 2011
Messages
289
Motherboard
Asus TUF Z690 Plus D4
CPU
i9-12900K
Graphics
RX 6900 XTXH (spoofed)
Mobile Phone
  1. Android
  2. iOS
make sure you have sip enabled csrutil enable
 
Joined
Jun 30, 2018
Messages
26
Motherboard
AsusTeK COMPUTER INC. X510UF
CPU
i5 8250U
Graphics
MX130
Mobile Phone
  1. Android
Thanks for your reply.
Where I could check that?
 
Joined
Jun 30, 2018
Messages
26
Motherboard
AsusTeK COMPUTER INC. X510UF
CPU
i5 8250U
Graphics
MX130
Mobile Phone
  1. Android
Little update. I have reinstalled BS and launch, at the final reboot, from PREBOOT partition and now BS is 11.2. So one problem is gone. App Store starts to download apps but it doesn't proceed to install them

EDIT: Now I always have to launch my Mac from PREBOOT partition. It's normal?
EDIT2: Keynote was been updated but every others app still not update .-.
 
Last edited:
Joined
Jun 30, 2018
Messages
26
Motherboard
AsusTeK COMPUTER INC. X510UF
CPU
i5 8250U
Graphics
MX130
Mobile Phone
  1. Android
Ok, I've launched this command from terminal and this was the output:


csrutil status
System Integrity Protection status: unknown (Custom Configuration).

Configuration:
Apple Internal: disabled
Kext Signing: disabled
Filesystem Protections: disabled
Debugging Restrictions: disabled
DTrace Restrictions: disabled
NVRAM Protections: disabled
BaseSystem Verification: enabled

This is an unsupported configuration, likely to break in the future and leave your machine in an unknown state.
 
Joined
Jun 30, 2018
Messages
26
Motherboard
AsusTeK COMPUTER INC. X510UF
CPU
i5 8250U
Graphics
MX130
Mobile Phone
  1. Android
I have to say that I'm using USB tethering and I've already had these kind of issue. But I always logout-relogin to my iCloud account or used this command:

cd /Library/Preferences/SystemConfiguration
sudo rm preferences.plist NetworkInterfaces.plist*; sudo shutdown -r

and everything come back to work

Moreover before to update the system see my USB tethering connection as a ethernet connection, now the situation is this:
Schermata 2021-02-03 alle 09.58.08.png
 
Joined
Jun 30, 2018
Messages
26
Motherboard
AsusTeK COMPUTER INC. X510UF
CPU
i5 8250U
Graphics
MX130
Mobile Phone
  1. Android
Ok I've resolved. I had to delete xCode that was the app that at the beginning I have downloaded but has never been installed successfully. So my solution was:

- Download from the store Big Sur
- Install Big Sur
- The system will be restarted
- Run install partition
- System restarting
- Run install PREBOOT partition
- DONE


The only thing that I don't know how to resolve is how to run MacOS with the normal partition and not the PREBOOT. It's not a tragedy but I have 3 partition for just 1 Mac system so it's a little bit ugly. Solution?
 
Joined
Dec 12, 2016
Messages
208
Motherboard
Xiaomi Notebook Air 13.3 UEFI
CPU
i5-6200U
Graphics
520 + 940X
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I'm also unable to run this updater...?
In the meantime i have OC updated to 0.6.6 from OC 0.6.3
Also updated some critical kexts such as lilu...
 
Joined
Jun 30, 2018
Messages
26
Motherboard
AsusTeK COMPUTER INC. X510UF
CPU
i5 8250U
Graphics
MX130
Mobile Phone
  1. Android
I'm also unable to run this updater...?
In the meantime i have OC updated to 0.6.6 from OC 0.6.3
Also updated some critical kexts such as lilu...
Sorry I've Clover so I don't know how manage the problem with OC. Have you already tried to follow the steps that I wrote?
 
Joined
Dec 12, 2016
Messages
208
Motherboard
Xiaomi Notebook Air 13.3 UEFI
CPU
i5-6200U
Graphics
520 + 940X
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
YES i managed to have CSRUtil enable via the Recovery partition
 
Status
Not open for further replies.
Top