Contribute
Register

Asus X299 - Support

Joined
Feb 24, 2013
Messages
2,228
Motherboard
ASUS WS X299 SAGE/10G
CPU
i9-9980XE
Graphics
Radeon VII
Mac
MacBook Pro
Mobile Phone
iOS
Just spent time time testing with a very bare EFI folder (literally nothing except FakeSMC/USBKext/TCAdjust) as well as a very simple config.plist and I couldn't figure out what is causing the crackling audio..

It's definitely something Apple has done in .5 that causes this issue.

Maybe when they fixed this they broke Radeon VII.

Can someone please test Radeon VII on a non-Prime Deluxe board like a Gigabyte X299 board? I wanted to test 10.14.5 with a non Radeon VII GPU but I don't have anything extra to test.
 
Last edited:
Joined
Feb 24, 2013
Messages
2,228
Motherboard
ASUS WS X299 SAGE/10G
CPU
i9-9980XE
Graphics
Radeon VII
Mac
MacBook Pro
Mobile Phone
iOS
I am thinking it may be DisplayPort cable related, going to try a DP1.4 cable.

After disabling DP1.2 in the display, it worked for a while, but then after a restart the glitches came back.

But I really really doubt it's cable related.
 

Attachments

Last edited:
Joined
Sep 8, 2011
Messages
55
Motherboard
Asus Rampage VI Extreme
CPU
i9-7960X
Graphics
Radeon VII
Mac
MacBook Pro
Mobile Phone
iOS
10.14.5 (18F132)
GB OpenCL 158163
GB Metal 154019
Luxmark 50332 (Imagen validation: OK)
Aceleration H.264 OK HEVC NO
GPUSensor.kext (Radeon VII) Not Working
AppleALC.kext ("sound") Cracking over DP or Thunderbolt 3. (LG 5k2k)

Code:
EFI\CLOVER\kexts\Other\AppleALC.kext (v.1.3.7)
EFI\CLOVER\kexts\Other\KGP-iMacPro-ASUS-PX299D-XHCI-15port.kext (v.<null string>)
EFI\CLOVER\kexts\Other\LPCSensors.kext (v.1802)
EFI\CLOVER\kexts\Other\GPUSensors.kext (v.1802)
EFI\CLOVER\kexts\Other\TSCAdjustReset.kext (v.1.1)
EFI\CLOVER\kexts\Other\SmallTree-Intel-211-AT-PCIe-GBE.kext (v.1.0.6)
EFI\CLOVER\kexts\Other\FakeSMC.kext (v.1802)
EFI\CLOVER\kexts\Other\CPUSensors.kext (v.1802)
EFI\CLOVER\kexts\Other\AGPMEnabler.kext (v.2.3.1)
EFI\CLOVER\kexts\Other\IntelMausiEthernet.kext (v.2.3.0)
EFI\CLOVER\kexts\Other\ACPISensors.kext (v.1802)
No SSDT for Radeon VII, WEG or LILU kexts.
 
Last edited:
Joined
Feb 24, 2013
Messages
2,228
Motherboard
ASUS WS X299 SAGE/10G
CPU
i9-9980XE
Graphics
Radeon VII
Mac
MacBook Pro
Mobile Phone
iOS
10.14.5 (18F132)
GB OpenCL 158163
GB Metal 154019
Luxmark 50332 (Imagen validation: OK)
Aceleration H.264 OK HEVC NO
GPUSensor.kext (Radeon VII) Not Working
AppleALC.kext ("sound") Cracking over DP or Thunderbolt 3. (LG 5k2k)

Code:
EFI\CLOVER\kexts\Other\AppleALC.kext (v.1.3.7)
EFI\CLOVER\kexts\Other\KGP-iMacPro-ASUS-PX299D-XHCI-15port.kext (v.<null string>)
EFI\CLOVER\kexts\Other\LPCSensors.kext (v.1802)
EFI\CLOVER\kexts\Other\GPUSensors.kext (v.1802)
EFI\CLOVER\kexts\Other\TSCAdjustReset.kext (v.1.1)
EFI\CLOVER\kexts\Other\SmallTree-Intel-211-AT-PCIe-GBE.kext (v.1.0.6)
EFI\CLOVER\kexts\Other\FakeSMC.kext (v.1802)
EFI\CLOVER\kexts\Other\CPUSensors.kext (v.1802)
EFI\CLOVER\kexts\Other\AGPMEnabler.kext (v.2.3.1)
EFI\CLOVER\kexts\Other\IntelMausiEthernet.kext (v.2.3.0)
EFI\CLOVER\kexts\Other\ACPISensors.kext (v.1802)
No SSDT for Radeon VII, WEG or LILU kexts.
I get (repeatble tests)

GB OpenCL 171,000
GB Metal 167,000
Luxmark 51,000
Aceleration H.264 YES HEVC YES
GPUSensor.kext (Radeon VII) Working (via KGP patched FakeSMC)
AppleALC.kext ("sound") Cracking over DP or Thunderbolt 3. (LG 5k2k)

The crackling, not sure it has anything to do with AppleALC. If you remove it, DisplayPort Audio still shows up and works but it still crackles for me.
 
Joined
Jun 13, 2018
Messages
339
Motherboard
Prime X299-A
CPU
i9-9980XE
Graphics
Radeon VII
Mac
iMac, MacBook Pro
Classic Mac
iMac, Power Mac
Mobile Phone
Android, iOS
I get (repeatble tests)

GB OpenCL 171,000
GB Metal 167,000
Luxmark 51,000
Aceleration H.264 YES HEVC YES
GPUSensor.kext (Radeon VII) Working (via KGP patched FakeSMC)
AppleALC.kext ("sound") Cracking over DP or Thunderbolt 3. (LG 5k2k)

The crackling, not sure it has anything to do with AppleALC. If you remove it, DisplayPort Audio still shows up and works but it still crackles for me.
I think GB needs un update at his point, if it was a driver related issue we would got sluggish numbers for Luxmark too.
I got significant lower point on my Vega 64 too now.

I'm curious to see if KGP will update his EFI folders on GitHub now that 10.14.5 is out.
 
Joined
Feb 5, 2013
Messages
1,053
Motherboard
Asus X299 WS Sage
CPU
i9-7980XE
Graphics
Radeon VII
Mac
iMac, Mac Pro
Boy, i'd really like to see if someone with a Gigabyte X299 and Radeon VII would report in.....

BTW, @Ellybz - didn't work.

@izo1 - I tried other DP cables and I tried a certified HDMI cable(s), two of them, no change, still crackle.

One thing I've been holding off on is VoodooHDA. Might try that in a bit....

EDIT: VoodooHDA didn't work either - still scratchy audio on the DP Monitor connection
 
Last edited:
Joined
Feb 24, 2013
Messages
2,228
Motherboard
ASUS WS X299 SAGE/10G
CPU
i9-9980XE
Graphics
Radeon VII
Mac
MacBook Pro
Mobile Phone
iOS
I think GB needs un update at his point, if it was a driver related issue we would got sluggish numbers for Luxmark too.
I got significant lower point on my Vega 64 too now.
Maybe. I noticed in certain tasks R7 is faster than VII, but there's some discrepancy at the system level.

@izo1 - I tried other DP cables and I tried a certified HDMI cable(s), two of them, no change, still crackle.

One thing I've been holding off on is VoodooHDA. Might try that in a bit....

EDIT: VoodooHDA didn't work either - still scratchy audio on the DP Monitor connection
Just tried a different cable too, same thing. VoodooHDA did not work for me either.

Definitely driver related imo even if others are reporting no issues on another motherboard.
 
Joined
Feb 24, 2013
Messages
2,228
Motherboard
ASUS WS X299 SAGE/10G
CPU
i9-9980XE
Graphics
Radeon VII
Mac
MacBook Pro
Mobile Phone
iOS
At this stage I really believe Geekbench is bugged and needs to be updated. I submitted a ticket to their support team.

This is the first time I got such a "high score" with the Radeon VII on macOS.

Screen Shot 2019-05-14 at 8.42.20 PM.png


It should be over 200,000 at a minimum.
 
Joined
Feb 24, 2013
Messages
2,228
Motherboard
ASUS WS X299 SAGE/10G
CPU
i9-9980XE
Graphics
Radeon VII
Mac
MacBook Pro
Mobile Phone
iOS
View attachment 405799

Here's mine with a Radeon VII, interesting.

Could you do a OpenCL/Metal compute run in GB and post results? As well as LuxMark.

Also if possible, do you have a monitor with DisplayPort audio capability to check if you get “crackling” audio?
 
Top