Contribute
Register

Asus Prime Z370-A - Instant reboots after an update to Big Sur

Status
Not open for further replies.
Joined
Nov 13, 2010
Messages
121
Motherboard
Asus Prime Z370-A
CPU
i7-8700K
Graphics
RX580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Dear Hackintosh Community,

After following other threads and searching around, I successfully got into the Big Sur installer and updated from Catalina to Big Sur. However after reboot, it shows:
1.png

2.png

4.png
3.png


After the last screen, it stays there for a few seconds and reboots.

This is what I did:

1) Update clover to latest version v5.1 r5127
2) Update AppleALC, Lilu, VirtualSMC and WhateverGreen. The full list of kext is:

Code:
$ ls -1 /Volumes/EFI/EFI/CLOVER/kexts/Other
AirportBrcmFixup.kext
AppleALC.kext
IntelMausiEthernet.kext
Lilu.kext
NullCPUPowerManagement.kext
SMCProcessor.kext
SMCSuperIO.kext
USBPorts.kext
VirtualSMC.kext
WhateverGreen.kext
dAGPM.kext

3) Use Clover Configurator to change system definitions to iMac 19,2:
Screenshot 2020-11-28 at 16.08.17.png


4) Update config.plist to add Quirks config.plist additions - this made it boot into Catalina and into the Big Sur installer. The full config attached.

This is an 8700K on Asus Prime Z370-A with an RX580 GPU

Any ideas what I missed?
 

Attachments

  • config.plist
    27.7 KB · Views: 106
Last edited:
Joined
Nov 13, 2010
Messages
121
Motherboard
Asus Prime Z370-A
CPU
i7-8700K
Graphics
RX580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Update, I successfully upgraded from Catalina to Big Sur

This is what I did:
  1. Update clover to latest version v5.1 r5127
  2. Update AppleALC, Lilu, VirtualSMC and WhateverGreen. The full list of kext is:
Code:
$ ls -1 /Volumes/EFI/EFI/CLOVER/kexts/Other
AirportBrcmFixup.kext
AppleALC.kext
IntelMausiEthernet.kext
Lilu.kext
NullCPUPowerManagement.kext
SMCProcessor.kext
SMCSuperIO.kext
USBPorts.kext
VirtualSMC.kext
WhateverGreen.kext
dAGPM.kext
  1. Use Clover Configurator to change system definitions to iMac 19,2 (screenshot in first post)
  2. Update config.plist to add Quirks config.plist additions - this made it boot into Catalina and into the Big Sur installer. The full config attached to first post.
  3. There was a gotcha that I had to select to boot from "Pre-Boot Apple" instead of "Boot Mac OS", I use this option to boot my Hackintosh every time now.
I am now successfully in and everything is working great so far!
 
Last edited:
Joined
Aug 14, 2018
Messages
80
Motherboard
Asus Z370-F Gaming
CPU
i7-8700K
Graphics
Vega 64
Mac
  1. iMac
Mobile Phone
  1. iOS
Update, I successfully upgraded from Catalina to Big Sur

This is what I did:
  1. Update clover to latest version v5.1 r5127
  2. Update AppleALC, Lilu, VirtualSMC and WhateverGreen. The full list of kext is:
Code:
$ ls -1 /Volumes/EFI/EFI/CLOVER/kexts/Other
AirportBrcmFixup.kext
AppleALC.kext
IntelMausiEthernet.kext
Lilu.kext
NullCPUPowerManagement.kext
SMCProcessor.kext
SMCSuperIO.kext
USBPorts.kext
VirtualSMC.kext
WhateverGreen.kext
dAGPM.kext
  1. Use Clover Configurator to change system definitions to iMac 19,2 (screenshot in first post)
  2. Update config.plist to add Quirks config.plist additions - this made it boot into Catalina and into the Big Sur installer. The full config attached to first post.
  3. There was a gotcha that I had to select to boot from "Pre-Boot Apple" instead of "Boot Mac OS", I use this option to boot my Hackintosh every time now.
I am now successfully in and everything is working great so far!

Could you share the full EFI without your serial number? I can't get it to work and I want to see where I have the error, thank you very much.
 
Status
Not open for further replies.
Top