Contribute
Register

Z87E-ITX Updates

Status
Not open for further replies.

WonkeyDonkey

Moderator
Joined
Aug 31, 2010
Messages
4,452
Motherboard
Asrock Z87E-ITX
CPU
i7-4770S
Graphics
GTX 760
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
I see. Maybe at ASRock they could find useful this Pike's article

Yeah I had read that recently too.

Interesting development though; ReHabMan produced a modified kernel with the changes mentioned by Pike.

Ive loaded this kernel onto my Unibeast key and also my working system to see if it makes any difference; I then flashed 2.10E they sent me and it boots up just fine.

Im now going to try the same with the 2.10 stock from the website and also the 2.10G public beta from the website.
 
Joined
Apr 28, 2011
Messages
903
Motherboard
ASRock Fatal1ty Z370 Gaming-ITX/ac
CPU
i7-8700
Graphics
UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Well the modified kernel works with all of the bios updates so far.

2.10 Stock
2.10E Beta
2.10G Beta

The muliplier stays at 35 in HWMonitor though, temps around 50 C.

Ssdt? Smbios and sysdef?
EDIT: A lot of people don't trust HWMonitor: try with SJ_Underwater's DPCIManager
 

WonkeyDonkey

Moderator
Joined
Aug 31, 2010
Messages
4,452
Motherboard
Asrock Z87E-ITX
CPU
i7-4770S
Graphics
GTX 760
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
Ssdt? Smbios and sysdef?
EDIT: A lot of people don't trust HWMonitor: try with SJ_Underwater's DPCIManager

DPCIManager only shows a single Pstate of 35.

Smbios is default with 14,2 definition.

I dont have an SSDT for it though. I used the Multibeast version on my previous sandy bridge build but Im assuming thats not relevant here, or is it....
 
Joined
Sep 20, 2013
Messages
28
Motherboard
ASUS Maximus VIII Impact
CPU
i7-6700K
Graphics
R9 380
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hi WonkeyDonkey:

I was able to fix my own black screen issue w/ integrated gfx by hooking up the display via the mbd's HDMI port. You'll need that IntelAzulFB=10 key/value pair in the chameleon bootloader settings as well (though I believe Chimera does this automatically).

Also got both my OCed mem sticks to report @ 2400MHz by editing their values in smbios.plist (this may only be a cosmetic alteration though?).

Could you post a copy of the 2.10G PMPatched BIOS? Curious to test it and I don't have Windows on here to run PMPatch myself.
 

WonkeyDonkey

Moderator
Joined
Aug 31, 2010
Messages
4,452
Motherboard
Asrock Z87E-ITX
CPU
i7-4770S
Graphics
GTX 760
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
Hi WonkeyDonkey:

I was able to fix my own black screen issue w/ integrated gfx by hooking up the display via the mbd's HDMI port. You'll need that IntelAzulFB=10 key/value pair in the chameleon bootloader settings as well (though I believe Chimera does this automatically).

Also got both my OCed mem sticks to report @ 2400MHz by editing their values in smbios.plist (this may only be a cosmetic alteration though?).

Could you post a copy of the 2.10G PMPatched BIOS? Curious to test it and I don't have Windows on here to run PMPatch myself.

Hi, I saw your posts over on insanelymac, I posted on that thread too but no further replies yet.

I currently have my GTX650 Ti Boost installed; everything to do with graphics is perfect with this, its a very nice and extremely quiet GPU!

I was able to get the ram to show the correct speeds by modifing smbios.plist too. Its odd that the UEFI setup screen reports both sticks as 1866; 'About This Mac' shows it as correct speed, but Memory under System Information shows one stick at the correct 1866 and the other at 1333 still. Ive no way to know where the fault lies with this, but Asrock are aware of the issue.

The 2.10G PMpatched bios file wont flash to the board; still shows that error message of 'Secure Flash Check Fail'.

Im currently using the 2.10G unmodified beta from the website, together with the modified kernel mentioned a few posts back. But the multiplier seems locked at 35 right now.
 
Joined
Sep 20, 2013
Messages
28
Motherboard
ASUS Maximus VIII Impact
CPU
i7-6700K
Graphics
R9 380
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I currently have my GTX650 Ti Boost installed; everything to do with graphics is perfect with this, its a very nice and extremely quiet GPU!

Right on. Been thinking of getting a 650 or 660 Ti Boost myself. :) Saw a 660 Ti Boost on craigslist recently for $120 and still kicking myself for not getting it. :(

I was able to get the ram to show the correct speeds by modifing smbios.plist too. Its odd that the UEFI setup screen reports both sticks as 1866; 'About This Mac' shows it as correct speed, but Memory under System Information shows one stick at the correct 1866 and the other at 1333 still. Ive no way to know where the fault lies with this, but Asrock are aware of the issue.

Ahh. I wonder which speeds they're actually running @ in OSX—if any different. It seems to me if the UEFI setup says 1866, it should be no different under OSX regardless of what System Information says. But I'm just assuming things; is there a reliable utility we can use within OSX to verify the actual memory speeds?

The 2.10G PMpatched bios file wont flash to the board; still shows that error message of 'Secure Flash Check Fail'.

Im currently using the 2.10G unmodified beta from the website, together with the modified kernel mentioned a few posts back. But the multiplier seems locked at 35 right now.

Gotcha. Whereas speedstep did work properly under the PMPatched BIOSes you were able to apply before (like v2.0)? Because I know it works in mine (one can see it cycling between different multipliers in HWMonitor).

Also if ASRock wants more guinea pigs to help with testing this board in OSX, I'll be happy to volunteer.
 

WonkeyDonkey

Moderator
Joined
Aug 31, 2010
Messages
4,452
Motherboard
Asrock Z87E-ITX
CPU
i7-4770S
Graphics
GTX 760
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
Having spent a lot of time reading reviews and checking out prices, I went for the MSI GTX650 Ti Boost - its the Twin Frozr edition. It really is quiet as a mouse, you dont hear the fans at all, regardless of how hard you push the system. I have a newfound respect for MSI following this purchase.

Edit : Model number is 'N650Ti TF 2GD5 BE'; note this is NOT the OC edition. From the reviews I read, this is one of the quietest graphic cards out there right now.

Regarding the memory speeds, its weird. If I load up a Linux bootable CD, it too shows 1 x 1866 and 1 x 1333.

bdmesg out shows this :
SPD[0] (size): 146 @0x50
Slot: 0 Type 24 8192MB (DDR3 SDRAM) 1867MHz Vendor=Corsair
PartNo=CMY16GX3M2A1866C9 SerialNo=00000000
SPD[0] (size): 255 @0x51
SPD[0] (size): 146 @0x52
Slot: 2 Type 24 8192MB (DDR3 SDRAM) 1333MHz Vendor=Corsair
PartNo=CMY16GX3M2A1866C9 SerialNo=00000000
SPD[0] (size): 255 @0x53
SPD[0] (size): 255 @0x54
SPD[0] (size): 255 @0x55
SPD[0] (size): 255 @0x56
SPD[0] (size): 255 @0x57

And this :

MemoryDevice:
deviceLocator: ChannelA-DIMM0
bankLocator: BANK 0
memoryType: DDR3
memorySpeed: 1867MHz
manufacturer: Corsair
serialNumber: 00000000
assetTag: 9876543210
partNumber: CMY16GX3M2A1866C9

Type: 20, Length: 35, Handle: 0x10
Type: 17, Length: 34, Handle: 0x11
MemoryDevice:
deviceLocator: ChannelB-DIMM0
bankLocator: BANK 2
memoryType: DDR3
memorySpeed: 1333MHz
manufacturer: Corsair
serialNumber: 00000000
assetTag: 9876543210
partNumber: CMY16GX3M2A1866C9

Type: 20, Length: 35, Handle: 0x12
Type: 19, Length: 31, Handle: 0x13
Type: 131, Length: 6, Handle: 0x13

I suppose the only way to really tell is to load up some 1333 only ram, do a couple of Geekbench runs and then do the same with this memory and compare the two.

Yes, speedstep worked correctly under the 2.00 modified bios, but these others which now work with the modified kernel dont speedstep at all. Just stuck at 35 all the time.

Im attaching the 2.10G PMPatched bios, but I couldnt get this to flash. Maybe you can give it a try.

View attachment pmZ87EITX2.10G.zip

Remember to remove the 'pm' at the beginning before trying to patch otherwise it doesnt get recognised for some reason.
 
Joined
May 27, 2010
Messages
2,406
Motherboard
Dell Optiplex 9030 All in One
CPU
i5-4690K
Graphics
HD 4600
Mac
  1. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
I am interested in this board too.

I'd be interested to know if using the method I detailed in my Zotac thread here http://www.tonymacx86.com/user-buil...e-i5-4430-zotac-h87-itx-8gb-ram-gt-240-a.html (see first post "flashing the bios" section) you can get your new bios flashed. I too had the secure bios issue preventing me from getting it done up until using those precise steps - I have attachments in the post that may help.

Good luck.
 
Status
Not open for further replies.
Top