Contribute
Register

World of Warcraft performance?

Joined
Feb 10, 2012
Messages
19
Motherboard
Dell Inspiron 13" 7000 series
CPU
i5-7200u
Graphics
Intel HD620
i7 4790k GTX 770 SC and I noticed that if I play the game in Fullscreen mode, my FPS holds steady in the 80-90 fps...If i try to play in Fullscreen(windowed) I get FPS drops to 8-10. My solution? play in full screen mode lol
 
Joined
Jun 17, 2012
Messages
141
Motherboard
Gigabyte GA-Z68X-UD3H
CPU
Intel i7-2600K
Graphics
Nvidia GTX1070Ti
Mac
MacBook Air
Mobile Phone
iOS
Are you running under El Capitan? If so, try quitting the Battle.net launcher (you can set it to do this automatically) when you launch WoW. There is a documented bug with the launcher (and pretty much any other browser or app that uses Flash) that is killing framerates when running in fullscreen windowed mode.
 
Joined
Feb 10, 2012
Messages
19
Motherboard
Dell Inspiron 13" 7000 series
CPU
i5-7200u
Graphics
Intel HD620
Are you running under El Capitan? If so, try quitting the Battle.net launcher (you can set it to do this automatically) when you launch WoW. There is a documented bug with the launcher (and pretty much any other browser or app that uses Flash) that is killing framerates when running in fullscreen windowed mode.
This still doesn't fix my issue. I tried it right after I read your post. Running El Capitan and the frame rate issue still exists. Full screen for now for me
 
Joined
Mar 31, 2016
Messages
6
Motherboard
MSI Z87-G43 GAMING
CPU
i7-4770K
Graphics
EVGA GTX970 SC
Mac
Classic Mac
Mobile Phone
iOS
Hey guys.

I want to ask you, if you know how to make my WoW to work with 1920x1200 resolution.

I'w working on El Capitan 10.11.4.

My hack spec is:
i7-4770k, GTX970, MSI Z87-G43, 16GB DDR3 and 24" BenQ @1920x1200.

BTW. Thanks for your earlier posts which solve my low performance (running game without launcher works fine).
 

beelzebozo

Super Moderator
Joined
Mar 31, 2010
Messages
3,803
Motherboard
Main Build: ASUS z170-Deluxe
CPU
i7 - 6700K
Graphics
GTX 1080
Mac
MacBook Pro
Classic Mac
Power Mac
Mobile Phone
iOS
Hey guys.

I want to ask you, if you know how to make my WoW to work with 1920x1200 resolution.

I'w working on El Capitan 10.11.4.

My hack spec is:
i7-4770k, GTX970, MSI Z87-G43, 16GB DDR3 and 24" BenQ @1920x1200.

BTW. Thanks for your earlier posts which solve my low performance (running game without launcher works fine).
Not sure what the problem is. I'm running WOW at the same resolution. Check your in-game settings.
 

beelzebozo

Super Moderator
Joined
Mar 31, 2010
Messages
3,803
Motherboard
Main Build: ASUS z170-Deluxe
CPU
i7 - 6700K
Graphics
GTX 1080
Mac
MacBook Pro
Classic Mac
Power Mac
Mobile Phone
iOS
i7 4790k GTX 770 SC and I noticed that if I play the game in Fullscreen mode, my FPS holds steady in the 80-90 fps...If i try to play in Fullscreen(windowed) I get FPS drops to 8-10. My solution? play in full screen mode lol
Have to play in full screen as far as I know. It broke in El Capitan where as it was fine in Yosemite.
 
Joined
Mar 31, 2016
Messages
6
Motherboard
MSI Z87-G43 GAMING
CPU
i7-4770K
Graphics
EVGA GTX970 SC
Mac
Classic Mac
Mobile Phone
iOS
I tried all 3 modes: Windowed, Windowed (fullscreen) and Fullscreen. In all these modes I can set maximum resolution 1920x1080.
Of course when I'm out of game I have 1920x1200 resolution.
 
Joined
May 17, 2016
Messages
34
Motherboard
P67 Sabertooth
CPU
i7 2600
Graphics
RX 580
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
Classic, iBook
Mobile Phone
Android, iOS
New rendition of WoW works fine for my on my skylake. I run a R9 380 2 gig without frame rate issues. Actually it runs better in Mac OS then it does in windows for me. Only runs better in windows when I overclock the video card. But i'm seeing steady 70fps at max graphical settings, just set the ground clutter to 5 and distance to 5 and shadows to high everything else maxed. If you lock the fps with v-sync frame rates drastically stutter and I get down to 40fps sometimes lower. I noticed the video card automatically switches to a lower clock speed with vsync on. So always leave it off. Also don't forget it might try to run in metal not open GL. It will run like crap in metal. Change it to Open GL. Goodluck!
 
Last edited:
Joined
Mar 16, 2014
Messages
163
Motherboard
GA-Z170MX-Gaming 5
CPU
Intel Core I7-6700 FC-LGA14C 3.40 GHz 8 M Processor Cache 4
Graphics
Gigabyte GeForce GTX 970 Overclocked GDDR5, 4GB
Mac
iMac, MacBook Pro
Classic Mac
Power Mac
Mobile Phone
iOS
I was wondering if anyone here plays World of Warcraft on their hackintosh and what type of performance they are receiving from their machines?

I am in the process of building a machine with a Core i7 920, 4GB of DDR3 and a Nvidia GeForce GTX 260.

What types of frame rates are people seeing with similar setups?
I actually created a dual-boot system and running WOW under Windows 10, but plan on installing on the Mac side to see.
 
Joined
Jun 5, 2016
Messages
86
Motherboard
GA-Z170X-UD5 TH
CPU
i7-6700K
Graphics
GTX 980 Ti
Mobile Phone
iOS
I tried all 3 modes: Windowed, Windowed (fullscreen) and Fullscreen. In all these modes I can set maximum resolution 1920x1080.
Of course when I'm out of game I have 1920x1200 resolution.
Here is the fix you were probably looking for:

https://us.battle.net/forums/en/wow/topic/8873728013

With Patch 7.1.5, running into a lot of load time problems with Metal and El Capitan. A lot of Windows users are also having problems, so it could be something else related to the client. Switching to OpenGL (or upgrading to Sierra) seems to resolve, but neither of those options are very good, for me at least.

Performance with Metal is otherwise excellent on my GTX 750 Ti FTW with 60+ FPS in most situations.
 

Top