Contribute
Register

World of Warcraft performance?

Joined
May 2, 2012
Messages
24
Motherboard
GA-Z77N-WIFI
CPU
i5 3570k
Graphics
HD4000 - Evga GT640
Mac
MacBook Air, MacBook Pro
Classic Mac
Mobile Phone
iOS
When I run WoW my FPS tends to be around 80 fps and sometimes drops to as low as 8 fps, resulting in extreme lagging which makes playing almost impossible (especially as a healer). I also get CPU% spikes all the time while playing, jumping from 30% to sometimes 140%.

My hackintosh is: GA-Z77N-WIFI, i5 3570k, onboard HD4000 (my GT640 also result in the same lag spikes), 8GB ram

Does anyone have an idea why this is happening and how to fix it?
 
Joined
Jun 4, 2010
Messages
122
Motherboard
ASUS Z97 Maximus VII Gene
CPU
i7 4790K
Graphics
GTX 1080
Mac
MacBook Air, MacBook Pro, Mac Pro
Classic Mac
Classic, Power Mac, PowerBook
Mobile Phone
Android
I am now running an i5-2500k, 8GB DDR3 and dual XFX 5770's. All settings are maxed except shadows on high. Idle I am getting about 110fps average. With shadows on low I get over 150fps.

Now if only I could get the game to span across all three monitors :(
 
Joined
Jun 10, 2012
Messages
12
Motherboard
GA-Z97X-Gaming 7
CPU
Intel Core i7 4790k
Graphics
Sapphire Radeon R9 290 Tri-X
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS
This post is off-topic, however might help someone:

If you are unable to use modifier keys with your MMO mouse (Naga/G600/etc) then execute the following command in Terminal:
defaults write com.blizzard.worldofwarcraft disable-expose-fix -bool YES
If your mouse acceleration is strange then execute the following command using the in-game chat box:
/console useDesktopMouseSpeed 1
Note: I use this in combination with SteerMouse to fully disable OS X's mouse acceleration and mimic Windows' linear mouse movement.

If you want to use function keys (F1-F19) then you will need to disable some of Expose's hotkeys:
  • Open System Preferences, click on Keyboard, and change to the Keyboard Shortcuts tab.
  • Under Display, uncheck Decrease display brightness (F14) and Increase display brightness (F15).
  • Under Mission Control, uncheck Show Desktop (F11) and Show Dashboard (F12).
  • If you're using a Razer Blackwidow Ultimate Mac Edition, enable gaming mode (FN + F13) to be able to directly use keys without holding the fn key.
 
Joined
Mar 7, 2011
Messages
11
Motherboard
Gigabyte GA-Z77-DS3H
CPU
i5-3330
Graphics
GTX 670
Mac
iMac, Mac Pro
Classic Mac
iBook, iMac, Performa, Power Mac
Mobile Phone
iOS
I am seeing excellent performance in WoW MoP. My current hackintosh is a i5 3330 with a GA-Z77-DS3H mobo, evga 9800GT 1GB, and 16gigs of DDR 3 ram. I was having some issue with my 550ti and random lock ups so I reverted to the old 9800GT. I do raid quite often and am seeing on average 40-50fps in most 25mans. I also have an intel SSD which also helps quite a bit. I think the build you have would run wow quite well. I do run my settings on high@1680x1050 resolution. Update I am now using an asus GTX 650 all settings on high never seeing anything below 50fps even in 25 man raids
 
Joined
Dec 5, 2012
Messages
12
Motherboard
Gigabyte GA-Z77N WIFI
CPU
i5 3570K
Graphics
GTX 1060
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
When I run WoW my FPS tends to be around 80 fps and sometimes drops to as low as 8 fps, resulting in extreme lagging which makes playing almost impossible (especially as a healer). I also get CPU% spikes all the time while playing, jumping from 30% to sometimes 140%.

My hackintosh is: GA-Z77N-WIFI, i5 3570k, onboard HD4000 (my GT640 also result in the same lag spikes), 8GB ram

Does anyone have an idea why this is happening and how to fix it?
I have the same problem with this MOBO, even with a Geforce GTX 660 TI :(
If anyone could help to find a solution or just an idea of where the problem is
Thanks in advance
 
Joined
Jul 9, 2013
Messages
60
Motherboard
MSI Z97 Gaming 5
CPU
i5 4690K
Graphics
MSI GTX 970
Mac
Classic Mac
Mobile Phone
I have the same problem with this MOBO, even with a Geforce GTX 660 TI :(
If anyone could help to find a solution or just an idea of where the problem is
Thanks in advance

I know this is old, but I have the same MOBO as well and the same issues. Was anyone ever able to solve this?
 
Joined
Jun 7, 2013
Messages
5
Mac
Classic Mac
Mobile Phone
Oddly enough wow MoP plays pretty bad for me, low fps and stuttering even in empty locations and low settings. Wow 3.3.5 (WOTLK) plays very smooth, maxed out settings 150+ fps on private servers.

Got an i7 4770k @ 4.3 ghz and GTX 780 3GB. 16GB system memory

Tried numerous times to increase performance in os x but I always end up playing retail in windows instead :/
 
Joined
Mar 9, 2014
Messages
19
Motherboard
GiBy GA-H97M-HD3
CPU
Intel Core-i7 4770
Graphics
ATI Radeon HD 6850
Mac
iMac, MacBook
Classic Mac
Mobile Phone
try using your onboard graphic instead of gtx 780 and tell us if performance increased...

i know that intel HD 4600 is by far weaker than gtx 780, but i tried it in the beginning with hd4600 graphics and was able to play wow on low-mid settings fluently.

maybe your gpu is not supported yet..


few weeks ago i put in a gt640 with much better performance. i'm now playing on good-high details in 25-raids with min. fps 30-40



please keep me postet, friend of mine is buying new hardware soon, including gtx 780
 
Joined
Oct 15, 2014
Messages
165
Motherboard
GA-Z97X-GAMING-GT
CPU
i7-4790k 4.4ghz
Graphics
Nvidia GeForce GTX 970 SC
Mac
Mac Pro
Mobile Phone
iOS
Figured I'd chime in with some gameplay on a GTX 970 @ 1920x1080 resolution.

I am getting around 90-95 fps with everything at highest settings, everything. Lowest I've seen is 82 fps in AV during a crazy bridge fight.

Looking forward to a 34UC97 monitor and seeing how it plays at 3440x1440.

Pretty awesome, quite the step up in performance from my 17" Macbook Pro (2009), which was finding it hard to play at all anymore. Nearly 6 years out of that laptop though, and with an upgrade to its ram and an SSD its still got a lot of life left in it for less taxing usage.
 
Top