Contribute
Register

USB Wifi for macOS Sierra 10.12

Joined
Apr 29, 2018
Messages
2
CPU
intel I7
Graphics
nvidia geforce gtx 1050 ti OC edition
Is this working on high sierra ??
 
Joined
Jul 29, 2012
Messages
6
Motherboard
Asus Vivobook S15 (S510UN-BQ134T) - Clover
CPU
i7-8550U
Graphics
Intel UHD620 + nvidia MX150
Is there some difference between the US drivers and the UE drivers? Since there are no beta drivers on the non-us site.
 
Joined
Jul 29, 2012
Messages
6
Motherboard
Asus Vivobook S15 (S510UN-BQ134T) - Clover
CPU
i7-8550U
Graphics
Intel UHD620 + nvidia MX150
Joined
Aug 2, 2013
Messages
66
Motherboard
Intel Skylake-U Premium PCH
CPU
Core i7-6500U
Graphics
Intel HD Graphics 520 (1920x1080)
Mac
MacBook Pro
Mobile Phone
iOS
Thank you. Where did you buy it? Because on amazon I can find a generic article that does not describe the version of the dongle (and only the v3 has the driver for HS).
Just as side note:
Long time ago I purchased the TL-823WN V2 and it did not work for me under Sierra. But, now since there were new drivers linked in this thread I tried it again.

I can confirm that the linked drivers (https://static.tp-link.com/2018/201804/20180428/TP-Link_Installer_Beta_Mac.zip) work under High Sierra 13.4 (de facto I just removed all other network devices, installed the driver, rebooted, inserted the wifi stick and immediately could connect to my network). Just testing for 15 minutes, but no issues until now.
 
Joined
Jul 22, 2017
Messages
69
Motherboard
ASUS H170 Pro Gaming
CPU
i5-7600
Graphics
GTX 750 TI
Mac
iMac
Classic Mac
Classic, LC
Mobile Phone
Android, iOS
Hello !

Little update...

Just bought the Tp-link TL-WN823N v.3, 300Mbps Mini.

I installed the Mac drivers from the Tp-link website, in beta version (released on the 2018-04-28). Works like a charm, either on Usb 2 ou 3 port, on High Sierra 10.13.4.

Hope this will be usefull to other people. ;)

EDIT : after few days of use... It seems that the Tp-link TL-WN823N v.3 needs to be pluged out and back in to works properly. But after that, it's reliable (two "Netflix binge night" as a test...).

Alpha


Hey AlphaRe,
My TL-WN722Nv2 can work but got two issues:
it can only link to invisible SSID hotspots, not visible free hotspots because it cannot see any ... that's so strange) and I won't be able to use any of the "wifi-explorer" type apps:
https://itunes.apple.com/tw/app/wifi-explorer-lite/id1408727408?mt=12

Can you confirm my issues doesn't exist on yours? if it's my device's issue or this model?
since you had TL-WN823N for some time...

Thanks in advance!:thumbup:
 
Top