Contribute
Register

USB mouse and keyboard extremely laggy

Joined
Jun 1, 2017
Messages
17
Motherboard
Aorus GA-Z270X-Gaming 7
CPU
Intel i7-7700K
Graphics
HD630
Hello guys

So I eventually managed to install 10.12.5 onto my machine (i7 Kabylake, GA-Z270X G7, 960 EVO) but my mouse and keyboard are super laggy. It's been like that since the installer so when I installed Sierra I thought the problem would go away but it didn't. It's so bad I can't use Sierra. I really need some help here

Thank you to everyone who has helped me so far, but need a little bit more help!

Thanks
 
Joined
Aug 1, 2017
Messages
4
Motherboard
Aorus GA-Z270X-Gaming 8
CPU
Intel I7-7700K Kaby Lake
Graphics
1080 Ti
Hello guys

So I eventually managed to install 10.12.5 onto my machine (i7 Kabylake, GA-Z270X G7, 960 EVO) but my mouse and keyboard are super laggy. It's been like that since the installer so when I installed Sierra I thought the problem would go away but it didn't. It's so bad I can't use Sierra. I really need some help here

Thank you to everyone who has helped me so far, but need a little bit more help!

Thanks
Hello hello !
Glad to hear you finally get a success with this configuration !
I'm like you, two weeks ago, with a ton of things to learn to get this work (same configuration, but I've add a 1080ti).
First question, if you agree, how did you managed the super laggy mouse and keyboard problem ? It's really annoying and if you have any idea to help me, i would really appreciate it. Many thanks !
 
Joined
Jun 1, 2017
Messages
17
Motherboard
Aorus GA-Z270X-Gaming 7
CPU
Intel i7-7700K
Graphics
HD630
Hello hello !
Glad to hear you finally get a success with this configuration !
I'm like you, two weeks ago, with a ton of things to learn to get this work (same configuration, but I've add a 1080ti).
First question, if you agree, how did you managed the super laggy mouse and keyboard problem ? It's really annoying and if you have any idea to help me, i would really appreciate it. Many thanks !
Hi aerofx

The problem lay within the graphics. I had to inject Intel graphics with the right ID and a specific Kext, which solved my problem. Unfortunately I cannot remember exactly what I did. But if you search this forum for slow/laggy graphics you should find a thread that mentions fixing the Kabylake HD630 including a kext file. Are you booting with on board graphics or with the 1080ti? I think booting with the 1080ti might slove your problem

Edit: The kext file I used was the Lilu.kext file found at https://github.com/vit9696/Lilu/releases
 
Last edited:
Joined
Aug 1, 2017
Messages
4
Motherboard
Aorus GA-Z270X-Gaming 8
CPU
Intel I7-7700K Kaby Lake
Graphics
1080 Ti
Hi,


Many thanks for your reply !
The laggy mouse / keyboard problem is solved after installing the webdriver for the 1080ti ... but, now i'm completely lost, if I don't want to have a black screen on startup, i need to use nv_disable=1 on boot and so the 1080ti is not detected and instead of it, I have NVIDIA Chip model 3 Mo installed ... any idea bout that ?
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,620
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
GTX 970
The laggy mouse / keyboard problem is solved after installing the webdriver for the 1080ti ... but, now i'm completely lost, if I don't want to have a black screen on startup, i need to use nv_disable=1 on boot and so the 1080ti is not detected and instead of it, I have NVIDIA Chip model 3 Mo installed ... any idea bout that ?
BIOS - Disable Integrated Graphics - PEG as Primary
Use a digital connection - DVI or HDMI - VGA is not supported.
Config.plist - Do not inject Intel or Nvidia graphics and no ig-platform-id
Edit config.plist - NvidiaWeb = true as per Link
Gigabyte 100/200 series motherboards need to emulate NVRAM - Problem 6 (Install EmuVariableUefi-64 + RC Scripts)
Remove nv_disable=1 from config.plist
MacPro 6,1 or iMac 15 or iMac 17 System Definition need black screen fix as per Link
 
Joined
Aug 1, 2017
Messages
4
Motherboard
Aorus GA-Z270X-Gaming 8
CPU
Intel I7-7700K Kaby Lake
Graphics
1080 Ti
Many many thanks for your answer, i'll check that !
 
Joined
Aug 1, 2017
Messages
4
Motherboard
Aorus GA-Z270X-Gaming 8
CPU
Intel I7-7700K Kaby Lake
Graphics
1080 Ti
Yes !! it's working, with your last advise .. again, many thanks for you help !
 
Top