Contribute
Register

UniBeast: Install macOS High Sierra on Any Supported Intel-based PC

Joined
Sep 25, 2012
Messages
101
Motherboard
Asus ROG STRIX Z390-F
CPU
i5-9600K
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
Installed with all updates, everything seems to work fine. It's slowish to boot, but runs fairly stable on my antiquated hardware. One thing I did run up against, is that apfs.efi needed to be put in the drivers64uefi folder, otherwise clover won't see boot option for High Sierra.

*EDIT*
Had too many freezing issues, so reinstalled without apfs.
What works;
  • iMessage
  • FaceTime
  • Bluetooth
  • Wifi
  • USB
  • Airdrop (after realising you have to have your iPhone open :banghead:)
  • Sound
What doesn't;
  • Continuity and Handoff
  • Sleep
 
Last edited:
Joined
Mar 9, 2018
Messages
1
Motherboard
ASUS Maximus VI Gene
CPU
Intel i5-4670K
Graphics
NVIDIA GTX1080 FE
Mac
iMac, MacBook Air
Mobile Phone
iOS
I also get this message after the first reboot: /system/installation/packages/osinstall.mpkg appears to be missing or damaged

Any ideas for this?

EDIT: (Problem solved)

It seems to be fixed since i removed my GTX1080 and all my other Drives from my Computer, not choose any Graphics parameter in UniBeast and rebuilt the USB Stick like 5 times... Impatience at its best :-D
 
Last edited:
Joined
Mar 13, 2018
Messages
4
Motherboard
Z370 AORUS Gaming 5
CPU
Intel Core i7-8700K
Graphics
AORUS GeForce® GTX 1080 Ti Xtreme Edition 11G
I also get this message after the first reboot: /system/installation/packages/osinstall.mpkg appears to be missing or damaged

Any ideas for this?

EDIT: (Problem solved)

It seems to be fixed since i removed my GTX1080 and all my other Drives from my Computer, not choose any Graphics parameter in UniBeast and rebuilt the USB Stick like 5 times... Impatience at its best :-D
You mean u remove your gpu from the motherboard & it fix the problem? i too have this problem :(
 
Joined
Mar 13, 2018
Messages
4
Motherboard
Z370 AORUS Gaming 5
CPU
Intel Core i7-8700K
Graphics
AORUS GeForce® GTX 1080 Ti Xtreme Edition 11G
Sorry for my poor English, but some of my experiences may help you. I tried to reinstall HIGH SIERRA with APFS (using EmuVariableUefi-64.efi in driver64uefi), The difference is, I changed OsxAptioFixDrv-64 with AptioMemoryFix. have a try, good luck!
Can you guide be how to do that? this is my first hackitosh.
 
Joined
Dec 21, 2014
Messages
13
Motherboard
Gigabyte Z370 AORUS Ultra Gaming
CPU
Intel Core i7-8700K
Graphics
Gigabyte GeForce GTX 770 OC 2GB
Mac
MacBook Pro
Mobile Phone
iOS
Can't find anything about "The recovery server could not be connected".
Absolutely clean installation, all was done referring to the instruction.

Any ideas? Thx!
If you are only on Wifi you need to connect to the wifi on the top right corner.
 
Joined
Mar 2, 2018
Messages
9
Motherboard
HP Compaq 6300 Pro
CPU
G2020
Graphics
GT 210
Mobile Phone
Android
Loved this guide - followed through with links and HP Compaq 6300 pro (With GT710) and it all worked also using another guide on TonyMacX86. WORKS! FAB!
(set BIOS to all UEFI and no legacy - and used MultiBeast to sort network, sound and Mac ID :eek:)

[ps: I can't change the info on mt TMx86 login, to show the new second hand gear I bought...]
 
Last edited:
Joined
Mar 2, 2018
Messages
9
Motherboard
HP Compaq 6300 Pro
CPU
G2020
Graphics
GT 210
Mobile Phone
Android
Can't find anything about "The recovery server could not be connected".
Absolutely clean installation, all was done referring to the instruction.

Any ideas? Thx!
--------------------

I had this. But repeating the process with network cable plugged in (and network/internet available) solved it
 
Joined
Dec 28, 2017
Messages
20
Motherboard
ASUS ROG STRIX Z370G
CPU
I7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac Pro
Classic Mac
Power Mac
Mobile Phone
iOS
NEED HELP!!! Finished the Hackintosh build of a G4 Quicksilver case but I am now stuck on the High Sierra Installation.
The USB is recognized and the OS starts loading but then it gets stuck on the apple logo with half of the progress bar and the circle progress bars (see below).
My set up is ASUS Z370G, Nvidia 1060 OC 6GB, I7-8700K, 16GB RIPJAWS V.
Any help or suggestions is appreciated.
IMG_0609.JPG
 
Top