Contribute
Register

UniBeast: Install macOS High Sierra on Any Supported Intel-based PC

Joined
Aug 22, 2015
Messages
8
Motherboard
GA-Z97X-UD7 TH
CPU
i7 4970K
Graphics
GTX 970
Mac
Classic Mac
Mobile Phone
iOS
First time unibeast user, long time mac user. Haven't attempted to build a hackintosh since early 2006, so my learning curve is pretty steep. On my macbook, I have tried to create the boot media, and unibeast is failing with "There was an error creating your unibeast drive: Couldn't copy apfs.efi to destination EFI folder". Log output is below:
Code:
10/24/17 21:18:13 - Starting UniBeast 8.0.0-20171024
10/24/17 21:18:38 - Copying Files...
10/24/17 21:26:46 - Installing Bootloader...
10/24/17 21:26:51 - Attaching Base System...
10/24/17 21:26:51 - Copying apfs.efi...
10/24/17 21:26:52 - Couldn't copy apfs.efi to destination ESP folder
I have rebooted, reformatted, and tried again with the same issue. Brand new 16gb sandisk thumb drive. Ideas?

Thanks
The reason is because you have to format with GUI.
 
Joined
May 15, 2017
Messages
2
Motherboard
GA-Z170X
CPU
intel i5 6500
Graphics
RX480
I’m stuck when I select install macOS, I click the continue button which then greys out but nothing happens it just seems to hang. The mouse still responds and I can select other options. Mobo z170 gaming, i5 6500, rx480. Note that I have tried this with integrated and dedicated gpu and have the same issue. I was able to format the hdd in disk utility ready for macOS install.
 
Joined
Mar 16, 2016
Messages
6
Motherboard
Gigabyte B85M-ds3h
CPU
Core i5 4460
Graphics
Gtx 950 SC
Mac
Mac Pro
Classic Mac
Apple
Mobile Phone
Android
I have an issue trying boot first time. I used 2 different USB and appears the message insert a properly boot an restart, what can i do?
 
Joined
Jan 4, 2011
Messages
384
Motherboard
Dell Alienware Aurora R7
CPU
i7-8700k
Graphics
AMD Radeon RX Vega64
Mac
Mac mini
Mobile Phone
Android, iOS
I can't seem to get UniBeast to create a boot USB.

It says, "Select Mac OS X Installer is Incomplete: Your selected Mac OS X Installer is the partial installer and doesn't contain everything that UniBeast needs to work correctly"

I have noticed the Installer is only 21MB is size and it only took a few seconds to download from the app store. It seems That the OS package image of the OS is missing.

I tried just installing High Sierra directly to my 64GB USB and I see an InstallESDDmg.pkg file with 4.71GB in size. This sounds like the missing file. Can I move this file somewhere?

I already tried the Terminal method yesterday with similar results of no valid OS.

I's appreciate any help
-=Mark=-
 
Joined
Mar 3, 2018
Messages
1
Motherboard
Msi gaming z87 gd65
CPU
i7 4770k
Graphics
none yet
After installation (steps 10, 11, 12), I reboot from "high sierra" disk and get the following error:
/system/installation/packages/osinstall.mpkg appears to be missing or damaged'

Any help on this one?
 
Joined
May 31, 2016
Messages
113
Motherboard
Gigabyte Z170X UD5 TH
CPU
I7-6700K
Graphics
VEGA 64
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
Android
I'm on the same boat. Any ideas?

At step 4.9 of the guide I get the following message when trying to execute the No-Convert script in Terminal from the HS installer: "No volumes with /macOS Install Data/minstallconfig.xml found, exiting". Any suggestions? Thanks.

4790k, Asus Maximus Impact VII, Onboard Graphics. Unibeast thumb drive is plugged into USB 2.0 slot.
 
Joined
Mar 7, 2018
Messages
23
Motherboard
Gigabyte Z370N WiFi mini-itx
CPU
i5-8400
Graphics
integrated
Mac
MacBook Pro
Mobile Phone
iOS
Can't find anything about "The recovery server could not be connected".
Absolutely clean installation, all was done referring to the instruction.

Any ideas? Thx!
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
21,018
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
Can't find anything about "The recovery server could not be connected".
Absolutely clean installation, all was done referring to the instruction.

Any ideas? Thx!
That says a lot about your search skills.
Put the kext for your network interface into /EFI/CLOVER/kexts/Other on the EFI partition of your USB installer.
Ensure that your system clock is set to the correct date/time.

Hint : Do not post for help in a guide thread - Start a new thread of your own in High Sierra Desktop Support.
 
Joined
Mar 7, 2018
Messages
4
Motherboard
MSI B85M-E45
CPU
I5 4590
Graphics
HD 4600
Mac
iMac
Mobile Phone
Android
After installation (steps 10, 11, 12), I reboot from "high sierra" disk and get the following error:
/system/installation/packages/osinstall.mpkg appears to be missing or damaged'

Any help on this one?
Sorry for my poor English, but some of my experiences may help you. I tried to reinstall HIGH SIERRA with APFS (using EmuVariableUefi-64.efi in driver64uefi), The difference is, I changed OsxAptioFixDrv-64 with AptioMemoryFix. have a try, good luck!
 
Top