Contribute
Register

Success: X79 UD5 + 10.13 High Sierra

Joined
Nov 10, 2011
Messages
364
Motherboard
Gigabyte X79-UD5
CPU
i7-3930K
Graphics
GTX 960
Mac
MacBook Air, MacBook Pro, Mac mini
Mobile Phone
Android, iOS
Hi All,

After some time and allot of help from others (PikerAlpha,Stork,Dr. Drumm,tofisi,Thanos, profmartinmarsian,TonyMac,MacMan, and all those I can't recall).

Below you will find the quick and dirty steps to get macOS 10.13 to boot on X79 UD5 Mainboard.

1- Make sure you have latest clover configurator 4.44.0 (mine is booting from SMBIOS MacPro6,1 profile), and Clover 4097

2- Create a macOS High Sierra Public Beta Installation USB by following the Tony Mac guide)

How to Create a macOS High Sierra Public Beta Installation USB

3- Download, and use the EFI Folder Attached below:

4- Below are the clover setting screenshots in case users have 3rd party devices not listed in my profile.


Will refine this down the line. Please note at this time Nvidia web drivers are not working. Looking for a solution for those that need it.


Screen Shot 2017-07-03 at 11.35.22 AM.png
Screen Shot 2017-07-03 at 11.35.27 AM.png

Screen Shot 2017-07-03 at 11.35.22 AM.png
Screen Shot 2017-07-03 at 11.35.27 AM.png
Screen Shot 2017-07-03 at 11.35.33 AM.png
Screen Shot 2017-07-03 at 11.35.38 AM.png
Screen Shot 2017-07-03 at 11.35.44 AM.png
Screen Shot 2017-07-03 at 11.35.50 AM.png
Screen Shot 2017-07-03 at 11.35.56 AM.png
Screen Shot 2017-07-03 at 11.36.00 AM.png
Screen Shot 2017-07-03 at 11.36.05 AM.png
 

Attachments

Last edited:
Joined
Dec 19, 2010
Messages
87
Motherboard
GA-X79-UD3
CPU
i7-3930K
Graphics
GTX-970
Mac
Mac Pro
Mobile Phone
iOS
Well done!

I see you used my DSDT. Glad it's working well for you.
With this DSDT, you don't need all of those clover patches.
I'm attaching a new DSDT (I think I made some more changes over the one you have) and config.plist + some kexts that in conjunction should also give you audio (Gave me 5.1 audio).

Try it out and let me know :)
 

Attachments

Joined
Nov 10, 2011
Messages
364
Motherboard
Gigabyte X79-UD5
CPU
i7-3930K
Graphics
GTX 960
Mac
MacBook Air, MacBook Pro, Mac mini
Mobile Phone
Android, iOS
Well done!

I see you used my DSDT. Glad it's working well for you.
With this DSDT, you don't need all of those clover patches.
I'm attaching a new DSDT (I think I made some more changes over the one you have) and config.plist + some kexts that in conjunction should also give you audio (Gave me 5.1 audio).

Try it out and let me know :)

Appreciate you Dr. Drumm - will give this one a shot, and loop back. BTW do you have Nvidia card working on your X79 UD3? My 960 and 560 are only getting 1024 rez ATM.


P.S. agree ATM it is pretty hacktastic ; )
 
Last edited:
Joined
Dec 19, 2010
Messages
87
Motherboard
GA-X79-UD3
CPU
i7-3930K
Graphics
GTX-970
Mac
Mac Pro
Mobile Phone
iOS
I installed the attached drivers. It's for Sierra, but hacked to install on High Sierra.
Won't give you acceleration but might give you native resolution.

It's for nvidia cards...


BTW,

You didn't say if the files I uploaded earlier worked for you. Did you manage to get sound working?
 

Attachments

Joined
Nov 10, 2011
Messages
364
Motherboard
Gigabyte X79-UD5
CPU
i7-3930K
Graphics
GTX 960
Mac
MacBook Air, MacBook Pro, Mac mini
Mobile Phone
Android, iOS
I installed the attached drivers. It's for Sierra, but hacked to install on High Sierra.
Won't give you acceleration but might give you native resolution.

It's for nvidia cards...


BTW,

You didn't say if the files I uploaded earlier worked for you. Did you manage to get sound working?

Hi, Dr. Drumm.

Appreciate that! Tried the Nvidia driver and no dice. I'm on beta 2 build (17A291m). In regards to 'hacking this in' do, you have any other details other than kext wizard...etc? Tried the Nvidia web driver updater 1.5.

For audio, I use RME Fireface 800 it is working perfectly with latest drivers that are fairly old. Love RME the drivers just always work regardless of platform and or builds. This thing is going on ten years + old and still runs like a champ! Maybe the best investment I ever made :). Only had to install a new power supply in that time.
 
Last edited:
Top