Success: X79 UD5 + 10.13 High Sierra

Discussion in 'High Sierra Desktop Guides' started by GuitarGuy77, Jul 4, 2017.

  1. GuitarGuy77

    GuitarGuy77

    Joined:
    Nov 10, 2011
    Messages:
    357
    Mobo:
    Gigabyte X79-UD5
    CPU:
    Intel Core i7-3930K @ 3.50 GHz 1 processor, 6 cores, 12 threads
    Graphics:
    GeForce GTX 960
    Mac:
    MacBook Air, MacBook Pro, Mac mini
    Mobile Phone:
    Android, iOS
    Jul 4, 2017 at 2:51 AM #1
    GuitarGuy77

    GuitarGuy77

    Joined:
    Nov 10, 2011
    Messages:
    357
    Mobo:
    Gigabyte X79-UD5
    CPU:
    Intel Core i7-3930K @ 3.50 GHz 1 processor, 6 cores, 12 threads
    Graphics:
    GeForce GTX 960
    Mac:
    MacBook Air, MacBook Pro, Mac mini
    Mobile Phone:
    Android, iOS
    Hi All,

    After some time and allot of help from others (PikerAlpha,Stork,Dr. Drumm,tofisi,Thanos, profmartinmarsian,TonyMac,MacMan, and all those I can't recall).

    Below you will find the quick and dirty steps to get macOS 10.13 to boot on X79 UD5 Mainboard.

    1- Make sure you have latest clover configurator 4.44.0 (mine is booting from SMBIOS MacPro6,1 profile), and Clover 4097

    2- Create a macOS High Sierra Public Beta Installation USB by following the Tony Mac guide)

    How to Create a macOS High Sierra Public Beta Installation USB

    3- Download, and use the EFI Folder Attached below:

    4- Below are the clover setting screenshots in case users have 3rd party devices not listed in my profile.


    Will refine this down the line. Please note at this time Nvidia web drivers are not working. Looking for a solution for those that need it.


    Screen Shot 2017-07-03 at 11.35.22 AM.png Screen Shot 2017-07-03 at 11.35.27 AM.png
    Screen Shot 2017-07-03 at 11.35.22 AM.png Screen Shot 2017-07-03 at 11.35.27 AM.png Screen Shot 2017-07-03 at 11.35.33 AM.png Screen Shot 2017-07-03 at 11.35.38 AM.png Screen Shot 2017-07-03 at 11.35.44 AM.png Screen Shot 2017-07-03 at 11.35.50 AM.png Screen Shot 2017-07-03 at 11.35.56 AM.png Screen Shot 2017-07-03 at 11.36.00 AM.png Screen Shot 2017-07-03 at 11.36.05 AM.png
     

    Attached Files:

    Last edited: Jul 5, 2017
  2. zlei

    zlei

    Joined:
    Jul 2, 2016
    Messages:
    283
    Mobo:
    GA-Z170-HD3
    CPU:
    i5 6500
    Graphics:
    GTX 960 Overclocked
    Mac:
    iMac
    Classic Mac:
    iMac
    Jul 6, 2017 at 3:00 AM #2
    zlei

    zlei

    Joined:
    Jul 2, 2016
    Messages:
    283
    Mobo:
    GA-Z170-HD3
    CPU:
    i5 6500
    Graphics:
    GTX 960 Overclocked
    Mac:
    iMac
    Classic Mac:
    iMac
    i can get access to language choosen sucessfully.
     
    GuitarGuy77 likes this.
  3. GuitarGuy77

    GuitarGuy77

    Joined:
    Nov 10, 2011
    Messages:
    357
    Mobo:
    Gigabyte X79-UD5
    CPU:
    Intel Core i7-3930K @ 3.50 GHz 1 processor, 6 cores, 12 threads
    Graphics:
    GeForce GTX 960
    Mac:
    MacBook Air, MacBook Pro, Mac mini
    Mobile Phone:
    Android, iOS
    Jul 6, 2017 at 3:31 AM #3
    GuitarGuy77

    GuitarGuy77

    Joined:
    Nov 10, 2011
    Messages:
    357
    Mobo:
    Gigabyte X79-UD5
    CPU:
    Intel Core i7-3930K @ 3.50 GHz 1 processor, 6 cores, 12 threads
    Graphics:
    GeForce GTX 960
    Mac:
    MacBook Air, MacBook Pro, Mac mini
    Mobile Phone:
    Android, iOS
    Congratulations!
     
  4. DrDrumm

    DrDrumm

    Joined:
    Dec 19, 2010
    Messages:
    66
    Mobo:
    GA-X79-UD3
    CPU:
    i7-3930K
    Graphics:
    Gigabyte GTX-970
    Mac:
    Mac Pro
    Mobile Phone:
    iOS
    Jul 6, 2017 at 3:05 PM #4
    DrDrumm

    DrDrumm

    Joined:
    Dec 19, 2010
    Messages:
    66
    Mobo:
    GA-X79-UD3
    CPU:
    i7-3930K
    Graphics:
    Gigabyte GTX-970
    Mac:
    Mac Pro
    Mobile Phone:
    iOS
    Well done!

    I see you used my DSDT. Glad it's working well for you.
    With this DSDT, you don't need all of those clover patches.
    I'm attaching a new DSDT (I think I made some more changes over the one you have) and config.plist + some kexts that in conjunction should also give you audio (Gave me 5.1 audio).

    Try it out and let me know :)
     
    GuitarGuy77 likes this.

    Attached Files:

  5. GuitarGuy77

    GuitarGuy77

    Joined:
    Nov 10, 2011
    Messages:
    357
    Mobo:
    Gigabyte X79-UD5
    CPU:
    Intel Core i7-3930K @ 3.50 GHz 1 processor, 6 cores, 12 threads
    Graphics:
    GeForce GTX 960
    Mac:
    MacBook Air, MacBook Pro, Mac mini
    Mobile Phone:
    Android, iOS
    Jul 6, 2017 at 5:18 PM #5
    GuitarGuy77

    GuitarGuy77

    Joined:
    Nov 10, 2011
    Messages:
    357
    Mobo:
    Gigabyte X79-UD5
    CPU:
    Intel Core i7-3930K @ 3.50 GHz 1 processor, 6 cores, 12 threads
    Graphics:
    GeForce GTX 960
    Mac:
    MacBook Air, MacBook Pro, Mac mini
    Mobile Phone:
    Android, iOS

    Appreciate you Dr. Drumm - will give this one a shot, and loop back. BTW do you have Nvidia card working on your X79 UD3? My 960 and 560 are only getting 1024 rez ATM.


    P.S. agree ATM it is pretty hacktastic ; )
     
    Last edited: Jul 6, 2017
  6. DrDrumm

    DrDrumm

    Joined:
    Dec 19, 2010
    Messages:
    66
    Mobo:
    GA-X79-UD3
    CPU:
    i7-3930K
    Graphics:
    Gigabyte GTX-970
    Mac:
    Mac Pro
    Mobile Phone:
    iOS
    Jul 6, 2017 at 7:46 PM #6
    DrDrumm

    DrDrumm

    Joined:
    Dec 19, 2010
    Messages:
    66
    Mobo:
    GA-X79-UD3
    CPU:
    i7-3930K
    Graphics:
    Gigabyte GTX-970
    Mac:
    Mac Pro
    Mobile Phone:
    iOS
    I'm getting my full screen's resolution: 2560x1440 with my 970. No acceleration, of course...
     
    GuitarGuy77 likes this.
  7. GuitarGuy77

    GuitarGuy77

    Joined:
    Nov 10, 2011
    Messages:
    357
    Mobo:
    Gigabyte X79-UD5
    CPU:
    Intel Core i7-3930K @ 3.50 GHz 1 processor, 6 cores, 12 threads
    Graphics:
    GeForce GTX 960
    Mac:
    MacBook Air, MacBook Pro, Mac mini
    Mobile Phone:
    Android, iOS
    Jul 6, 2017 at 7:58 PM #7
    GuitarGuy77

    GuitarGuy77

    Joined:
    Nov 10, 2011
    Messages:
    357
    Mobo:
    Gigabyte X79-UD5
    CPU:
    Intel Core i7-3930K @ 3.50 GHz 1 processor, 6 cores, 12 threads
    Graphics:
    GeForce GTX 960
    Mac:
    MacBook Air, MacBook Pro, Mac mini
    Mobile Phone:
    Android, iOS
    How are you doing that? Is there a place In config.plist or elsewhere I can hard code it to a higher setting? Locked into 1024x768 atm.

    Thanks!
     
  8. DrDrumm

    DrDrumm

    Joined:
    Dec 19, 2010
    Messages:
    66
    Mobo:
    GA-X79-UD3
    CPU:
    i7-3930K
    Graphics:
    Gigabyte GTX-970
    Mac:
    Mac Pro
    Mobile Phone:
    iOS
    Jul 6, 2017 at 8:11 PM #8
    DrDrumm

    DrDrumm

    Joined:
    Dec 19, 2010
    Messages:
    66
    Mobo:
    GA-X79-UD3
    CPU:
    i7-3930K
    Graphics:
    Gigabyte GTX-970
    Mac:
    Mac Pro
    Mobile Phone:
    iOS
    I installed the attached drivers. It's for Sierra, but hacked to install on High Sierra.
    Won't give you acceleration but might give you native resolution.

    It's for nvidia cards...


    BTW,

    You didn't say if the files I uploaded earlier worked for you. Did you manage to get sound working?
     
    GuitarGuy77 likes this.
  9. GuitarGuy77

    GuitarGuy77

    Joined:
    Nov 10, 2011
    Messages:
    357
    Mobo:
    Gigabyte X79-UD5
    CPU:
    Intel Core i7-3930K @ 3.50 GHz 1 processor, 6 cores, 12 threads
    Graphics:
    GeForce GTX 960
    Mac:
    MacBook Air, MacBook Pro, Mac mini
    Mobile Phone:
    Android, iOS
    Jul 6, 2017 at 10:58 PM #9
    GuitarGuy77

    GuitarGuy77

    Joined:
    Nov 10, 2011
    Messages:
    357
    Mobo:
    Gigabyte X79-UD5
    CPU:
    Intel Core i7-3930K @ 3.50 GHz 1 processor, 6 cores, 12 threads
    Graphics:
    GeForce GTX 960
    Mac:
    MacBook Air, MacBook Pro, Mac mini
    Mobile Phone:
    Android, iOS

    Hi, Dr. Drumm.

    Appreciate that! Tried the Nvidia driver and no dice. I'm on beta 2 build (17A291m). In regards to 'hacking this in' do, you have any other details other than kext wizard...etc? Tried the Nvidia web driver updater 1.5.

    For audio, I use RME Fireface 800 it is working perfectly with latest drivers that are fairly old. Love RME the drivers just always work regardless of platform and or builds. This thing is going on ten years + old and still runs like a champ! Maybe the best investment I ever made :). Only had to install a new power supply in that time.
     
    Last edited: Jul 6, 2017
  10. Phathak

    Phathak

    Joined:
    Nov 25, 2011
    Messages:
    19
    Mobo:
    Gigabyte X79-UD5
    CPU:
    Intel Core i7 3930K (3200) Six Core
    Graphics:
    Gigabyte Nvidia GeForce GTX660Ti
    Jul 10, 2017 at 12:27 AM #10
    Phathak

    Phathak

    Joined:
    Nov 25, 2011
    Messages:
    19
    Mobo:
    Gigabyte X79-UD5
    CPU:
    Intel Core i7 3930K (3200) Six Core
    Graphics:
    Gigabyte Nvidia GeForce GTX660Ti
    Hi @GuitarGuy77,
    I have almost the same rig as your but I can't even get to clover! Would you mind posting screenshots of your UEFI BIOS settings?
    Thank you!
     
    GuitarGuy77 likes this.

Share This Page