Contribute
Register

[SUCCESS] jbarnette's Build - ASUS TUF Z390 M Gaming + i9-9900K + Sapphire RX Vega 64 8GB + 32GB RAM + MacOS 10.14.3 w/ USB3 working!

Joined
Mar 1, 2017
Messages
51
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
@gyrene2083, after upgrading to 10.14.4, I cannot make audio work, which is fine on 10.14.2. Can you post your EFI for reference as I am using Z390 M GAMING, too.

I'm not home right now but you should take a look at the OPs EFI and compare it to yours if you haven't done so already. You should also post your config.plist and your EFI too. Maybe someone with more experience can take a quick look and see what's going on.

Good Luck.
 
Joined
Dec 28, 2018
Messages
4
Motherboard
GA-B85M-D3H
CPU
i5
Graphics
rx580
I'm not home right now but you should take a look at the OPs EFI and compare it to yours if you haven't done so already. You should also post your config.plist and your EFI too. Maybe someone with more experience can take a quick look and see what's going on.

Good Luck.

Use latest AppleALC with Lilu and inject layout id 1

I delete some kexts and it worked now.
 
Joined
Aug 25, 2013
Messages
99
Motherboard
Gigabyte Z390M Gaming
CPU
i5-8600K
Graphics
RX580+UHD630
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I must say I'm impressed by the thoroughness of the port diagram and the extensive comments in the DSL file! Some suggestions:
  • Each of your USB 2 headers supports two USB ports. On F_USB1 you have already deactivated HS09 because you know that the Fenvi is attached to HS10. And you've set the type to 255 (Internal). All of this is good.
  • On F_USB2, however, if the only connected device is the Titan Ridge card, I would suggest looking at IORegistryExplorer --> XHC to determine whether the Titan Ridge is attached to HS11 or HS12.
  • Then I would suggest removing the unused port and setting the used-port to type Internal (255) as well. You'll free up one port in the process, which you can reallocate to a different USB port.
Let's start with this and see how it goes.

Hello @CaseySJ,
Many thanks for following up and for the kind words. So I have tried enabling HS09 and adding the 255 descriptor, but without success.
After many changes I finally manage to have a stable sleep by disabling the third advanced options in the BT panel (to avoid BT devices to wake up the computer); But this was not enough I also had to disable the network acces wake up (and power nap, but I am not sure this one is really necessary) in the Energy Saver panel. This is quite confusing as I have disabled the "Wake on Lan" in the BIOS.... so at the end it is a BT AND a network issue causing immediate wake up. Not sure to understand why I have this problem as it seems to be OK for others having the same motherboard!
Many thanks for the suggestion for the Titan Ridge USB ports. I have some screenshots attached showing that if connected to THB Port 1, HS12 is used, and if connected to Port2, HS11 is used! so both ports are used by the card!
I will edit the SSDT to have both HS11 and 12 annotated as 255 and not 2 as it is in the current version. I 'll report back soon on that one.
One more thing: I think I know why the Fenvi card was previously not detected. After extensive trials this happens specifically when the Platform Power Management in BIOS is set on Enabled and more precisely when PCH ASPM is Enabled!
The card is detected when PEG ASPM and DMI ASPM are enabled and PCH ASPM is disabled !
Looks like the Fenvi card isnt compatible with this particular feature. Maybe this observation could help others .... or not :)

Thank you
 

Attachments

  • ConnectionPortTHB01.png
    ConnectionPortTHB01.png
    358.3 KB · Views: 70
  • ConnectionPortTHB02.png
    ConnectionPortTHB02.png
    319.4 KB · Views: 79
Last edited:
Joined
Aug 25, 2013
Messages
99
Motherboard
Gigabyte Z390M Gaming
CPU
i5-8600K
Graphics
RX580+UHD630
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I will edit the SSDT to have both HS11 and 12 annotated as 255 and not 2 as it is in the current version. I 'll report back soon on that one.

Hello @CaseySJ,
So I finally managed to find some time to try a few things (with the 3rd advanced options activated in BT panel):
  1. Reactivated HS09 port, and added on both HS09 and HS010 (F-USB1 header), the 255 descriptor for internal port > wake immediately after sleep
  2. same as above and in top added 255 annotation for HS11 and HS12 so all four ports described as internal > wake immediately after sleep
  3. Plugged the Fenvi card on F-USB2 (will use HS12) and Titan ridge card on F-USB1 (will use both HS09 and HS10), all ports with 255 annotation > wake immediately after sleep
So no real progress here but then I realized that in my office I have a BT device that I use for plugging my iPad / iPhone on my HiFi system. This device is actually always on. And after turning it off, the computer stays on sleep!!!!!
I cannot resist on attaching a picture of the culprit. And here is his pedigree:

https://www.amazon.com/dp/B07FZ3G7SC/?tag=tonymacx86com-20

I have tried with a Magic Mouse as well as a Logitech BT mouse, and with both devices computer stays on sleep, and can be powered by the devices. So I guess I will have to kick out the Esinkin adapter and try to find another one that is less likely to perturb so much the BT receiver of the Broadcom module of the Fenvi card. I haven't search much, yet, but I don't think anybody has yet experienced something like this...
Just amazed how little details like this could derail things
 

Attachments

  • 61QWZenMPiL._SL1431_.jpg
    61QWZenMPiL._SL1431_.jpg
    102.2 KB · Views: 71

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
14,809
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hello @CaseySJ,
...
So no real progress here but then I realized that in my office I have a BT device that I use for plugging my iPad / iPhone on my HiFi system. This device is actually always on. And after turning it off, the computer stays on sleep!!!!!
...
Just amazed how little details like this could derail things
So true! So the moral of the story is to disconnect all USB and Bluetooth devices and then enable them one by one to find the offender!
 
Joined
May 14, 2019
Messages
1
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K
Graphics
RX 570
You should have seen my signature, is that 1 week ago I was deciding which parts I would use to mount my Hackintosh, and I would be informed.
But during that week, I decided to change to this one, and I do not have any of those parts, because it is a long-term project, because here in Brazil the value is doubled or triple that of the USA.

Hey man! I'm also Brazilian, and my build is really similar to yours. It's my first time building a hackintosh, maybe we can speak about it some time? :)
 
Joined
Apr 10, 2016
Messages
12
Motherboard
Gigabyte Z390 M Gaming
CPU
i5-8600K
Graphics
RX 580
Mobile Phone
  1. iOS
Anyone successfully updated to 10.14.5??
 
Top