Contribute
Register

[Solved] Mojave boot problem with UniBeast created Mojave USB drive

Joined
Nov 6, 2010
Messages
69
Motherboard
Gigabyte H370M-DS3H
CPU
i7-8770
Graphics
UHD 630
Mac
MacBook Pro, Mac mini
Mobile Phone
Android
#11
It is happening third and more times. I didn't mention before but I am trying to to install mojave into a nvme ssd. Can this be a problem? Should I Change SAT0 to SATA" patch in ACPI section of config.plist for the nvme ssd too?
 
Joined
Nov 11, 2018
Messages
954
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
#12
It is happening third and more times. I didn't mention before but I am trying to to install mojave into a nvme ssd. Can this be a problem? Should I Change SAT0 to SATA" patch in ACPI section of config.plist for the nvme ssd too?
NVMe (PCIe) SSDs do not technically require the SAT0-to-SATA patch. It can (and should) be added at some point.

Another possible cause for your problem might be the use of AptioMemoryFix in the CLOVER/driversUefi64 folder. Have you tried replacing it with:
  • OsxAptioFix2Drv-free2000 and setting slide=0 in Boot arguments?
  • OsxAptioFix2Drv-free2000 without setting slide=0 in Boot arguments?
This is available from bullet #3 here:
https://nickwoodhams.com/x99-hackintosh-osxaptiofixdrv-allocaterelocblock-error-update/

Have you tried re-creating the disk by running UniBeast again? Reason: possible corruption of 6GB mojave image.

You mentioned the SanDisk SD card above. Have you tried a plain and simple USB flash memory stick?

If this also fails, please compress and upload the EFI folder from your USB install disk.
 
Joined
Nov 6, 2010
Messages
69
Motherboard
Gigabyte H370M-DS3H
CPU
i7-8770
Graphics
UHD 630
Mac
MacBook Pro, Mac mini
Mobile Phone
Android
#13
CaseySJ!
You are awesome! OsxAptioFix2Drv-free2000 with settings slide=0 helped the installation went on, and I could finished the whole process. Now I am starting the post installation fine tuning.
Thanks again!
 
Top