Contribute
Register

[Solved] iMessage customer code with my id

Joined
Sep 30, 2018
Messages
21
Motherboard
ASUS PRIME Z390-A
CPU
i5-9600k
Graphics
Sapphire RX 5700XT Nitro+
Hi, it is a week that I have some problems with iMessage. I tried everything and it seems to be working with other Apple ID but non with the mine. When I try to log in with my id I receive the customer code message, and I have to call the support.
What can I do ? Thank you for your patience.
 
Joined
Sep 30, 2018
Messages
21
Motherboard
ASUS PRIME Z390-A
CPU
i5-9600k
Graphics
Sapphire RX 5700XT Nitro+
I already tried to:
-add credit card
-change password
-log on a legit apple product
-run Imessagedebug, and all SMBIOS details and RT variables is the same every boot (Nvram is ok)
-delete cache
I think that is a lock on my account because I can log in iMessage with my wife's account (account created in 2012).
I tried to call apple but nothing changed.

Bob, that guide is useless for me, I already used all the tips.
 
Last edited:

pastrychef

Moderator
Joined
May 29, 2013
Messages
16,247
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
If your account is locked, no one can help you except Apple.
 
Joined
Sep 30, 2018
Messages
21
Motherboard
ASUS PRIME Z390-A
CPU
i5-9600k
Graphics
Sapphire RX 5700XT Nitro+
If your account is locked, no one can help you except Apple.
It's really strange, I can log in on my MacBook Pro, iPhone , but not on the Hackintosh which it's ok with my wife's account. I tried with apple support and this is what happened:
1. Apple customer service unlocked account
2. i log in in iMessage, all it's ok
3 after 3 second iMessage kicked me off, and I had again the customer code
 
Last edited:

pastrychef

Moderator
Joined
May 29, 2013
Messages
16,247
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
It's really strange, I can log in on my MacBook Pro, iPhone , but non on the Hackintosh which it's ok with my wife's account. I tried with apple support and this is what happened:
1. Apple customer service unlocked account
2. i log in in iMessage, all it's ok
3 after 3 second iMessage kicked me off, and I had again the customer code

Make sure your NVRAM is working right on the hackintosh and/or clean NVRAM.
 
Joined
Sep 30, 2018
Messages
21
Motherboard
ASUS PRIME Z390-A
CPU
i5-9600k
Graphics
Sapphire RX 5700XT Nitro+
I cleaned the nvram, and deleted all the iMessage service cache, tried another network, but still nothing changed.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
16,247
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I cleaned the nvram, and deleted all the iMessage service cache, tried another network, but still nothing changed.

And you've set up Serial, Board Serial, and UUID in config.plist?
 
Joined
Sep 30, 2018
Messages
21
Motherboard
ASUS PRIME Z390-A
CPU
i5-9600k
Graphics
Sapphire RX 5700XT Nitro+
yeah surely.
anyway thank you for the help.
 
Top