Contribute
Register

Shutdown/Sleep and USB 3.1 not working

Status
Not open for further replies.
Joined
Nov 15, 2018
Messages
8
Motherboard
Asus Prime Z390-A
CPU
i5-9600K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hy!

Just assembled my first Hackintosh (Asus Prime Z390-A with i5-9600K and Nitro+ RX580) and the only two things not working are Shutdown/Restart/Sleep and the USB 3.1 Ports from the GPU (Front panel working though).

If I click restart, shutdown or sleep in the apple menu or press the on/off, the system just freezes and I need to make a hard reset. The USB 3.1 ports simply just don't work.

Maybe these issues are more common and someone can provide help?
 
Joined
Nov 28, 2011
Messages
147
Motherboard
ASUS Prime H370M-PLUS
CPU
i5-8600
Graphics
RX 570
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. Android
Have you tried USBInjectAll.kext? Did you follow a build guid for the board? Also, what Aptio fix are you using? I recommend removing AptioMemoryFix-64.efi and trying one of the three OSXPtioFixDrv files. Though my ASUS board is different, I had to use RC scripts and emulated NVRAM in the clover install.
 
Joined
Nov 15, 2018
Messages
8
Motherboard
Asus Prime Z390-A
CPU
i5-9600K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Have you tried USBInjectAll.kext? Did you follow a build guid for the board? Also, what Aptio fix are you using? I recommend removing AptioMemoryFix-64.efi and trying one of the three OSXPtioFixDrv files. Though my ASUS board is different, I had to use RC scripts and emulated NVRAM in the clover install.

Hey, yes I tried the USBInjectAll.kext and it did a good job with the front panel I guess. Also the two USB 2 ports on the Mobo are working, it's just the USB 3 ports they're with no function at all.
I'll definitely try the Aptio fixes you mentioned, as it's my first build I'm not quite familiar yet with all the different tweaks though. I partly followed a guide from someone who made a i9 build with the same Motherboard I'm using. Took his EFI folder and made a few adaptions he recommended for non i9 users.
 
Joined
Nov 28, 2011
Messages
147
Motherboard
ASUS Prime H370M-PLUS
CPU
i5-8600
Graphics
RX 570
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. Android
Hey, yes I tried the USBInjectAll.kext and it did a good job with the front panel I guess. Also the two USB 2 ports on the Mobo are working, it's just the USB 3 ports they're with no function at all.
I'll definitely try the Aptio fixes you mentioned, as it's my first build I'm not quite familiar yet with all the different tweaks though. I partly followed a guide from someone who made a i9 build with the same Motherboard I'm using. Took his EFI folder and made a few adaptions he recommended for non i9 users.

In addition to USBInjectAll.kext, you will need to apply the port limit patch in your config.plist via cloverconfigurator. Each port is essentially two USB ports, one 2.0 and one 3.0 and USB C ports can be as much as four based on how the motherboard interprets the port (you can put it in either way and some motherboards allocate a port for each speed for each insertion orientation). So, in the end you will exceed the port limit of OSX without the limit patch.
 
Joined
Nov 15, 2018
Messages
8
Motherboard
Asus Prime Z390-A
CPU
i5-9600K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
In addition to USBInjectAll.kext, you will need to apply the port limit patch in your config.plist via cloverconfigurator. Each port is essentially two USB ports, one 2.0 and one 3.0 and USB C ports can be as much as four based on how the motherboard interprets the port (you can put it in either way and some motherboards allocate a port for each speed for each insertion orientation). So, in the end you will exceed the port limit of OSX without the limit patch.

Thanks a bunch blueridgedog!

Do you guys know a solution for the shutdown/restart freeze? I tried to find a solutions in here, google and other sites, but couldn't get any useful information. It's the only thing thats missing now for the perfect built. Without a solution there's no way for me to update because of the freeze whilst restarting.
 
Status
Not open for further replies.
Top