Contribute
Register

Radeon Compatibility Guide - ATI/AMD Graphics Cards

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,559
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
So plugging in your monitor directly to the motherboard will be enough to use the iGPU? No need to disable a plugged in 5700 XT?

@arvinsim,

You may need to use Lilu + WahtEverGreen to correctly configure your IGPU :-


You may also need to disable the VESA level drivers from attaching to the 5700 dGPU using this SSDT method :-


Although that guide is aimed at disabling the VESA drivers for the Installer it also works well for MacOS, many Nvidia owners use the method to disable an unsupported Nvidia Card in Mojave .. the same applies to unsupported AMD GPU's.

Cheers
Jay
 
Joined
Jan 10, 2018
Messages
23
Motherboard
Gigabyte Z390M
CPU
I7-8700
Graphics
RX 5700 XT
Mac
MacBook Pro
@arvinsim,

You may need to use Lilu + WahtEverGreen to correctly configure your IGPU :-


You may also need to disable the VESA level drivers from attaching to the 5700 dGPU using this SSDT method :-


Although that guide is aimed at disabling the VESA drivers for the Installer it also works well for MacOS, many Nvidia owners use the method to disable an unsupported Nvidia Card in Mojave .. the same applies to unsupported AMD GPU's.

Cheers
Jay
Thanks Jay. Will follow this guide then.
 
Joined
Aug 9, 2011
Messages
12
Motherboard
Asus ROG Strix Z390 I
CPU
i9-9900K
Graphics
RX 580
Mac
iMac, MacBook Pro
Mobile Phone
iOS
I use an Sapphire RX 580 Pulse 8 GB graphics card, which appears to be one of the more compatible ones. Unfortunately I have an issue where the card randomly freezes in macOS (does not happen in Windows or Linux).

I have verified my BIOS settings on my Z390i are optimal, and my memory is working great at the proper timings with a full 4 pass run in MemTest86.

I have tried iMac18,3 (and iMac19,1 after reinstall) with the iGPU + dGPU together. It results in the freeze, which I cannot reliable reproduce. It can happen 15 minutes after boot, or after a week of running the machine. Not using the dGPU and using iMac18,1 makes the machine stable, and the issue no longer occurs. During the freeze I can move my mouse, and I get a colored square over where the mouse would appear eventually. The GPU appears to crash and I can still access the system over SSH and view logs. At this time I can see that the logs repeatedly write `com.apple.DumpGPURestart` over and over.

I have also tried only using a dGPU with iMacPro1,1 and this resulted in the same as above.

My EFI is fairly simple, I have no unusual kexts, just Lilu 1.3.8 + Whatevergreen 1.3.2 (latest as of posting). I am using Clover 5070 (also latest). All tests were done using Mojave versions 10.14.1-6, all of them have had the same problem.

I'd like to be using iMac19,1 as it would ideally work best with my Coffee Lake i9, and my RX 580. Do you think windows/linux aren't pushing the GPU the way macOS is? Should I just buy another card and roll the dice? Any advice on how I could get this working would be greatly appreciated. I can provide more details if anyone wants, I've been chasing this problem for 6 months.

Here is a link to my sapphire cards BIOS.

EDIT: Given some advice to try disabling XMP in another thread, I decided to try that with iMac19,1 SMBIOS and things have been stable so far (40 hours). I have tried this before in iMacPro1,1 and iMac18,3 but it never worked. I wonder if the combination of the SMBIOS that is more compatible with my chipset and processor fixed this. I am little surprised that my 3200 MHz RAM must be kept at 2133 MHz to run macOS, especially when it runs perfectly fine in Windows/Ubuntu at the desired speed, but it is a small price to pay for stability.
 
Last edited:
Joined
Sep 17, 2019
Messages
2
Motherboard
MSi H61M-P31 (G3)
CPU
Intel Core i5-3450
Graphics
Sapphire RX 550 2GB (Polaris 21-based)
Hi everybody, just got Sapphire's RX550 which one based on Polaris 21(RX560's chip) with ID 67FF1002
I've already red a few messages about it should work OOB, but seems nobody reported about that. Maybe somebody got expierence with that card?
Thanks!
 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,559
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
Hi everybody, just got Sapphire's RX550 which one based on Polaris 21(RX560's chip) with ID 67FF1002I've already red a few messages about it should work OOB, but seems nobody reported about that. Maybe somebody got expierence with that card?

@DimaYozh,

Try installing Lilu + WhatEverGreen ....


Cheers
Jay
 
Joined
Sep 17, 2019
Messages
2
Motherboard
MSi H61M-P31 (G3)
CPU
Intel Core i5-3450
Graphics
Sapphire RX 550 2GB (Polaris 21-based)
@DimaYozh,

Try installing Lilu + WhatEverGreen ....


Cheers
Jay
Thanks a lot! I'll try to install macOS in following weekend(last time I installed hack in El Capitan times, many things change since then?) Sorry for offtopic
 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,559
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
Thanks a lot! I'll try to install macOS in following weekend(last time I installed hack in El Capitan times, many things change since then?) Sorry for offtopic

@DimaYozh,

Things have moved on a lot since the days of El Cap ...

Lilu + WhatEverGreen should take care of configuring your AMD GPU with the correct Frame Buffer and any other patches that may be needed. Be sure to enable your IGPU in the BIOS and configure it as Headless. The AppleALC plugin should take care of your Audio .... its all explained in that guide i linked you to.

As explained in the guide you should remove any appropriate fixes and settings from clovers config file so that Lilu and the plugins can work correctly ...

Cheers
Jay
 
Joined
Jan 10, 2018
Messages
23
Motherboard
Gigabyte Z390M
CPU
I7-8700
Graphics
RX 5700 XT
Mac
MacBook Pro
Hi everybody, just got Sapphire's RX550 which one based on Polaris 21(RX560's chip) with ID 67FF1002
I've already red a few messages about it should work OOB
From the Mojave GPU Buyer's guide

Regarding Polaris, basically every model of card is supported as kong as it’s running a Polaris core(lower end cards like the RX550 run a Lexa core meaning no support in MacOs).
EDIT: Seems to be only on some models of RX 550 so yours should be fine
 
Joined
May 12, 2017
Messages
20
Motherboard
MSI Z270 Gaming Pro Carbon
CPU
i5-7600
Graphics
RX 550
Mac
MacBook Pro
Mobile Phone
iOS
EDIT: Seems to be only on some models of RX 550 so yours should be fine
I ordered a Radeon RX 550 few days ago. It should arrive before the end of October (currently out of stock - new product).

I took a careful look about RX 550 card before buying it (but I paid it about 60€, so if it doesn't work, that's not big money...). From what I've read, only "new" RX 550, based on Polaris 21 version (which is called Baffin) are compatible. The ones not compatible are flagged as Polaris 12 - Lexa.

Another spec to look at when searching for such card is "Shading Units" which are 512 for Lexa and 640 for Baffin. So, to me (but not currently tested) :
- Arez Phoenix RX 550 is OK
- while Asus RX 550 is not

@DimaYozh any news on your build ? It seems I'll receive the same GPU as you.
 
Top