Contribute
Register

Radeon Compatibility Guide - ATI/AMD Graphics Cards

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,562
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
I ordered a Radeon RX 550 few days ago. It should arrive before the end of October (currently out of stock - new product).

I took a careful look about RX 550 card before buying it

@Kuaaaly,

AMD RX 550 is not listed in the compatibility list in post #1 ...
But as you say it most likely depends on the Polaris version you GPU has ...
Let us know how you get on with it ...

Cheers
Jay
 
Joined
May 22, 2011
Messages
1,053
Motherboard
ASUS TUF Z390 Plus Gaming
CPU
i9-9900K
Graphics
RX 560
Mac
iMac, MacBook Pro
Mobile Phone
iOS
@jaymonkey we are seeing apple officially support RX560 but we are still getting a black screen on boot without WEG. is there any way to pass black screen on boot without WEG?
 
Last edited:

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,562
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
@jaymonkey we are seeing apple officially support RX560 but we are still getting a black screen on boot without WEG. is there any way to pass black screen on boot without WEG?

@telepati,

Real Macs have completely different ACPI tables to PC's ...
WEG patches the ACPI tables so that they work in MacOS and ensures the correct AMD FrameBuffer is used ..etc

You could use some clover patches and write some custom SSDT's if you did not want to use WEG but I'm not sure why you would want to do that ... WEG is a simple one stop solution for all GPU's on MacOS.

Cheers
Jay
 
Last edited:
Joined
Oct 1, 2019
Messages
1
Motherboard
I still didn't read
CPU
the RULES
Graphics
so ignore me
I can’t get vega 56, a black screen in the center and artifacts
YK5f1RH4yU0.jpg
 
Joined
May 12, 2017
Messages
20
Motherboard
MSI Z270 Gaming Pro Carbon
CPU
i5-7600
Graphics
RX 550
Mac
MacBook Pro
Mobile Phone
iOS
@Kuaaaly,

AMD RX 550 is not listed in the compatibility list in post #1 ...
But as you say it most likely depends on the Polaris version you GPU has ...
Let us know how you get on with it ...

Cheers
Jay
Very good news here! I received my RX 550 today and it's working OOB. Since I use the 3 video outputs (DP, HDMI, DVI) I had the "pink tint" problem on the DVI port (which I use with a DVI to HDMI adapter). Problem solved in a minute with this guide. If anyone knows a better idea to solve definitely the pink tint using Clover or EFI, I'm interested!

EDIT (solved):
  • Problem: it seems that sometimes the GPU is detected as RX 550 and sometimes RX 560...
  • Solution: this is the case (detected as 560) when the "Inject ATI" box is ticked in Clover Configurator (config.plist)

EDIT 2 (solved):
  • Problem: OOB on a fresh Mojave install Sleep / Wake & Hibernate worked well but since I restored a Time Machine backup of my MBP, hibernate stopped working. No idea why. It goes to hibernate in 1 or 2 minutes but on "wake up" I hear the computer "waking up" but I got black screen. If anyone has an idea...
  • Solution: this happened after I physically switched the GTX 1060 to PCIe slot 2 and RX 550 to PCIe slot 1. I revert this change and deactivate GTX 1060 using RehabMan SSDT trick see here for the solution in my specific case and here for global one.

IMG_1964.jpeg


IMG_1967.jpeg
 
Last edited:
Joined
Oct 2, 2019
Messages
6
Motherboard
Asus ROG Strix Z390-e Gaming
CPU
i5-9600K
Graphics
RX 580
Has anyone had an issue where their Hackintosh restarts halfway through booting up when a GPU is plugged in but the system boots into MacOS fine when the card is unplugged? I've tried every solution I've come across. Losing my mind trying to solve a problem for an OOB card supposedly. Rx 580, Z390, i5 9600k. (Can provide more info if anyone can actually help, getting desperate here)
 
Joined
May 12, 2017
Messages
20
Motherboard
MSI Z270 Gaming Pro Carbon
CPU
i5-7600
Graphics
RX 550
Mac
MacBook Pro
Mobile Phone
iOS
Has anyone had an issue where their Hackintosh restarts halfway through booting up when a GPU is plugged in but the system boots into MacOS fine when the card is unplugged? I've tried every solution I've come across. Losing my mind trying to solve a problem for an OOB card supposedly. Rx 580, Z390, i5 9600k. (Can provide more info if anyone can actually help, getting desperate here)
Yes, your HW is supposed to work OOB. Can you attach EFI Folder?
 
Joined
Oct 2, 2019
Messages
6
Motherboard
Asus ROG Strix Z390-e Gaming
CPU
i5-9600K
Graphics
RX 580
Yes, your HW is supposed to work OOB. Can you attach EFI Folder?
This is what I'm currently using, with just the iGPU everything seems to work fine. Its when I plug the RX580 in that it gets about halfway through startup and then restarts and it does that every time until I remove the RX580. Thanks for the help.
 

Attachments

Joined
Sep 27, 2017
Messages
3
Motherboard
MSI Gaming M5
CPU
i5-9600K
Graphics
Radeon VII
Mac
iMac
Mobile Phone
iOS
Anyone experiencing issues with Radeon VII and Catalina? I can get mine to boot with latest stable Clover r5070, and latest drivers, but it will only work on the last DisplayPort on the card, and will only show on one monitor. It will not load or detect any other monitors. Was working fine before upgrade to Catalina. I have attached my EFI.
 

Attachments

Joined
May 5, 2019
Messages
3
Motherboard
GIGABYTE Z390 M Gamer
CPU
i9-9900
Graphics
Vega46
Mac
Mac Pro
Anyone experiencing issues with Radeon VII and Catalina? I can get mine to boot with latest stable Clover r5070, and latest drivers, but it will only work on the last DisplayPort on the card, and will only show on one monitor. It will not load or detect any other monitors. Was working fine before upgrade to Catalina. I have attached my EFI.
I have the same issue with Vega 56. Only one DisplayPort and the HDMI works. No detect any other monitor.
 
Top