Contribute
Register

pastrychef's Asus ROG Strix Z370-G Gaming (WI-FI AC) build w/ i9-9900K + AMD 6600 XT

Anyone can help me with WiFi? It not works
depends on the make and model of your wifi card and if it is supported and if you are using the correct kexts and if your usb ports are setup correctly.....
 
depends on the make and model of your wifi card and if it is supported and if you are using the correct kexts and if your usb ports are setup correctly.....
In Ventura I see this wifi (see attach file). Do I have to copy some kext from Ventura EFI to Sonoma EFI to make it works?
 

Attachments

  • Screenshot 2023-12-06 alle 18.20.00.png
    Screenshot 2023-12-06 alle 18.20.00.png
    203 KB · Views: 13
In Ventura I see this wifi (see attach file). Do I have to copy some kext from Ventura EFI to Sonoma EFI to make it works?
to make your broadcom work then you will need to use OCLP to make it work for Sonoma
 
Hi @fbud,

USB Ports:
I also experienced USB issues when I did a fresh install of Sonoma 14.1 (I have not updated yet to 14.1.2); only 'some' of the USB ports were working - fewer ports than in Monterrey (but at least some ARE working). I would appreciate it if you could share the USBkext - as these may enable additional ports (I am not sure where to find info about the port configuration - not sure if the initial description in the first post of this thread by Pastry is still relevant/usable.

WIFI:
It does not work for me, however I use wired internet so it does not really bother me.

GPU related question:
I still use the SAPPHIRE Radeon RX 580 NITRO+ 8GB VGA (and the Intel i7-8700K CPU), I am planning to upgrade the GPU (only the GPU) to the GIGABYTE Radeon RX 6600 XT EAGLE 8G - as this is more affordable now. My question if I need to do any 'tweeks' when I replace the GPUs (I only hope that I can simply swap these and have the system running as before). Do you have any insights on this by any chance? thanks.
 
GPU related question:
I still use the SAPPHIRE Radeon RX 580 NITRO+ 8GB VGA (and the Intel i7-8700K CPU), I am planning to upgrade the GPU (only the GPU) to the GIGABYTE Radeon RX 6600 XT EAGLE 8G - as this is more affordable now. My question if I need to do any 'tweeks' when I replace the GPUs (I only hope that I can simply swap these and have the system running as before). Do you have any insights on this by any chance? thanks.

Just add "agdpmod=pikera" boot-arg.
 
Hi @fbud,

USB Ports:
I also experienced USB issues when I did a fresh install of Sonoma 14.1 (I have not updated yet to 14.1.2); only 'some' of the USB ports were working - fewer ports than in Monterrey (but at least some ARE working). I would appreciate it if you could share the USBkext - as these may enable additional ports (I am not sure where to find info about the port configuration - not sure if the initial description in the first post of this thread by Pastry is still relevant/usable.

WIFI:
It does not work for me, however I use wired internet so it does not really bother me.

GPU related question:
I still use the SAPPHIRE Radeon RX 580 NITRO+ 8GB VGA (and the Intel i7-8700K CPU), I am planning to upgrade the GPU (only the GPU) to the GIGABYTE Radeon RX 6600 XT EAGLE 8G - as this is more affordable now. My question if I need to do any 'tweeks' when I replace the GPUs (I only hope that I can simply swap these and have the system running as before). Do you have any insights on this by any chance? thanks.
WiFi working. See attach config.plist (use post install root patch in OC Patcher - after reboot reset NVRAM). USB ports working.
 

Attachments

  • config.plist
    37.7 KB · Views: 13
  • USBPorts.kext.zip
    2.3 KB · Views: 5
EFI updated to OpenCore 0.9.7
Attached are two different EFI for those with Ventura and the other for Sonoma.
...to replace with your own USBPorts.kext , SMBIOS, Mac address, Device Properties (GPU Injection).
I added Sonoma Updates.pdf to help run and view macOS updates.

macOS 14.2 Update, took ~25 minutes.
 

Attachments

  • EFI OC 0.9.7 Z370G.zip
    11.7 MB · Views: 21
  • EFI Sonoma OC 0.9.7 Z370G.zip
    17.8 MB · Views: 38
Hey all,

I'm about to make a clean Sonoma setup, but I have a quick question, will I be able to transfer all my stuff from time machine after the install? I'm currently running Monterey and have my backups ready.

The reason why I ask is that previously I had issues using the backups, and I just wonder if people have positive experience with Sonoma. Thanks!


Okay guys, I need some help. I was able to install Sonoma on top of Monterey, and successfully booted, however I cannot apply OCLP. I disabled secure boot in Bios and in my config, and followed Chef's advice on how to disable SIP. However, OCPL keep telling me that SIP is not disable and current booted SIP is 0x00.
 
Last edited:
Hey all,

I'm about to make a clean Sonoma setup, but I have a quick question, will I be able to transfer all my stuff from time machine after the install? I'm currently running Monterey and have my backups ready.

The reason why I ask is that previously I had issues using the backups, and I just wonder if people have positive experience with Sonoma. Thanks!


Okay guys, I need some help. I was able to install Sonoma on top of Monterey, and successfully booted, however I cannot apply OCLP. I disabled secure boot in Bios and in my config, and followed Chef's advice on how to disable SIP. However, OCPL keep telling me that SIP is not disable and current booted SIP is 0x00.

Did you try clearing NVRAM from the OpenCore boot picker?
 
Did you try clearing NVRAM from the OpenCore boot picker?
Yeah, I initially done that, but probably messed up something else afterwards. Today with the fresh head I've repeated all the steps and now everything seems to work fine, WiFi is up, sleep\wake seems to work.
But the boot time now became even longer.

Do you know if there is a way to fix that? I'm using EVO 960 NVME, and before Monterey boot times were perfect.
Update: no way fixing it.
Also, do you know how to return chime on boot, I kinda liked it :)

Thanks guys, as usual, you are the best!!

Screenshot 2023-12-17 at 3.52.10 PM.png
 
Last edited:
Back
Top