Contribute
Register

OsxAptioFix2Drv-64.efi VS OsxAptioFix2Drv-free2000.efi

Status
Not open for further replies.
Joined
Feb 19, 2014
Messages
25
Motherboard
H370M D3H
CPU
i7-8700K
Graphics
RX 580
Mac
  1. iMac
And some windows
Screen Shot 2020-02-21 at 12.42.21.jpg
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,198
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I tried, copied the entire folder and had it shut down.

1. Shutdown (work, I think I was still using the last boot drivers)
2. Initialized normally.
3. I tried to shut down and it restarted. (shutdown don't work)

Please test and see if NVRAM is working on your motherboard.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,198
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS

Yes. I enabled SIP for you. You obviously have unsigned hackintosh kexts in /Library/Extensions/ and/or /System/Library/Extensions/. Please MOVE (not copy) them to /EFI/CLOVER/kexts/Other/.
 
Joined
Feb 19, 2014
Messages
25
Motherboard
H370M D3H
CPU
i7-8700K
Graphics
RX 580
Mac
  1. iMac
Please test and see if NVRAM is working on your motherboard.
Not working
 
Joined
Feb 19, 2014
Messages
25
Motherboard
H370M D3H
CPU
i7-8700K
Graphics
RX 580
Mac
  1. iMac
Yes. I enabled SIP for you. You obviously have unsigned hackintosh kexts in /Library/Extensions/ and/or /System/Library/Extensions/. Please MOVE (not copy) them to /EFI/CLOVER/kexts/Other/.

I made a backup and deleted the kexts from /L/E and /S/L/E.
I think what I really needed is in the EFI folder.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,198
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS

Attachments

  • EFI.zip
    18.4 MB · Views: 121

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,198
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
NVRAM not working
Shutdown not working

Just out of curiosity I compared the first and second EFI you sent:
View attachment 451091
That's right?

Yes. Correct.

Please try adding "slide=0" (without the quotes) to config.plist > Boot > Arguments.
 
Joined
Feb 19, 2014
Messages
25
Motherboard
H370M D3H
CPU
i7-8700K
Graphics
RX 580
Mac
  1. iMac
Yes. Correct.

Please try adding "slide=0" (without the quotes) to config.plist > Boot > Arguments.
I tested it three times to make sure:

NVRAM working
Shutdown working

Thanks @pastrychef
:headbang:


Do I really need these arguments?

shikigva=32
shiki-id=Mac-7BA5B2D9E42DDD94
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,198
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I tested it three times to make sure:

NVRAM working
Shutdown working

Thanks @pastrychef
:headbang:


Do I really need these arguments?

shikigva=32
shiki-id=Mac-7BA5B2D9E42DDD94

I have no idea. Those were added by you... I don't use them.
 
Status
Not open for further replies.
Top