Contribute
Register

OSX 10.8.2 Mountain Lion - App Store Fix Instructions

Joined
Jul 31, 2012
Messages
29
Motherboard
Biostar TP 55
CPU
Intel Core i5 661
Graphics
GeForce GT 520
Mac
Classic Mac
Mobile Phone
Hi,

This is a guide for people who can't get App Store working. I have tried virtually "all" the ways that is possible to get app store working. In conclusion there is only 1 way that work for me (side note: if there is only 1 way that work when all has failed, which mean that 1 way is the "solid" universal way). This may seem tough but it really is not. So don't scare yourself.


Requirements:
----------------
1 - Champlist v3.1
2 - Efi Studio v1.1
3 - TextWrangler

Procedures:
-------------
Step 1: Open Champlist. For many people it will ask to update to your champlist to some new version like for my case it is: Champlist r2051. What you are updating is not the champlist but rather the chameleon boot loader. Click the update button to let it update "automatically".

Step 2: Go to Config tab on Champlist. Then check "use kernal cache, ethernet built-in, timeout:2, graphics enabler, 1024x768x32, NPCI=0x3000, darkwake=0, V-boot, PCIRoot=1 " . Then click "Apply" button. If you check anything else beside this it may prevent your hackintosh to boot up.
Unless you want to spend 3hr reformat and reconfigure your mac software be my guest.

Step 3: Go to Smbios tab on Champlist. Choose Model MacPro3,1 <-- you do this so you can boot without problem.

Step 4: Choose your country: I live in usa so i choose: G8 Usa. For the purpose of making this work even if you live in some non usa country you would still choose "G8 Usa". Then click Apply button. If you want to try other country be my guess but beware you might waste your time.

Step 5: Open Efi studio. Choose Select Device: Ethernet. Then click "add Device button". Then Copy the LONG Hex string of text.

Step 6: Go to your Mac Hard Drive/Extra/ folder. Then open the file: "org.chameleon.Boot.plist" using TextWrangler (don't use textedit app).

Step 7: Copy that code to the chameleon boot plist like the example below:

<key>device-properties</key>
<string>4b00000001000000010000003f0000000100000002010c00d041030a0000000001010600061c0101060000007fff0400160000006200750069006c0074002d0069006e0000000500000001</string>

Then save it.

Step 8: Click on the Apple Icon at the way top left. Then go to System Preference. Then Click on "network". Then Click on the minus sign at the bottom left to delete ALL the Network connections. Then click Apply.


Step 9: Go to : Mac Hard Drive/Library/Preferences/SystemConfiguration folder. Then delete the : networkinterfaces.plist file and emtpy the trash.

Step 10: Restart computer.

Step 11: Now Re-add network interaces with ethernet first. You should have internet connection and then you should be able to login to app store and download apps.

Done. Have fun.

Note: This is the only way it work for me. Any other way fail on my computer. So if it doesn't work for you that mean there really is no hope for you to ever login to app store. Except maybe you need to "get a new mountain lion.app" and "re-install it".

Side note: I will probably won't be replying to this thread because there is no reason for it not to work because this is as i say the last ultimate resort. If this don't work, nothing else will work. This thread would basicly serve as a guidance for "me" mostly and for other people too that have app store failure. Also if I ever reformat my mac and become clueless on how to login app store. This thread will alway be here using search feature.

=========================
SUMMARY informations for lazy people

"my" : org.chameleon.Boot.plist
~~~~~~~~~~~~~~~~~~~~

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Credits</key>
<string>Created with Champlist</string>

<key>EthernetBuiltIn</key>
<string>Yes</string>

<key>Graphics Mode</key>
<string>1024x768x32</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>npci=0x3000 darkwake=0 -v</string>

<key>PciRoot</key>
<string>1</string>

<key>device-properties</key>
<string>4b00000001000000010000003f0000000100000002010c00d041030a0000000001010600061c0101060000007fff0400160000006200750069006c0074002d0069006e0000000500000001</string>

<key>Timeout</key>
<string>2</string>
<key>UseKernelCache</key>
<string>Yes</string>
</dict>
</plist>






"my" : smbios.plist
~~~~~~~~~~~~~~~~~~~~


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Credits</key>
<string>Created with Champlist</string>
<key>SMbiosvendor</key>
<string>Apple Inc.</string>
<key>SMbiosversion</key>
<string>MP31.88Z.006C.B05.0802291410</string>
<key>SMboardproduct</key>
<string>Mac-F42C88C8</string>
<key>SMfamily</key>
<string>Mac Pro</string>
<key>SMproductname</key>
<string>MacPro3,1</string>
<key>SMserial</key>
<string>(champlist generated serials)</string>
</dict>
</plist>


===============================================
If you did all the steps right. You file should have similar contents like mine.
===============================================


My Hackintosh Spec:

Motherboard: Biostar TP55
CPU: Intel® Core™ i5 LGA 1156
Memory: 12 GB
SSD: Kingston HyperX 3K 240 GB
Graphic: Nvidia Geforce GT 520
Audio: Realtek ALC 662

Dual Boot OS:
MBR Table Partition Scheme.
1st Partition : Mac OSX 10.8.2 Mountain Lion ( app store work, No DSDT)
2nd Partition: HFS+ Mac (blank reserve for dual boot mac OSX 10.9.0 when it come out)
3rd Partition : Windows Ultimate 7 Sp1 (x64)
4th Partition : (Blank reserve to be ready to install Windows Server 2012 or Windows 9 or other OS testing purpose like linux)

3 Must use tools to FIX dual boot MBR:
Windows 7 Installation DVD.
EasyBCD
Erd Disk Commander x64 bit



Custom OSX 10.8 Install Usb:
Kingston 16 GB DataTraveler SE9
Patriot 32 GB Supersonic Xpress


Horrible Never Work Flash drive:
Lexar JumpDrive Twist & Turn 8GB <-- don't ever buy this because chameleon,clover,chimera boot loader just don't work on it.


~~==~~==~~==~~==
Credits

Special thanks to: solbergw
because of his instruction that said to use efi studio to generate hex string, I was able to get app store working.
 
Joined
Sep 28, 2012
Messages
3
Motherboard
m1530
CPU
2.0ghz
Graphics
8600m GT
Mac
Classic Mac
Mobile Phone
  1. Android
  2. iOS
When all else failed this WORKED!
Hackintosh:
GA-H61M-DS2 Rev.1.2
Vertex 3 SSD 128gb
ATI 6870 Tripple Monitor
i5 2400k 8GB Ram
 
Joined
Dec 8, 2012
Messages
1
Motherboard
Mackey
CPU
3.06 Core2 Duo
Graphics
ATI Radeon HD 5000
Mac
Classic Mac
Mobile Phone
OP is a GOD! After hours of troubleshooting, this worked!
 
Joined
Aug 20, 2013
Messages
5
Mac
Classic Mac
Mobile Phone
i don`t have org.chameleon.Boot.plist file, i downloaded chameleon wizard, EFI studio, tried to find in extra (folder) to solve this problem, but no success... because almost all tutorials ask for this file, if anyone can help me, please do it, i`ll be very thankful...

Best Regards
 
Joined
May 12, 2012
Messages
2
Motherboard
Hackintosh
CPU
Core i7
Graphics
1gb Saphire
Mac
Classic Mac
Mobile Phone
Thank you! I spent many, many hours trying every imaginable fix. Yours worked for me.

In my case, I used EFI Studio to get the hex string for my /Extra/org.chameleon.Boot.plist

Here's my working configuration:
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>GenerateCStates</key>
<string>Yes</string>
<key>GeneratePStates</key>
<string>Yes</string>
<key>GraphicsEnabler</key>
<string>No</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>darkwake=0 npci=0x3000 PCIRootUID=1 -v</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>Timeout</key>
<string>2</string>
<key>UseKernelCache</key>
<string>Yes</string>
<key>device-properties</key>
<string>4b00000001000000010000003f0000000100000002010c00d041030a0000000001010600001e0101060000017fff0400160000006200750069006c0074002d0069006e0000000500000001</string>
</dict>
</plist>

My build:
Hackintosh:
Mountain Lion 10.8.4
Asus Sabertooth X58 Motherboard
Core i7 Intell Processor (3.2 GHZ)
12 Gigs Ram (Mushkin)
1 Gig ATI Radeon Videocard (Saphire)

I also own a macbook pro... I knew something was wrong when my macbook pro could connect to the app store just fine, but my hackintosh kept getting an "unknown error" with the app store (the Itunes store was working fine for me).
 
Joined
May 12, 2012
Messages
2
Motherboard
Hackintosh
CPU
Core i7
Graphics
1gb Saphire
Mac
Classic Mac
Mobile Phone
Maybe I should give more details on what worked for me:

In my case, adding this entry (see my full Boot.plist above):
<key>device-properties</key>
<string>4b00000001000000010000003f0000000100000002 010c00d041030a0000000001010600001e0101060000017fff 0400160000006200750069006c0074002d0069006e00000005 00000001</string>

(I put the ethernet card generated hex-string from EFI Studio in there), then removed my network devices (in my case just my ethernet) in System Preferences > Network

I then rebooted & I was able to log into the app store.
 
Joined
Dec 25, 2013
Messages
77
Mac
Classic Mac
Mobile Phone
ChampList says I don't have CHameleon installed and when I let it install it, it says it could not be installed... first hackintosh, someone help :(
 
Joined
Sep 19, 2013
Messages
3
Mac
Classic Mac
Mobile Phone
Wicked guide. Thank you very much for posting it. Just to share as well... my hackintosh is a XW8600, pretty much the default. I just changed the video card to one that was on the compatibility list and added a second processor.

I used Tony Mac's guide to get Mountain Lion working and I used multi-beast once I got everything installed and I set my Mac to a Mac Pro 3.1 with multibeast. All I had to do was start at Step #8 to get my ethernet working.

To start my ethernet I used this broadcom kext. http://cl.ly/8WBg

And then I used Kext Wizard to install it. I used other kext installers and later I found out that I couldn't get my ethernet to work because they weren't installing the kext properly. So USE KEXT WIZARD lol Here's my little guide:

1. Download Moutain Lion
2. Download Unibeast
3. Create boot USB by formatting USB to 1 partition, master boot record, mac Journaled
4. Boot computer from USB
5. On Chimera window, -v (Verbose Mode)
6. Open Disk Utility, partition OS drive to GUID and Mac Journaled
7. Install Mountain Lion
8. Fill out setup (DO NOT RESTART YET)
9. Run Multi Beast (Easy DSDT + Mac Pro 3.1)
10. Repair Disk Permissions (Kext Wizard)
11. Restart


Ethernet
1. Install Broadcom BCM5722D kext with Kext Wizard
2. Repair Permissions and Cache
3. Restart
4. Delete all networks under system preferences
5. Library/Preferences/System Configuration and delete NetworkInterfaces.plist - Empty Trash
6. Restart
7. Re-add Ethernet to Network
8. Repair Permissions and Cache






******* NEVER USE KEXT UTILITY OR ANYTHING *******


******* ONLY USE KEXT WIZARD *******
 
Joined
Jul 12, 2012
Messages
1
Motherboard
PC
CPU
Intel Core 2 Duo
Graphics
Nvidia Geforce 8600 GT
Mac
Classic Mac
Mobile Phone
Thanks a lot!!! Works also for me!
 
Top