Only Stereo output from Apple Music/TV

Oct 19, 2015
ASUS Sage WS II x299
AMD Radeon 6900XT
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Mobile Phone
  1. iOS
Hey guys, wondering if anyone can help me here? I have upgraded from Big Sur to Ventura and now I lost the ability to play Dolby Atmos and/or 5.1 from Apple apps through my audio interface. Only Left and Right Channels seem to receive streams from Apple Music, Quicktime, and Apple TV.

I have a Scarlett 18i20 with a 5.1 JBL Studio speaker setup.

What works:
- PC games that use surround, with the 18i20 set as the output device (also works with virtual surround devices using Loopback)
- Professional apps, with the 18i20 set as the output device (also works with virtual surround devices using Loopback)

What doesn't work:
- Apple Music Dolby Atmos Playback
- Quicktime 5.1 or Atmos Playback
- Apple TV 5.1 or Atmos Playback

The Setup:
Scarlett 18i20 > Audio MIDI Setup > 5.1/5.1.2 Dolby Atmos
Virtual Loopback Audio Device > Audio MIDI Setup > 5.1/5.1.2 Dolby Atmos

What I have tried:
- Reinstalled the AppleALC kext, update, etc.
- Uninstall Loopback and ACE
- The same setup on a M1 Mac mini to verify that these apps in Ventura should still see the Scarlett 18i20 as a Dolby Atmos capable system, verified working.

Here's a screen of the virtual device that just illustrates the issue during playback of an Apple Music Dolby Atmos song:

Screenshot 2023-09-19 at 11.33.46 AM.png
And this might be helpful here, if I DISABLE AC3 passthrough in the Apple TV player, surround/atmos works. Time to do some digging on AC3
Okay I finally solved this and wanted to followup for future folks with the same problem.

If you are using Loopback on Monterey and Above, you MUST create a virtual audio device with 16 channels, even if your setup is actually 6 channels (5.1) or similar.

Secondly I had to set Apple Music to Automatic for Dolby Atmos Playback, "Always" was intermittently successful.

Lastly, before trying Apple Music again, with it closed, delete /Users/resolve/Library/Caches/