Contribute
Register

Official CustoMac Mini 2012 Guide and Notes (in progress)

Joined
Jan 7, 2013
Messages
120
Motherboard
MAC
CPU
i7-3770K @ 3.6 Ghz
Graphics
HD4000
Mac
MacBook, Mac mini
Classic Mac
Apple
Mobile Phone
Android
This may be a known issue, but on every one I've built so far, at boot up, it takes almost a minute for the OS to see the Magic Trackpad and Apple BT Keyboard. It just sits there then eventually says connected.
 
Joined
Nov 7, 2010
Messages
197
Motherboard
GA-Z97MX-Gaming 5, GA-B85N Phoenix
CPU
I7-4790k, i7-4770s
Graphics
Nvidia GTX 660, Nvidia GTX 640
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac mini
Mobile Phone
iOS, Other
I installed a i3-3225 on a GA-H77N-WIFI board, followed the guide to the letter. Video memory is set to 64MB but when I boot into the desktop the graphics are messed up completely, I can't see anything. Tried increasing the video memory but the screen got only worse.

I am using a VGA monitor though, plugged into the DVI output (using a DVI to VGA converter), could this be the culprit? The converter and the monitor are both working fine, they work with other hardware.
For Garbled Text with HD4000

Try adding this string to your org.chameleon.Boot.plist (in "Extra" folder)
Code:
<key>Graphics Mode</key>
<string>"1920x1080x32"</string>

It worked for me with the same board and processor.
 
Joined
Nov 7, 2010
Messages
197
Motherboard
GA-Z97MX-Gaming 5, GA-B85N Phoenix
CPU
I7-4790k, i7-4770s
Graphics
Nvidia GTX 660, Nvidia GTX 640
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac mini
Mobile Phone
iOS, Other
This may be a known issue, but on every one I've built so far, at boot up, it takes almost a minute for the OS to see the Magic Trackpad and Apple BT Keyboard. It just sits there then eventually says connected.
My mini setup recognizes the BT Keyboard Mouse, Trackpad and Keyboard immediately. However I made my own genuine Apple BT setup from a Macbook Pro BT card and used the antenna from the GA-H77N WiFi logic board.
 
Joined
Jan 7, 2013
Messages
120
Motherboard
MAC
CPU
i7-3770K @ 3.6 Ghz
Graphics
HD4000
Mac
MacBook, Mac mini
Classic Mac
Apple
Mobile Phone
Android
My mini setup recognizes the BT Keyboard Mouse, Trackpad and Keyboard immediately. However I made my own genuine Apple BT setup from a Macbook Pro BT card and used the antenna from the GA-H77N WiFi logic board.
Yeah I am just using the built in BT from the Z77 Wifi, or actually, it's not my system, it's my neighbors.
 
Joined
Jan 7, 2013
Messages
120
Motherboard
MAC
CPU
i7-3770K @ 3.6 Ghz
Graphics
HD4000
Mac
MacBook, Mac mini
Classic Mac
Apple
Mobile Phone
Android
Something else I noticed, I have my users folder on an NTFS Drive, and the hard drive is kind of noisy, I'm going to change it I think, but either way, at some times there is a LOT of hard drive activity on that drive. Yesterday it was hitting that drive constantly for over 30 minutes. It didn't seem normal.
 
Joined
May 22, 2012
Messages
2
Motherboard
Mac
CPU
17-3770k
Graphics
GTX650
Mac
Classic Mac
Mobile Phone
Hi Everyone. Im trying one of these builds (the first of my own), and am having an issue.I have formatted the unibeast drive and when i select it in the boot menu the screen goes black after about 4 seconds i get a quick flash of the grey apple screen and then the system reboots. Is this a hardware issue? or something wrong with my unibeast or bios settings? I have re read the unibeast and bios tutorials and don't think those are wrong.

Thanks in advance!


Hardware specs:

GA-Z77n-Wifi
i7-3770k
gtx-650 (not installed)
 

Attachments

Joined
Jan 7, 2013
Messages
120
Motherboard
MAC
CPU
i7-3770K @ 3.6 Ghz
Graphics
HD4000
Mac
MacBook, Mac mini
Classic Mac
Apple
Mobile Phone
Android
Hi Everyone. Im trying one of these builds (the first of my own), and am having an issue.I have formatted the unibeast drive and when i select it in the boot menu the screen goes black after about 4 seconds i get a quick flash of the grey apple screen and then the system reboots. Is this a hardware issue? or something wrong with my unibeast or bios settings? I have re read the unibeast and bios tutorials and don't think those are wrong.

Thanks in advance!


Hardware specs:

GA-Z77n-Wifi
i7-3770k
gtx-650 (not installed)

Follow my setup guide. Make SURE you set the bios settings AND boot -x -v to the installer.
 
Joined
Dec 11, 2012
Messages
4
Motherboard
OSX 10.10
CPU
i7-3550K
Graphics
Onboard
Mac
Classic Mac
Mobile Phone
I did this first build as a total newbie to the Hackintosh world. I just want to give a shout out to all of you who make the install and configuration of OSX possible. Since the machine has been up it has been rock solid and hasn't given me a single problem. You all rock!


I completed my first build yesterday and it is working great! I used the following components:

Gigabyte GA-Z77N-WIFI
Intel i7-3770K
Corsair Hydro H55 cooler
Corsair Vengeance 16GB DDR3 1600 MHz
BitFenix Prodigy Arctic White
SanDisk Extreme SSD 240GB
Seagate Barracuda 500GB 7200rpm
Corsair TX650 power supply
TP-Link Wireless N PCI-Express
Apple Magic Trackpad
Apple Wireless Keyboard

I have a nearly identical setup to alexvery and found his post very helpful: http://www.tonymacx86.com/user-buil...0go-dd-16go-ram-geforce-640-a.html#post508349

It took a half day of fooling around with the install to get everything working properly. If I had read the description of MultiBeast more carefully I would have wasted less time---I didn't understand that it made the internal drive bootable--- but it was fun nevertheless.


I know many people have reported difficultly with bluetooth using this board. Mine is working well. It was very laggy initially, especially with the Magic Trackpad, but installing the supplied antennae helped a lot. Don't know if they are actually connected to the bluetooth part of the motherboard or are just helping with interference.


The cooler is a tight fit in the case. It interferes with the USB 3.0 connection to the front of the case, so I will either have to remount the cooler to the front or try to find some kind of low profile connector.

Geekbench score is 13988 (using the 64-bit setting).
 
Joined
Mar 6, 2013
Messages
13
Motherboard
Corsair Carbide 500R, Gigabyte GA-Z77X-UP5-TH, Corsair Vengeance 16GB, Samsung 840 256GB,
CPU
i7 3770
Graphics
EVGA GeForce GT 640
Mac
Classic Mac
Mobile Phone
Can anyone tell me if I can pull a working Mountain Lion drive from my MacBook Pro and put it in my CustoMac Pro build without needing to do anything else? Or will I need to start over completely using the UniBeast process?
 
Joined
Nov 28, 2012
Messages
2
Motherboard
Lion
CPU
Intel Dualcore E2140
Graphics
GMA 950
Mac
Classic Mac
Mobile Phone
Can anyone tell me if I can pull a working Mountain Lion drive from my MacBook Pro and put it in my CustoMac Pro build without needing to do anything else? Or will I need to start over completely using the UniBeast process?
Basically, your drive from MacBook Pro can run in your CustoMac Pro, but you should re customize all kexts.
 
Top