NVIDIA Releases Alternate Graphics Drivers for macOS High Sierra 10.13.3 (387.10.10.10.25)

Discussion in 'Graphics' started by tonymacx86, Jan 24, 2018.

  1. tonymacx86

    tonymacx86 Administrator Staff Member

    Joined:
    Nov 18, 2009
    Messages:
    8,456
    Motherboard:
    GA-Z270X-UD5
    CPU:
    Core i3-7100
    Graphics:
    HD 630
    Mac:
    MacBook Pro, Mac mini
    Classic Mac:
    Apple, PowerBook
    Mobile Phone:
    iOS
    Jan 24, 2018 at 2:10 PM #1
    tonymacx86

    tonymacx86 Administrator Staff Member

    Joined:
    Nov 18, 2009
    Messages:
    8,456
    Motherboard:
    GA-Z270X-UD5
    CPU:
    Core i3-7100
    Graphics:
    HD 630
    Mac:
    MacBook Pro, Mac mini
    Classic Mac:
    Apple, PowerBook
    Mobile Phone:
    iOS
    [​IMG]

    NVIDIA has released alternate graphics drivers for macOS High Sierra 10.13.3. These are separate from the drivers Apple ships as standard, and should be considered experimental. These drivers have been known to solve OpenCL issues with certain applications, as well as providing better native GPU power management for certain devices.

    NOTE: These drivers are currently the only method to get full acceleration for GeForce GTX 1050, 1050 Ti, 1060, 1070, 1070 Ti, 1080, 1080 Ti, TITAN Pascal, and TITAN Xp 'Pascal' graphics cards and NVIDIA GeForce GTX 750, 750 Ti, 950, 960, 970, 980, 980 Ti, and TITAN X 'Maxwell' graphics cards. There are no current Macs with these cards, so support is absent natively in macOS.

    If you've installed the drivers before, you may get a notification to update to the new drivers from the built in System Preferences pane.
    [​IMG]
    NVIDIA Alternate Graphics Drivers for macOS 10.13.3 + Supplemental Update (17D102)
    https://images.nvidia.com/mac/pkg/387/WebDriver-387.10.10.10.25.161.pkg

    NVIDIA Alternate Graphics Drivers for macOS 10.13.3 + Supplemental Update for iMac Pro (17D2102)
    https://images.nvidia.com/mac/pkg/387/WebDriver-387.10.10.10.25.160.pkg

    NVIDIA Alternate Graphics Drivers for macOS 10.13.3 + Supplemental Update for iMac Pro (17D2102)
    https://images.nvidia.com/mac/pkg/387/WebDriver-387.10.10.10.25.159.pkg

    NVIDIA Alternate Graphics Drivers for macOS 10.13.3 + Supplemental Update (17D102)

    https://images.nvidia.com/mac/pkg/387/WebDriver-387.10.10.10.25.158.pkg

    NVIDIA Alternate Graphics Drivers for macOS 10.13.3 for iMac Pro
    (17D2047)

    https://images.nvidia.com/mac/pkg/387/WebDriver-387.10.10.10.25.157.pkg

    NVIDIA Alternate Graphics Drivers for macOS 10.13.3
    (17D47)

    http://www.nvidia.com/download/driverResults.aspx/130460/en-us

    How to Install the Web Drivers:
    In order to use the alternate drivers on a CustoMac, you must first install the driver package.
    [​IMG]
    As of macOS Sierra, nvda_drv=1 in config.plist under Boot > Arguments is no longer working to initiate drivers. Clover has been updated with a new System Parameter setting called NvidiaWeb.

    There's a new method for enabling the NVIDIA Web Drivers in the latest versions of Clover. It can be turned on and off by editing /Volumes/EFI/EFI/CLOVER/config.plist to add SystemParameters/NvidiaWeb. This takes the place of nvda_drv=1 boot flag, which will not work in macOS Sierra+.

    1. Mount EFI Partition
    2. Open /Volumes/EFI/EFI/CLOVER/config.plist with text edit, Xcode, or Plist Editor Pro
    3. Edit as shown below:

    Code:
    <key>SystemParameters</key>
        <dict>
            <key>InjectKexts</key>
            <string>YES</string>
            <key>InjectSystemID</key>
            <true/>
            <key>NvidiaWeb</key>
            <true/>
        </dict>
    4. Remove Boot/Arguments/nvda_drv=1 if necessary
    5. Save and reboot

    For full information:
    http://www.tonymacx86.com/threads/new-method-for-enabling-nvidia-web-drivers-in-clover.202341/

    Emulated NVRAM:
    Emulated NVRAM is required for support of NVIDIA Web Drivers on many desktop systems. Use MultiBeast to install Bootloaders > Clover UEFI Boot Mode + Emulated NVRAM. This allows for menu bar switch between NVIDIA Web Drivers and OS X Default Graphics Drivers.

    [​IMG]

    Common Problems and Solutions:
    https://www.tonymacx86.com/graphics/161256-solving-nvidia-driver-install-problems.html

    NVIDIA Drivers - Latest:
    https://www.tonymacx86.com/nvidia-drivers/

    Related:
    https://www.tonymacx86.com/threads/...s-high-sierra-10-13-2-378-10-10-10-25.239852/
    https://www.tonymacx86.com/threads/...s-high-sierra-10-13-1-378-10-10-10-20.236101/
    https://www.tonymacx86.com/threads/...s-high-sierra-10-13-0-378-10-10-10-15.225522/
    https://www.tonymacx86.com/threads/...for-macos-sierra-10-12-6-378-05-05-25.227494/
    https://www.tonymacx86.com/threads/...for-macos-sierra-10-12-5-378-05-05-15.222102/
    https://www.tonymacx86.com/threads/...for-macos-sierra-10-12-4-378-05-05-05.218005/
    https://www.tonymacx86.com/threads/...for-macos-sierra-10-12-3-367-15-10-35.213122/
    https://www.tonymacx86.com/threads/...for-macos-sierra-10-12-2-367-15-10-25.209714/
    https://www.tonymacx86.com/threads/...for-macos-sierra-10-12-1-367-15-10-15.205568/
    https://www.tonymacx86.com/threads/...for-macos-sierra-10-12-0-367-15-10-05.200843/
    http://www.tonymacx86.com/threads/n...s-drivers-for-macos-sierra-10-12-beta.195315/
     
    z0lt4n likes this.
    Last edited: Feb 21, 2018
  2. frontgear

    frontgear

    Joined:
    Oct 1, 2012
    Messages:
    109
    Motherboard:
    Gigabyte Z270XP-SLI (F9d)
    CPU:
    i7-7700K
    Graphics:
    RX 580
    Mac:
    MacBook Air, MacBook Pro
    Mobile Phone:
    iOS
    Jan 24, 2018 at 4:29 PM #2
    frontgear

    frontgear

    Joined:
    Oct 1, 2012
    Messages:
    109
    Motherboard:
    Gigabyte Z270XP-SLI (F9d)
    CPU:
    i7-7700K
    Graphics:
    RX 580
    Mac:
    MacBook Air, MacBook Pro
    Mobile Phone:
    iOS
    max.1974 and tonymacx86 like this.
  3. tonymacx86

    tonymacx86 Administrator Staff Member

    Joined:
    Nov 18, 2009
    Messages:
    8,456
    Motherboard:
    GA-Z270X-UD5
    CPU:
    Core i3-7100
    Graphics:
    HD 630
    Mac:
    MacBook Pro, Mac mini
    Classic Mac:
    Apple, PowerBook
    Mobile Phone:
    iOS
    Jan 24, 2018 at 4:29 PM #3
    tonymacx86

    tonymacx86 Administrator Staff Member

    Joined:
    Nov 18, 2009
    Messages:
    8,456
    Motherboard:
    GA-Z270X-UD5
    CPU:
    Core i3-7100
    Graphics:
    HD 630
    Mac:
    MacBook Pro, Mac mini
    Classic Mac:
    Apple, PowerBook
    Mobile Phone:
    iOS
  4. newmotu

    newmotu

    Joined:
    Dec 3, 2013
    Messages:
    5
    Motherboard:
    Z97 Extreme4, Z370 Extreme4
    CPU:
    Xeon E3-1231V3, i7-8700
    Graphics:
    GTX 960, GTX1060
    Mac:
    Mac Pro
    Classic Mac:
    Power Mac
    Mobile Phone:
    iOS
    Jan 24, 2018 at 4:43 PM #4
    newmotu

    newmotu

    Joined:
    Dec 3, 2013
    Messages:
    5
    Motherboard:
    Z97 Extreme4, Z370 Extreme4
    CPU:
    Xeon E3-1231V3, i7-8700
    Graphics:
    GTX 960, GTX1060
    Mac:
    Mac Pro
    Classic Mac:
    Power Mac
    Mobile Phone:
    iOS
    update went well, but I've got more sluggish screen drawing than previous version of MacOS and nvidia driver.
     
    Utamaru likes this.
  5. ccerny33944

    ccerny33944

    Joined:
    Feb 27, 2016
    Messages:
    13
    Motherboard:
    Gigabyte Z170N WiFi
    CPU:
    i7 6700k
    Graphics:
    EVGA GTX 1060 6GB
    Mac:
    iMac, MacBook Pro
    Mobile Phone:
    iOS
    Jan 24, 2018 at 4:55 PM #5
    ccerny33944

    ccerny33944

    Joined:
    Feb 27, 2016
    Messages:
    13
    Motherboard:
    Gigabyte Z170N WiFi
    CPU:
    i7 6700k
    Graphics:
    EVGA GTX 1060 6GB
    Mac:
    iMac, MacBook Pro
    Mobile Phone:
    iOS
    Anyone else getting slow animations or slow/lagging video playback?
     
    balazs631 and Utamaru like this.
  6. david279

    david279

    Joined:
    Jul 30, 2015
    Messages:
    11
    Motherboard:
    Gigabyte Z170XP-SLI
    CPU:
    i7-7700k
    Graphics:
    EVGA GT 1030
    Mobile Phone:
    Android
    Jan 24, 2018 at 5:13 PM #6
    david279

    david279

    Joined:
    Jul 30, 2015
    Messages:
    11
    Motherboard:
    Gigabyte Z170XP-SLI
    CPU:
    i7-7700k
    Graphics:
    EVGA GT 1030
    Mobile Phone:
    Android
    Yep in the plex media app it sounds kinda glitchy. Plex web app in chrome has no problems. I have a GT 1030.
     
  7. aliengfx

    aliengfx

    Joined:
    Mar 9, 2017
    Messages:
    44
    Motherboard:
    GA H270N-WiFi
    CPU:
    i7 7700
    Graphics:
    GTX 1060
    Mobile Phone:
    Android
    Jan 24, 2018 at 5:18 PM #7
    aliengfx

    aliengfx

    Joined:
    Mar 9, 2017
    Messages:
    44
    Motherboard:
    GA H270N-WiFi
    CPU:
    i7 7700
    Graphics:
    GTX 1060
    Mobile Phone:
    Android
    Yes, I do. So much inside of the browser, maybe nVidia will release a new driver.
     
    ccerny33944 likes this.
  8. pastrychef

    pastrychef Moderator

    Joined:
    May 29, 2013
    Messages:
    5,704
    Motherboard:
    Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
    CPU:
    i7-8700K @ 5.0GHz
    Graphics:
    MSI Radeon RX Vega 56 Air Boost
    Mac:
    Mac Pro
    Classic Mac:
    Power Mac
    Mobile Phone:
    iOS
    Jan 24, 2018 at 5:19 PM #8
    pastrychef

    pastrychef Moderator

    Joined:
    May 29, 2013
    Messages:
    5,704
    Motherboard:
    Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
    CPU:
    i7-8700K @ 5.0GHz
    Graphics:
    MSI Radeon RX Vega 56 Air Boost
    Mac:
    Mac Pro
    Classic Mac:
    Power Mac
    Mobile Phone:
    iOS
    Yes, everything is laggy.
     
    ccerny33944 likes this.
  9. bogdanw

    bogdanw

    Joined:
    Mar 29, 2011
    Messages:
    230
    Motherboard:
    GA-Z170X-UD3 (F23g)
    CPU:
    Intel Core i5-7400
    Graphics:
    Asus Radeon RX 560 4GB
    Jan 24, 2018 at 5:42 PM #9
    bogdanw

    bogdanw

    Joined:
    Mar 29, 2011
    Messages:
    230
    Motherboard:
    GA-Z170X-UD3 (F23g)
    CPU:
    Intel Core i5-7400
    Graphics:
    Asus Radeon RX 560 4GB
    DO NOT USE THIS DRIVER! It causes terrible lags.
     
    SV2017, ccerny33944 and pastrychef like this.
  10. pastrychef

    pastrychef Moderator

    Joined:
    May 29, 2013
    Messages:
    5,704
    Motherboard:
    Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
    CPU:
    i7-8700K @ 5.0GHz
    Graphics:
    MSI Radeon RX Vega 56 Air Boost
    Mac:
    Mac Pro
    Classic Mac:
    Power Mac
    Mobile Phone:
    iOS
    Jan 24, 2018 at 5:45 PM #10
    pastrychef

    pastrychef Moderator

    Joined:
    May 29, 2013
    Messages:
    5,704
    Motherboard:
    Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
    CPU:
    i7-8700K @ 5.0GHz
    Graphics:
    MSI Radeon RX Vega 56 Air Boost
    Mac:
    Mac Pro
    Classic Mac:
    Power Mac
    Mobile Phone:
    iOS
    There's definitely something wrong with this driver release. I thought maybe something was wrong with my system, so I tested on a clean install and still lots of lag everywhere.
     
    ccerny33944 likes this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice