Contribute
Register

NVIDIA Releases Alternate Graphics Drivers for macOS High Sierra 10.13.3 (387.10.10.10.25)

Joined
Feb 27, 2016
Messages
13
Motherboard
Gigabyte Z170N WiFi
CPU
i7-6700K
Graphics
GTX 1060
Mac
iMac, MacBook Pro
Mobile Phone
iOS
I used a tool called „Nvidia Webtreiber all Version update“ – don’t know if it’s available in English.

Open the app, choose „Webdriver neu installieren“ („Reinstall web driver“), choose the old webdriver *.pkg file – the app installs the old driver.

Restart the app, choose „Vorhandenen Webdriver Patchen“ („patch existing web driver“) – click through, choose „Rechte bereinigen“ („correct permissions“) enter admin password and restart the Mac.
Use Fuximus' Method to revert back to x.106 drivers. 10.13.2 Drivers work just fine in 10.13.3. FIXES LAG AND STUTTERING

Edit: I have included the app download for those having difficulty registering. Everything's in German, but just follow the steps outlined above.
 

Attachments

Last edited:

jch

Joined
Mar 28, 2013
Messages
6
Motherboard
Gigabyte GA-Z170N-WIFI
CPU
i5-6600
Graphics
EVGA GTX1080 SC
Lagging with my GTX1080. It might need an update on CUDA driver.
 
Joined
Dec 28, 2015
Messages
24
Motherboard
Asus Z170 Maximus VIII HERO
CPU
i7-6700K
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
Updated to new drivers have GTX750. Laggy as hell.
 
Joined
May 4, 2014
Messages
29
Motherboard
AsRock Fatality Z97X Killer
CPU
i7 - 4790K
Graphics
GTX1070
Classic Mac
iMac
Mobile Phone
Android
Use Fuximus' Method to revert back to x.106 drivers. 10.13.2 Drivers work just fine in 10.13.3. FIXES LAG AND STUTTERING
Yes did the same here , working fine now , even cuda works. Nvidia have broken their drivers it is not a MacOS issue or old drivers would do the same and lag.
 
Last edited:
Joined
Jun 6, 2013
Messages
84
Motherboard
MSI Z97 Gaming 5
CPU
i7-4790K
Graphics
GTX 1070
Mobile Phone
iOS
CUDA needs an update.
The current CUDA driver seems to lack the definitions for the current GPU driver.
As a result After Effects, for example, can't activate CUDA rendering at this state (at least for me).
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
15,092
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
I couldn't take it anymore. The lag was so bad that I was getting a headache looking at the screen. I reverted back to the previous version of the web drivers and all is well again.

Btw, Cuda has nothing to do with display. This is not a Cuda issue. It's a web driver issue.
 
Joined
Sep 23, 2010
Messages
158
Motherboard
X58A-UD5 Rev 2.0 Fe5
CPU
I7-950
Graphics
GTX 970
Classic Mac
Apple
Mobile Phone
iOS
I wonder if nVidia pulled their server offline due to the issues, I just upgraded and got an error that no server could be found when checking for graphics updates in the nVidia app.
 
Joined
Jun 29, 2015
Messages
10
Motherboard
MSI Z370 Carbon Gaming Pro
CPU
Intel i7-8700k
Graphics
ASUS GTX 1080 Ti OC
Mac
iMac
Mobile Phone
iOS
dont update to this garbage driver!! causing crazy lags. i had to roll back to 378.10.10.10.25.104
 
Joined
Jul 1, 2015
Messages
72
Motherboard
ASUS B150M-K D3
CPU
Intel Core i5 6500
Graphics
Gigabyte Geforce GTX 960
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac mini, Mac Pro
Classic Mac
Color Classic, eMac, iBook, iMac, Power Mac, Xserve
Mobile Phone
Android, iOS
There's definitely something wrong with this driver release. I thought maybe something was wrong with my system, so I tested on a clean install and still lots of lag everywhere.
Having the same issue too!
 
Top