NVIDIA Releases Alternate Graphics Drivers for macOS High Sierra 10.13.3 (387.10.10.10.25)

Discussion in 'Graphics' started by tonymacx86, Jan 24, 2018.

  1. ccerny33944

    ccerny33944

    Joined:
    Feb 27, 2016
    Messages:
    13
    Motherboard:
    Gigabyte Z170N WiFi
    CPU:
    i7 6700k
    Graphics:
    EVGA GTX 1060 6GB
    Mac:
    iMac, MacBook Pro
    Mobile Phone:
    iOS
    Jan 24, 2018 at 8:01 PM #21
    ccerny33944

    ccerny33944

    Joined:
    Feb 27, 2016
    Messages:
    13
    Motherboard:
    Gigabyte Z170N WiFi
    CPU:
    i7 6700k
    Graphics:
    EVGA GTX 1060 6GB
    Mac:
    iMac, MacBook Pro
    Mobile Phone:
    iOS
    Use Fuximus' Method to revert back to x.106 drivers. 10.13.2 Drivers work just fine in 10.13.3. FIXES LAG AND STUTTERING

    Edit: I have included the app download for those having difficulty registering. Everything's in German, but just follow the steps outlined above.
     

    Attached Files:

    Last edited: Jan 25, 2018
  2. Frumushelu

    Frumushelu

    Joined:
    Oct 17, 2013
    Messages:
    1
    Motherboard:
    Gigabyte GA-B75-D3V Rev. 1.1
    CPU:
    I5 3570
    Graphics:
    Gigabyte GTX 1050 Ti G1 Gaming
    Mac:
    iMac
    Mobile Phone:
    Android
    Jan 24, 2018 at 8:15 PM #22
    Frumushelu

    Frumushelu

    Joined:
    Oct 17, 2013
    Messages:
    1
    Motherboard:
    Gigabyte GA-B75-D3V Rev. 1.1
    CPU:
    I5 3570
    Graphics:
    Gigabyte GTX 1050 Ti G1 Gaming
    Mac:
    iMac
    Mobile Phone:
    Android
    I updated the nvidia web drivers - no problems so far
     
  3. jch

    jch

    Joined:
    Mar 28, 2013
    Messages:
    6
    Motherboard:
    Gigabyte GA-Z170N-WIFI
    CPU:
    i5-6600
    Graphics:
    EVGA GTX1080 SC
    Jan 24, 2018 at 8:59 PM #23
    jch

    jch

    Joined:
    Mar 28, 2013
    Messages:
    6
    Motherboard:
    Gigabyte GA-Z170N-WIFI
    CPU:
    i5-6600
    Graphics:
    EVGA GTX1080 SC
    Lagging with my GTX1080. It might need an update on CUDA driver.
     
  4. Utamaru

    Utamaru

    Joined:
    Dec 28, 2015
    Messages:
    20
    Motherboard:
    Asus Z170 Maximus VIII HERO
    CPU:
    Intel Skylake i7 6700K
    Graphics:
    Geforce GTX 750
    Mac:
    MacBook Pro
    Mobile Phone:
    Android, iOS
    Jan 24, 2018 at 9:38 PM #24
    Utamaru

    Utamaru

    Joined:
    Dec 28, 2015
    Messages:
    20
    Motherboard:
    Asus Z170 Maximus VIII HERO
    CPU:
    Intel Skylake i7 6700K
    Graphics:
    Geforce GTX 750
    Mac:
    MacBook Pro
    Mobile Phone:
    Android, iOS
    Updated to new drivers have GTX750. Laggy as hell.
     
  5. xpzone

    xpzone

    Joined:
    May 4, 2014
    Messages:
    23
    Motherboard:
    AsRock Fatality Z97X Killer
    CPU:
    i7 - 4790K @ 4 GHz
    Graphics:
    Nvidia GTX1070 SLI
    Classic Mac:
    iMac
    Mobile Phone:
    Android
    Jan 24, 2018 at 9:47 PM #25
    xpzone

    xpzone

    Joined:
    May 4, 2014
    Messages:
    23
    Motherboard:
    AsRock Fatality Z97X Killer
    CPU:
    i7 - 4790K @ 4 GHz
    Graphics:
    Nvidia GTX1070 SLI
    Classic Mac:
    iMac
    Mobile Phone:
    Android
    Yes did the same here , working fine now , even cuda works. Nvidia have broken their drivers it is not a MacOS issue or old drivers would do the same and lag.
     
    Last edited: Jan 24, 2018
  6. Jippa_Lippa

    Jippa_Lippa

    Joined:
    Jun 6, 2013
    Messages:
    67
    Motherboard:
    MSI Z97 Gaming 5
    CPU:
    i7-4790K 4.0 GHz
    Graphics:
    GTX 980 4GB
    Jan 24, 2018 at 10:09 PM #26
    Jippa_Lippa

    Jippa_Lippa

    Joined:
    Jun 6, 2013
    Messages:
    67
    Motherboard:
    MSI Z97 Gaming 5
    CPU:
    i7-4790K 4.0 GHz
    Graphics:
    GTX 980 4GB
    CUDA needs an update.
    The current CUDA driver seems to lack the definitions for the current GPU driver.
    As a result After Effects, for example, can't activate CUDA rendering at this state (at least for me).
     
  7. pastrychef

    pastrychef Moderator

    Joined:
    May 29, 2013
    Messages:
    4,685
    Motherboard:
    Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
    CPU:
    i7-8700K @ 5.0GHz
    Graphics:
    MSI Radeon RX Vega 56 Air Boost
    Mac:
    Mac Pro
    Classic Mac:
    Power Mac
    Mobile Phone:
    iOS
    Jan 24, 2018 at 10:25 PM #27
    pastrychef

    pastrychef Moderator

    Joined:
    May 29, 2013
    Messages:
    4,685
    Motherboard:
    Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
    CPU:
    i7-8700K @ 5.0GHz
    Graphics:
    MSI Radeon RX Vega 56 Air Boost
    Mac:
    Mac Pro
    Classic Mac:
    Power Mac
    Mobile Phone:
    iOS
    I couldn't take it anymore. The lag was so bad that I was getting a headache looking at the screen. I reverted back to the previous version of the web drivers and all is well again.

    Btw, Cuda has nothing to do with display. This is not a Cuda issue. It's a web driver issue.
     
  8. BartMan01

    BartMan01

    Joined:
    Sep 23, 2010
    Messages:
    134
    Motherboard:
    X58A-UD5 Rev 2.0 Fe5
    CPU:
    I7-950
    Graphics:
    EVGA GeForce GTX 970 SSC GAMING ACX 2.0+
    Classic Mac:
    Apple
    Mobile Phone:
    iOS
    Jan 24, 2018 at 11:19 PM #28
    BartMan01

    BartMan01

    Joined:
    Sep 23, 2010
    Messages:
    134
    Motherboard:
    X58A-UD5 Rev 2.0 Fe5
    CPU:
    I7-950
    Graphics:
    EVGA GeForce GTX 970 SSC GAMING ACX 2.0+
    Classic Mac:
    Apple
    Mobile Phone:
    iOS
    I wonder if nVidia pulled their server offline due to the issues, I just upgraded and got an error that no server could be found when checking for graphics updates in the nVidia app.
     
  9. MrGIS

    MrGIS

    Joined:
    Aug 6, 2016
    Messages:
    6
    Motherboard:
    GA-H170N-WiFi
    CPU:
    i7-6700
    Graphics:
    Nvidia 1050 Ti
    Mac:
    MacBook Pro
    Mobile Phone:
    iOS
    Jan 24, 2018 at 11:28 PM #29
    MrGIS

    MrGIS

    Joined:
    Aug 6, 2016
    Messages:
    6
    Motherboard:
    GA-H170N-WiFi
    CPU:
    i7-6700
    Graphics:
    Nvidia 1050 Ti
    Mac:
    MacBook Pro
    Mobile Phone:
    iOS
    I was forced to do this as well.. A little scary given everything is in german, but it worked. Nvidia, what are you doing?...
     
  10. SeriousM4x

    SeriousM4x

    Joined:
    Jun 29, 2015
    Messages:
    10
    Motherboard:
    MSI Z370 Carbon Gaming Pro
    CPU:
    Intel i7-8700k
    Graphics:
    ASUS GTX 1080 Ti OC
    Mac:
    iMac
    Mobile Phone:
    iOS
    Jan 24, 2018 at 11:29 PM #30
    SeriousM4x

    SeriousM4x

    Joined:
    Jun 29, 2015
    Messages:
    10
    Motherboard:
    MSI Z370 Carbon Gaming Pro
    CPU:
    Intel i7-8700k
    Graphics:
    ASUS GTX 1080 Ti OC
    Mac:
    iMac
    Mobile Phone:
    iOS
    dont update to this garbage driver!! causing crazy lags. i had to roll back to 378.10.10.10.25.104
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice