Contribute
Register

NVIDIA Releases Alternate Graphics Drivers for macOS High Sierra 10.13.3 (387.10.10.10.25)

Joined
Dec 23, 2017
Messages
15
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Joined
Sep 24, 2013
Messages
102
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
GTX 1080 Ti
Mac
iMac, MacBook Pro
Classic Mac
eMac, iMac, Power Mac
Mobile Phone
iOS
Try this URL: http://images.nvidia.com/mac/pkg/387/WebDriver-387.10.10.10.25.156.pkg It'll be a manual download, but worked for me to get that package. Looks line nvidia needs to fix some stuff on their side.
As noted, the system preferences pane and the nvidia driver downloads link on tonymacx86, as well as skandragon's link, do not work. The link in post #1 does download the driver installer. But I would not install this driver. The driver files were withdrawn most likely because the driver is faulty. On my set up, I rebooted into the usual white apple progress bar, but then a small rotating white waiting circle (not a good sign), and then my screen goes black, but disk activity continues, reliving the black-screen-on-boot days previously fixed. Likely bad driver.
 
Joined
Jul 25, 2012
Messages
14
Motherboard
GA-Z97-HD3
CPU
i5-4460
Graphics
750 Ti
Can’t even get to login screen with this. Rolling back with webdriver.sh
 
Joined
Jan 24, 2018
Messages
1
Motherboard
Asus Z 170 Pro Gaming and Acer Nitro 5 Laptop
CPU
i7 7700K and i7 7700 HQ
Graphics
GTX 1060 + Intel HD630, GTX 1050 Ti (Off) / HD630
Indeed, the system after the upgrade does not work stably. The video plays with jerks. I think the reason is lack of a Nvidia CUDA driver.
2018-01-24_21-49-42.jpg
 
Joined
Feb 24, 2013
Messages
1,571
Motherboard
ASUS X299 Prime Deluxe II
CPU
i9-7900X
Graphics
Vega FE
Mac
MacBook Pro
Mobile Phone
iOS
I feel like Apple opened up a pandoras box for nVidia users with this update.

I know they know about the nVidia issues even on real Macs with nVidia GPUs. They might release a smaller patch to fix this, hopefully....or 10.13.4 might fix this issue.

In the meantime I have moved to AMD and keeping 980Ti's outside for now.
 
Joined
Nov 6, 2016
Messages
125
Motherboard
Gigabyte Z170XP-SLI
CPU
i7-6700k
Graphics
GTX 1070
Mac
MacBook Air
Mobile Phone
iOS
Great work as usual, however, I'm bumping into some issues here after updating to 10.13.3. with the latest Nvidia driver.

Issue: update went smooth and I installed the Nvidia driver manually through the provided URL. However, I booted into a black screen after the Apple Logo. the monitor is on, but there is just black screen shown.

What I have tried:
1. remove the Nvidia driver according to the method in this post:
https://www.tonymacx86.com/threads/fix-for-failure-nvidia-web-driver-on-high-sierra-black-screen-panics.234390/

2. updated to the latest clover and removed OsxAptioFix2Drv-64.efi and EmuVariableUefi-64.efi. Then I install the new "OsxAptioFix3Drv-64.efi".

(Credit to Scrambler77 in this post: https://www.tonymacx86.com/threads/macos-10-13-3-update.243852/page-10)

3. Restart

After that, I am still booting into a black screen after the apple logo.

Does anyone know what might be the issue?
 
Joined
Dec 15, 2015
Messages
297
Motherboard
MSI Z270 M7
CPU
i7-7700K
Graphics
GTX 1070
Mobile Phone
iOS
Same thing here, spinning wheel/cannot get the login screen. First time ever I cannot boot a hack with last web drivers.
DO NOT INSTALL THEM OR MAKE A TIME MACHINE BACKUP !
 
Joined
Jul 1, 2015
Messages
75
CPU
Intel Core i5 6500
Graphics
Gigabyte Geforce GTX 960
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac mini, Mac Pro
Classic Mac
Color Classic, eMac, iBook, iMac, Power Mac, Xserve
Mobile Phone
Android, iOS,
Top