Contribute
Register

[Need help] ASUS Vivobook X542UA

Joined
Feb 22, 2019
Messages
34
Motherboard
Asus Vivobook X542UA
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
iOS
You did not set those as info.plist patches, have a look at the linked config again.
Sorry, I sent wrong files.
CoolStar's patches added, as in config at your link, nothing changes. Touchpad still doesn't work.
And OS boot time increased, from 15 sec before to 2-3 min now.
 

Attachments

Joined
Apr 21, 2016
Messages
1,164
Motherboard
ASUS X556UA (Clover)
CPU
i5-6200U
Graphics
Intel HD 520, 15.6" 1366x768
Mobile Phone
iOS
Sorry, I sent wrong files.
CoolStar's patches added, as in config at your link, nothing changes. Touchpad still doesn't work.
And OS boot time increased, from 15 sec before to 2-3 min now.
That ELAN1010 name is quite unusual. Does Windows say it's an ELAN1010 too?
 
Joined
Feb 22, 2019
Messages
34
Motherboard
Asus Vivobook X542UA
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
iOS
That ELAN1010 name is quite unusual. Does Windows say it's an ELAN1010 too?
It's from DSDT, as I see:

Code:
            Method (_HID, 0, NotSerialized)  // _HID: Hardware ID
            {
                If (And (TPDI, 0x04))
                {
                    Return (DerefOf (Index (ETPH, TPHI)))
                }

                If (And (TPDI, 0x10))
                {
                    Return (DerefOf (Index (FTPH, TPHI)))
                }

                Return ("ELAN1010")
            }
Windows say it's FTE1200. How can I modify this code to make it correctly?
Replace all inside this method to Return ("FTE1200")? Or there is another error?
 
Joined
Apr 21, 2016
Messages
1,164
Motherboard
ASUS X556UA (Clover)
CPU
i5-6200U
Graphics
Intel HD 520, 15.6" 1366x768
Mobile Phone
iOS
It's from DSDT, as I see:

Code:
            Method (_HID, 0, NotSerialized)  // _HID: Hardware ID
            {
                If (And (TPDI, 0x04))
                {
                    Return (DerefOf (Index (ETPH, TPHI)))
                }

                If (And (TPDI, 0x10))
                {
                    Return (DerefOf (Index (FTPH, TPHI)))
                }

                Return ("ELAN1010")
            }
Windows say it's FTE1200. How can I modify this code to make it correctly?
Replace all inside this method to Return ("FTE1200")? Or there is another error?
Changing the code to return FTE1200 is purely cosmetic, the issue lays somewhere else.

Why did you patch ETPD._STA? That's a mistake, revert it and attach a new archive.
 
Joined
Feb 22, 2019
Messages
34
Motherboard
Asus Vivobook X542UA
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
iOS
Changing the code to return FTE1200 is purely cosmetic, the issue lays somewhere else.

Why did you patch ETPD._STA? That's a mistake, revert it and attach a new archive.
Make Return ("FTE1200"), and undo changes in ETPD._STA.
Touchpad still not working, but system now boots normally, 10-15 sec.
 

Attachments

Joined
Feb 22, 2019
Messages
34
Motherboard
Asus Vivobook X542UA
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
iOS
Power Management (DSDT patched but still getting battery as 0% and laptop turns off after I unplugg the power cord).
USB 2.0 (3.0 works for some strange reason)
Did you do Rehabman's patches to DSDT?
battery_ASUS-N55SL.txt
system_ADP1.txt
 
Joined
Apr 21, 2016
Messages
1,164
Motherboard
ASUS X556UA (Clover)
CPU
i5-6200U
Graphics
Intel HD 520, 15.6" 1366x768
Mobile Phone
iOS
Make Return ("FTE1200"), and undo changes in ETPD._STA.
Touchpad still not working, but system now boots normally, 10-15 sec.
Huh? I didn't tell you to patch _HID. Leave it native, and attach an updated archive.
No need to separately attach your DSDT, it's included in the gen_debug.sh archive.
 
Joined
Feb 22, 2019
Messages
34
Motherboard
Asus Vivobook X542UA
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
iOS
Huh? I didn't tell you to patch _HID. Leave it native, and attach an updated archive.
Ben, it seems in my case GPIO pinning doesn't work. Or something else wrong.
I rolled back all changes from Apr, 26. I thought that I broke something.

Than I make only ASUS Fn key pathches (all 3 volume still doesn't work, brightness and sleep works) and reboot with this DSDT. System boots in 15 sec, touchpad working good in polling mode.

Next I do only GPIO patches - I add:
- "Name (SBFG ..." into Device (ETPD) with 0x0055 in pin list
- _STA & _CRC as follows
Code:
            Method (_STA, 0, NotSerialized)  // _STA: Status
            {
//                If (LOr (LNotEqual (TPIF, One), LAnd (DSYN, One)))
//                {
//                    Return (Zero)
//                }

                Return (0x0F)
            }

            Method (_CRS, 0, Serialized)  // _CRS: Current Resource Settings
            {
                Name (SBFB, ResourceTemplate ()
                {
                    I2cSerialBusV2 (0x0015, ControllerInitiated, 0x00061A80,
                        AddressingMode7Bit, "\\_SB.PCI0.I2C1",
                        0x00, ResourceConsumer, , Exclusive,
                        )
                })
                Return (ConcatenateResTemplate (SBFB, SBFG))
            }
So, system boots ~3 min (look into logs, you can found timeout - 3*60s). Touchpad doesn't work.
And in this state I generated attached debug files.
 

Attachments

Joined
Feb 22, 2019
Messages
34
Motherboard
Asus Vivobook X542UA
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
iOS
Next I added patches:
GPIO Controller Enable (SKL+)
Windows 10 patch

and generated debug.

Result the same - touchpad doesn't working, OS boot time is 3 min.
 

Attachments

Top