Contribute
Register

MSI GS65 UHD630 & RTX2060 16GB NvME 512GB. - ACPI Errors

Joined
Jan 11, 2019
Messages
2
Motherboard
MSI GS75 8SE
CPU
i7-8750H
Graphics
RTX 2060
Mac
MacBook Pro
Classic Mac
Apple
Mobile Phone
iOS
Guys, thank you so much for your work! Working version 10.14 for a fresh MSI laptop is a great find. I also had a question about the backlight of the keyboard. I totally got the clover from annaclets. The backlight worked, but the usb ports did not work in 3.0 mode. I replaced USBInjectAll with USBxhci from my early clover. The situation has changed :) usb work but the backlight is gone.
I would be grateful if you tell me what is my mistake.
 
Joined
Jan 20, 2011
Messages
95
Motherboard
MSI GS65 8SE
CPU
i7-8750H
Graphics
HD 630, RTX 2060, 1080p
Mobile Phone
iOS
Guys, thank you so much for your work! Working version 10.14 for a fresh MSI laptop is a great find. I also had a question about the backlight of the keyboard. I totally got the clover from annaclets. The backlight worked, but the usb ports did not work in 3.0 mode. I replaced USBInjectAll with USBxhci from my early clover. The situation has changed :) usb work but the backlight is gone.
I would be grateful if you tell me what is my mistake.
I am glad your system is working. During testing I did not run into any USB 3.0 issue, how did you come to the conclusion that the USB 3.0 was not working?
If you want to use your USBxhci kext, you need to modify it for your current system per XHC USB Kext Creation Guideline
 
Joined
Jan 11, 2019
Messages
2
Motherboard
MSI GS75 8SE
CPU
i7-8750H
Graphics
RTX 2060
Mac
MacBook Pro
Classic Mac
Apple
Mobile Phone
iOS
I am glad your system is working. During testing I did not run into any USB 3.0 issue, how did you come to the conclusion that the USB 3.0 was not working?
If you want to use your USBxhci kext, you need to modify it for your current system per XHC USB Kext Creation Guideline
Thanks for the link. It is huge, I will read it readily. I’m not good at manual tuning, and this article will definitely allow me to figure it out better.
Like the skip5050, I first began to collect all the information about the possibility to install the Mac on this laptop model. This forum thread and one article on GS65 is all I could find.
I thought a tuned clover for the GS75 would be a good solution. And so it happened, but usb did not work.
The system does not see hard drives with a connection usb 3.0. With usb 2.0 drives no problem.
After reading a little bit of the article, I begin to think that the port numbers of the SE version laptop (rtx2060) may differ from the high model with rtx2080
 
Joined
Jan 20, 2011
Messages
95
Motherboard
MSI GS65 8SE
CPU
i7-8750H
Graphics
HD 630, RTX 2060, 1080p
Mobile Phone
iOS
Thanks for the link. It is huge, I will read it readily. I’m not good at manual tuning, and this article will definitely allow me to figure it out better.
Like the skip5050, I first began to collect all the information about the possibility to install the Mac on this laptop model. This forum thread and one article on GS65 is all I could find.
I thought a tuned clover for the GS75 would be a good solution. And so it happened, but usb did not work.
The system does not see hard drives with a connection usb 3.0. With usb 2.0 drives no problem.
After reading a little bit of the article, I begin to think that the port numbers of the SE version laptop (rtx2060) may differ from the high model with rtx2080
Another option is to follow the Creating a custom ssdt for usbinjectall guide. In order to determine your working USB ports and create a working ssdt. Remember to remove the uia-ssdt from your clover patched folder and reboot before starting the procedure.
 
Joined
May 6, 2019
Messages
13
Motherboard
MSI GS75 9SG
CPU
i7-9750H
Graphics
RTX 2080 Max-Q
Mac
MacBook Air, MacBook Pro, Mac mini
Mobile Phone
Android, iOS
Guys, thank you so much for your work! Working version 10.14 for a fresh MSI laptop is a great find. I also had a question about the backlight of the keyboard. I totally got the clover from annaclets. The backlight worked, but the usb ports did not work in 3.0 mode. I replaced USBInjectAll with USBxhci from my early clover. The situation has changed :) usb work but the backlight is gone.
I would be grateful if you tell me what is my mistake.
Just a thought - your laptop specs may be more similar to itech's than mine - have you tried using his Clover setup, specifically his SSDT-UIAC-ALL.aml, from post #10 of this thread?
 
Top