<< Solved >> Mojave Installation Fails on Skylake Computer

Mar 2, 2014
Gigabyte Z390 I AORUS PRO WIFI
RX 580
  1. MacBook Air
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
My "Mini-ITX 2" Skylake computer (listed below) is running Monterey 12.6.3. I have two 1 TB SATA drives. I want to downgrade this computer to run Mojave 10.14.6. I have made a Kingston Traveler USB 2 flash drive Mojave installer using Apple's "createinstallmedia" tool. I have repeated this procedure 3 times. Once from my computer at left (running Mojave 10.14.6), once from my "Mini-ITX 1" High Sierra computer, and finally from the "Mini-ITX 2" Monterey computer. Every time I try an installation on the Monterey computer by trying to boot the Install macOS Mojave USB drive, I get an Apple icon for about 15 seconds, then a progress bar that just barely lights up the far left-hand edge, then the computer restarts. The installer boots properly on my Mini-ITX 1 High Sierra computer, and on my Mini-ITX 4 Mojave computer, but will not boot on the Skylake Mini-ITX 2 (Monterey) computer. This has happened for every iteration of making this installer. Disk Utility First Aid on all my computers says the installer is good.

It's difficult to cover here all the things I have tried, but it seems that the installer works everywhere except on the Monterey computer. If I erase one of the SSDs, leave the other connected (on Monterey) with the Installer flash drive plugged in, I get the OpenCore window with the installer icon and can try to boot on it, with the result above. In that case, it seems like the installer tries to boot, but something or other "times out" in about 20 seconds and restarts. With the installer plugged in, If I leave the erased SSD connected but disconnect the Monterey SSD, I don't even get the Apple icon, so I can't try to boot from the installer.

Once again, Disk Utility First Aid run on the USB installer from any of my computers always says the installer is good. And the installer boots properly on any computer other than the Mini-ITX 2 computer, which is where I need it to work. And the Mini-ITX 2 computer running on its one Monterey SSD works fine.

This has cost me three days so far, and i'm no farther along. I have tried changing to the IGFX graphics, have removed the AMD RX 560 graphics card, but things just get worse. Best case so far is graphics card in, both SSDs connected (erased one and Monterey working one) which gives the "trying to boot" then restarting scenario.

Would appreciate any advice, thanks!
Among the many random weirdnesses I have experienced in the trek to downgrade Monterey to Mojave, once the USB installer actually did boot, made it to its options screen, and begin installing MacOS Mojave 10.14.6. Unfortunately at 2 minutes to go (according to the progress bar), the installation stopped, and I got an error message that the installer was damaged or corrupt and I should re-download it. I did download a 6.05 GB copy from the App Store (using my "Mini-ItX" 1" computer below), but now the "new" USB installer won't boot again. I'm still getting the beginning of boot: a progress bar with just a hint of brightness at its far left, then restart.
There were un-deletable "Trash" files (invisible) on the USB flash drive, which I got rid of by re-partitioning as MS-DOS/Master Boot Record, "Erasing," and then repartitioning as Mac HFS+ journaled, GUID. That took care of the non-starting Installer booting. So now it boots, and runs the installer, but once again stops at 2 minutes remaining with the same error message about corrupted or incomplete installation. It directs me to re-download the installer, which I already did, and now have that problem again. The installer came from the App Store, stored in my "Mini-ITX 1" Applications folder, and the USB installer was created by Apple's "createinstallmedia" process in Terminal.

Is there another source for Mac OS Mojave 10.14.6 installer that is more reliable?
Finally found a source for Mojave installer that did not fail at "2 minutes remaining." All working now on Mini-ITX 2/Mojave 10.14.6.

That's weird ... there's only ONE source for the Mojave installer pkg.
That's weird ... there's only ONE source for the Mojave installer pkg.
Probably just a coincidence, then, that the two failures I got (at 2 minutes from finishing on each of the two installer downloads from the App Store) didn't happen on the one I got from an online article (which also seemed to link to the App Store). Same exact install procedure on all three attempts, from cradle to grave.

[Edit: A thought... maybe Apple stores more than just one copy of Mojave 10.14.6 on its server(s) at that website, and maybe one is "damaged or incomplete," and I just happened to get that one twice, but not the third time.]
Last edited: