Contribute
Register

Mavericks: Audio - Realtek ALC AppleHDA [Guide]

Joined
Mar 11, 2014
Messages
331
Motherboard
Hackintosh R4
CPU
Intel i7 4770k
Graphics
GTX 770
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Just want to thank Toleda for taking his time to write this guide. My audio wasn't working after an update and your clear and concise instructions were easy to follow and allowed me to fix the issue.

If anyone with similar hardware has the same issue more than happy to help.

Thanks again Toleda! :thumbup:
 
Joined
Nov 28, 2012
Messages
7
Motherboard
Asus Z87I Deluxe
CPU
Core i7 4790K
Graphics
GTX 570 HD
Mac
  1. Mac Pro
Classic Mac
  1. Plus
  2. Power Mac
  3. SE
Mobile Phone
I had a heck of a time getting this to work on my Z87i-Deluxe (LGA1150 using Clover) but with a bunch of testing today I was able to get the following method working:

------


  1. cloverALC/Clover patched AppleHDA
    1. Bootloaders: Clover
    2. Software Update: persistent, no action required
    3. More Info: toleda/audio_CloverALC
    4. Installation - cloverALC (See Note 3)
      1. audio_cloverALC-90_v2.command.zip
      2. Download (View Raw)
      3. Double click Downloads/clover-90_patch_v2.command
      4. Password?
      5. Verify Codec? (885, 887, 888, 889, 892, 898, 1150 only)
      6. Legacy_v100202 - y/n? (887, 888 only)
      7. Restart
      8. Verify ALC onboard audio
        1. System Preferences/Sound/Output/select audio device

(Check the first post of this thread for these instructions)



------

What I had trouble with was the note F located here :

------


F. 1150 only: edit config.plist/KernelAndKextPatches/KextsToPatch/"10.9 or 10.10/AppleHDA/Realtek ALC1150"
  1. Clover Configurator/Property List Editor/Replace/
    • Before: <09ec10>
    • After: <0009ec10>
  2. TextEdit/Replace
    • Before: CewQ
    • After: AAnsEA==

------

What I had not understood was that I needed to find the KextsToPatch that audio_cloverALC-100_v1.0.3.command script had already created (it creates two) and edit the one that has a comment ending in Realtek ALC1150. I had misunderstood and tried to create a new KextToPatch entry.

If your editing in text edit or textwrangler or something like that you use the bottom values (#2). If you are using Clover Configurator use the top values (#1) but without the < and > that are before and after them. (this also confused me)

------

In my case I noticed that an earlyer KextToPatch was taking ixnUEQ== (textedit) or 8B19D411 (clover config) and changing it to CewQ (textedit) or 09ec10 (clover config). The above note says to find CewQ (textedit) or 09ec10 (clover config) and replace it with a new value, so I just skipped the middle man and did the following:

Before: ixnUEQ== (textedit) or 8B19D411 (clover config)
After: AAnsEA== (textedit) or 0009EC10 (clover config)

clover-config.jpg
Clover Config example

textwrangler.jpg
TextWrangler example


----

Now my audio is working great, I even have S/PDIF (Optical Toslink) as an option! Thanks Toleda for all your hard work. And maybe this will help others who like me didn't get what to edit or how (though now that I know, the note makes sense).

 
Joined
Jan 15, 2012
Messages
57
Motherboard
Gigabyte GA-Z370-HD3P
CPU
i7-8700K
Graphics
GTX 1070
What if someone only has AC97 Connector ?
I have only one audio connector in front that too AC97. Will this adaptor work?
AC97 to HD Audio.
 

Attachments

  • IMG_5289__89073_zoom.JPG
    IMG_5289__89073_zoom.JPG
    200.1 KB · Views: 90
Joined
Jan 15, 2012
Messages
57
Motherboard
Gigabyte GA-Z370-HD3P
CPU
i7-8700K
Graphics
GTX 1070
Ok got it! So no use of buying it.
 
Top